Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: “Weak Security” Wifi after iOS 14 update

Since updating to the newest iOS 14, my WiFi connection has an alert of “Weak Security”. I’ve called both my internet/service provider and both show on their end the system is registering correctly. Upon reading more, apparently the newest iOS creates a new MAC address that may not be recognized on the modem you use, causing a “Weak Security” notice? My wifi connection on my phone is slower than if I were disconnected from it.


All my other devices work on my wifi.


Any suggestions on how to get rid of this?




[Re-Titled by Moderator]

iPhone XR, iOS 14

Posted on Sep 20, 2020 10:12 AM

Reply
Question marked as Solved
Answer:
Answer:

It worked! Thank you!

Posted on Sep 20, 2020 11:25 AM

Question marked as Helpful

Sep 28, 2020 2:31 PM in response to _t_r-e In response to _t_r-e

_t_r-e wrote:

You need to check your router security setting to make sure it’s WPA2 (AES). It is the latest security protocol. If you’re not sure how to do that, call your internet provider and ask what it currently is, and have them change it if not.

Just to be clear, if your router is not set to WPA2 (AES) or WPA3 it has ALWAYS been insecure; you just didn’t know it was insecure until iOS 14 checked it.

Sep 28, 2020 2:31 PM

Question marked as Helpful

Sep 23, 2020 1:14 PM in response to _t_r-e In response to _t_r-e

yes, me too - after the ios 14update I got WEAK SECURITY - someone said "It worked, thank you" but didn't say what they did to get it to work. I am a senior and do not know technical stuff. Can someone PLEASE walk me through on how to fix this. Thank you so very, very much.

Sep 23, 2020 1:14 PM

Question marked as Helpful

Sep 21, 2020 10:44 AM in response to QuickTimeKirk In response to QuickTimeKirk

On Xfinity we you dont jave have access to WPA2 AES. Its already chosen for you and you cannot change it unless its on the Xfi app. On the you can choose WPA2 or open. Whos choosing open idk? But yea the router is set to WPA2 AES and still weak security.

Sep 21, 2020 10:44 AM

Question marked as Helpful

Sep 24, 2020 3:05 PM in response to _t_r-e In response to _t_r-e

_t_r_e

Thank you for your response to CrochetGal. I, too, have a "Weak Security" message on my iPhone 8 so I checked my Netgear router and it's confirming I have WPA2-PSK (AES) security enabled. Should this be sufficient security to eliminate the message? Like CrochetGal, I'm a senior and this stuff is not second nature to me - or even third nature for that matter. Thanks.

Sep 24, 2020 3:05 PM

Question marked as Helpful

Sep 23, 2020 1:35 PM in response to CrochetGal In response to CrochetGal

You need to check your router security setting to make sure it’s WPA2 (AES). It is the latest security protocol. If you’re not sure how to do that, call your internet provider and ask what it currently is, and have them change it if not.


If Comcast is your internet provider, they have an App (xFi) where you can check this setting.


Sep 23, 2020 1:35 PM

There’s more to the conversation

Read all replies
Question marked as Helpful

Sep 21, 2020 10:44 AM in response to QuickTimeKirk In response to QuickTimeKirk

On Xfinity we you dont jave have access to WPA2 AES. Its already chosen for you and you cannot change it unless its on the Xfi app. On the you can choose WPA2 or open. Whos choosing open idk? But yea the router is set to WPA2 AES and still weak security.

Sep 21, 2020 10:44 AM

Reply Helpful (10)
Question marked as Helpful

Sep 23, 2020 1:14 PM in response to _t_r-e In response to _t_r-e

yes, me too - after the ios 14update I got WEAK SECURITY - someone said "It worked, thank you" but didn't say what they did to get it to work. I am a senior and do not know technical stuff. Can someone PLEASE walk me through on how to fix this. Thank you so very, very much.

Sep 23, 2020 1:14 PM

Reply Helpful (32)
Question marked as Helpful

Sep 23, 2020 1:35 PM in response to CrochetGal In response to CrochetGal

You need to check your router security setting to make sure it’s WPA2 (AES). It is the latest security protocol. If you’re not sure how to do that, call your internet provider and ask what it currently is, and have them change it if not.


If Comcast is your internet provider, they have an App (xFi) where you can check this setting.


Sep 23, 2020 1:35 PM

Reply Helpful (5)
Question marked as Helpful

Sep 24, 2020 3:05 PM in response to _t_r-e In response to _t_r-e

_t_r_e

Thank you for your response to CrochetGal. I, too, have a "Weak Security" message on my iPhone 8 so I checked my Netgear router and it's confirming I have WPA2-PSK (AES) security enabled. Should this be sufficient security to eliminate the message? Like CrochetGal, I'm a senior and this stuff is not second nature to me - or even third nature for that matter. Thanks.

Sep 24, 2020 3:05 PM

Reply Helpful (9)

Sep 24, 2020 3:58 PM in response to rfstaplesjr In response to rfstaplesjr

The only two I know for sure to work are the ones I listed. If you’ve tried something else and you still have the message, I would guess they don’t work.


Once I changed to WPA2 (AES), the message went away immediately.

Sep 24, 2020 3:58 PM

Reply Helpful
Question marked as Helpful

Sep 28, 2020 2:31 PM in response to _t_r-e In response to _t_r-e

_t_r-e wrote:

You need to check your router security setting to make sure it’s WPA2 (AES). It is the latest security protocol. If you’re not sure how to do that, call your internet provider and ask what it currently is, and have them change it if not.

Just to be clear, if your router is not set to WPA2 (AES) or WPA3 it has ALWAYS been insecure; you just didn’t know it was insecure until iOS 14 checked it.

Sep 28, 2020 2:31 PM

Reply Helpful (11)
User profile for user: _t_r-e

Question: “Weak Security” Wifi after iOS 14 update