Previous 1 2 3 Next 87 Replies Latest reply: May 7, 2015 4:31 AM by kjon2518
RussyPlum Level 1 (0 points)
This message comes up every time I try to log in to my bank, ebay, paypal, vodafone, hotmail, etc. Basically everything I try to log into. It tells me the certificate is invalid, or the issuer is invalid. This just started one day a little while ago. I have all these pages bookmarked and safari used to be fine with them. I downloaded firefox to see if it was just a safari thing, and it did not have this problem. Can someone please tell me how to fix this with safari? Version 5.0.1

MacBook Pro, Mac OS X (10.6.4)
  • Carolyn Samit Level 10 (103,365 points)
    HI and welcome to Apple Discussions....

    From the Safari Menu Bar click Safari/Reset Safari. Select all the boxes. Then from the Menu Bar click Safari/Quit Safari.

    Now relaunch Safari. Try logging into one of those sites.

    If that didn't help, try troubleshooting the Safari .plist file.

    Open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder then the Preferences folder. Move the file from the Preferences folder to the Desktop. Now launch Safari. Navigate to a site that normally has a signed certificate like your bank. If you can do this without the invalid certificate dialog, move that .plist file to the Trash.

  • RussyPlum Level 1 (0 points)
    Thanks for your reply.
    I tried these suggestions, and unfortunately they have not solved the problem.
    I may just have to use firefox.
  • Carolyn Samit Level 10 (103,365 points)

    Try something else. From your Safari Menu Bar click Safari/Preferences then select the Security tab.
    Click: Show Cookies. Delete all the cookies for the sites you have problems with certificates.

    Now relaunch Safari and try one of those sites.

    *Delete one of the sites you had Bookmarked prior to the Safari update.* Then navigate to that site. See if you there's a verification issue. If not, then just add that site to your Bookmarks. Same for the rest.

  • dbsneddon Level 4 (1,525 points)
    Is the date and time correctly set on your machine?

  • RussyPlum Level 1 (0 points)
    Yes, it is correct. I really tried to find an answer before posting this question, and just couldn't. But that did solve the problem for a lot of people. Thanks anyway Dave.
  • RussyPlum Level 1 (0 points)
    Thanks for trying to help again Carolyn.
    I deleted cookies and bookmarks, but it made no difference.
    Perhaps it is actually my computer?
  • wayne mitzner Level 2 (400 points)
    i've got the same problem. in fact even the website login is untrusted by my Safari!!!
    I've reset Safari, deleted both Safari.plist files, and restarted. Still get the same "can't verify, etc:" popup box. Could this be a computer issue? It make Safari unusable.
    Thanks for any help.
  • wayne mitzner Level 2 (400 points)
    Well this is a first, since i'm responding to my own post, having located the source of the problem. This verification issue was a result of the computer date being set wrong. Somehow, the automatic date box became unchecked, and this led to the verification problems. When the automatic date box was checked, the problem disappeared!
  • ~Bee Level 7 (31,425 points)
    Wow, Wayne . . .
    How nice of you to come back and share your solution with us!
    That's one, I have to admit, I would not have thought of!
  • autochthon Level 1 (115 points)
    I have the same issue. Aren't sites supposed to provide current security certificates from a known issuing authority, so that companies like Apple can 'push' updated security certificates via Software Update? In the case of CitiBank, they recently re-vamped their credit cards page and now when I use the "" URL on my credit card, I get the message, "Safari can't verify the identity of the website, "" - The certificate has been signed by an unknown certifying authority...this website may be pretending to be...." , etc.

    This is a show-stopper for me, for sure: I can't afford to have such questions raised when visiting my credit card account site!!!

    I have wondered if this issue is caused by sloppy webmaster practices, where they just don't bother to update their security certificates after making changes to website structures.

    Whatever the cause, it defeats the entire purpose of secure online banking.

    Another thing I've noticed (though this is off-topic, since it's about Firefox): On one of my Macs, Firefox's preferences\security tab allows me to check a box to 'tell me if a site I'm visiting is a suspected forgery'. On another one of my macs, this same box is mysteriously greyed out. How's the average user supposed to know if this is the result of some hacker compromising their browser?
  • DanT3HMan Level 1 (0 points)
    I'm having this same problem except its my iPhone not my computer..What can I do in order for this message to go away? It keeps saying:

    Cannot verify server identity..Safari cannot verify the identity of u like to continue? Everytime I go to facebook..Sometimes, it doesn't say that, ONLY when it has that "Lock" logo next to the web browser..I don't know why there are times the logo isn't there and most of the times, no lock logo..This NEVER happened before. What can I do to fix it?? Someone PLEASE help..
  • ronchicago2 Level 1 (0 points)

    I havwe begun to get the same message on my new iPad 2. Have cleared out cache, cookoes, history but did not help.  My date is set. Is this becvause I have not given Safari location permision??

  • wiscgirl Level 1 (0 points)

    Okay - I have this same problem. It's not a certificate in the keychain, because I don't have one for Facebook.


    It persists after I reset safari, delete cookies, download the newest safari update, etc.


    My computer has the correct date and time.


    I even set safari preferences to "autofill user names and password" on someone's suggestion, and it did not work.


    The problem is one with the safari program, plain and simple. Apple needs to fix it and send out a patch.

  • jeanettefromgilbert Level 1 (0 points)

    I had the same issues and tried the same solutions as Wayne.  Like Wayne, the automatic date box became unchecked. When the automatic date box was checked, the problem disappeared!



Previous 1 2 3 Next