Previous 1 2 3 4 Next 87 Replies Latest reply: May 7, 2015 4:31 AM by kjon2518 Go to original post
  • cheong.andrew Level 1 Level 1 (0 points)

    Hi, I just had the same problem after my Mac shutdown due to an empty battery. When i charged and power-up, the date was set to 1 Jan 2000. I then manually set the time and this problem came. After rechecking the automatic date box, the problem went away. Hope the extra bit of info helps the next person. Thanks everyone for sharing this.....really got me sweating for a while.

    Andrew Cheong

  • Alan Templeton Level 1 Level 1 (35 points)

    I have been having the same problems for the last couple of months.  Even iTunes gives me an error message saying it doesn't trust Apple's own site.


    An apple salesperson suggested repairing permissions.  That isn't the issue.


    I thought it was me until I helped a friend last night who complained of the same thing.


    The warning is now useless since I always ignore it now.

  • gabrielpaipa Level 1 Level 1 (0 points)

    Date change solved my issue as well. Thanks!

  • K4TAY Level 1 Level 1 (0 points)

    I am having the same issue but the Date/Time fix is NOT working for me.  I have uninstalled all extensions, reset all data, removed the .plist files for Safari and going to PayPal gives me the warnings not the mention taking me to an unstyled PayPal home page (No CSS) if I accept the certificate.


    anyone else have any other ideas?

  • Muckwizard Level 1 Level 1 (0 points)

    I've tried all suggestions..  When I choose to continue it tells me access denied. for many sites, not just facebook..  What is the issue here??  Why suddenly did this occur??

  • Alan Templeton Level 1 Level 1 (35 points)

    The problem for me turned out to be in the Keychain preferences.  Try the following:


    Open Keychain Access ( Applications - Utilities - Keychain Access).


    Open the Keychain preferences (Keychain Access (in upper left corner) - Preferences).


    Select the Certificates tab.


    Set the following options:

    Online Certificate Status Protocol (OCSP):  Require if Cert Indicates

    Certificate Revocation List (CRL): Require if Cert Indicates

    Priority:  OCSP


    If these options are greyed out, hold the Option key at the same time as opening the options.

  • Fireguyy Level 1 Level 1 (0 points)

    I'm having the same problem too, keychain preferences didnt work for me, nor did the time which is correct. This just started in the last day or two.

  • Muckwizard Level 1 Level 1 (0 points)

    I did this, but now it just tells me access denied..  gah what the HECK is going on here???

  • moley2 Level 1 Level 1 (0 points)

    Having same problem with Any fix yet?? I've tried all the other fixes with no change.

  • ChelsiW Level 1 Level 1 (0 points)

    I've been having the same problem for about four to six months, although on my computer it's every website on EVERY browser I try, from Firefox to Chrome. I have visited the Apple store twice, they weren't really understanding my problem somehow and have sent me home both times telling me that it's fixed. My problem began happening shortly after my computer quit connecting to my home internet because it had a self-assigned IP address. At that point, I could connect elsewhere, but ANY website I have to fill in a user login and password would just reload automatically to the blank sign-in page. When I reset the ip address, that problem went away with some websites, such as tumblr and my school's student email, but got worse for others (when I try to log into Facebook or Amazon now, it reloads to a text-only view of those websites). In addition to this problem, my software updates will no longer install, and neither will software I attempt to install myself, such as for my printer.


    It seems to me that my problem is worsening. I have tried all of the options listed above, as have the employees at my local Genius Bar. I know that Mac's aren't supposed to have viruses or malware or etc, but this definitely seems to be something of that variety. At this point I'm ready to wipe my hard drive and start over...which would be a lot easier if my external would connect to this diseased computer or my TimeMachine was working properly, which it has not been doing lately.

  • Muckwizard Level 1 Level 1 (0 points)

    Do you thinkn it could be some sort of malware??  Maybe someone got it figured out??  It seems like it now happening worse than it was..  While I have not noticed any other issues aside from websites that I need to log into seem to have weird certificates.  For example face book, when it prompts me that it cant verify the certificate it claims that it does not match.  When I look at the certificate, its a gamestop cert...  I dont know why.  Now usually if I click continue it says access denied.  And I have to reset safari in order to get back on.  Now, it seems it brings me to the same page and all it says is 'success' and then I can re-enter facebook into the navigation bar and be on my way.


    This seems strange to me, and I was wondering if someone was accessing my computer, (like I had some sort of virus or whatnot)  so I tried to track the traffic in and out of my computer, using little snitch and I didn't see anything out of the ordinary.  Has Mac released any information?  Has anyone found *** is happening?? It is not quite as big a problem as you (chelsiW) but I fear it may escalate to that point..

  • stosto Level 1 Level 1 (0 points)

    I've struggled with this for about 1 hour today and found a solution that worked for me.


    The problem in my case was caused by a certificate under the "login" keychain that contained a private key for my apple id and the name of the certificate looked like this :


    Here is the solution that did the trick for me :


    Open Keychain Access, select "login" keychain and filter on certificates.

    Select all certificates and export them to a file on disk to have a backup.


    Now you have 2 options to identify the certificate causing the problem:

    1. Delete the certificates one by one and after each deletion try to open the page in Safari (I suggest to restart Safari after each deletion).


    2. Delete all certificates, restart Safari and try to open the page in Safari. If it works, you may have to import the certificates you exported and follow option 1 to identify the certificate that is causing the problem.


    HTH, good luck !


    MacBook Pro 15'', Mac OS X 10.7.2 (Lion), Safari 5.1.2

  • Muckwizard Level 1 Level 1 (0 points)

    I just wish a professional would read this forum and post that they may be working on identifying the problem.  It has started only recently and it may not even be just a mac issue.  Has anyone read or heard about anything like this on a windows OS?

  • sister mary constance Level 1 Level 1 (0 points)

    Oh, so glad someone finally asked this on this post. Yes, Safari seems to have this problem no matter where you use it. I am frankly sick and tired of constantly resetting Safari, emptying caches, restarting, etc., etc., I didn't see anyone mentioning that usually it's looking for a certificate that doesn't even apply to the page you are loading - is there one. I usually get the following:


    Safari can't verify the identity of the website


    The certificate for this ebsite is invalid. Your might be connecting to a website that is pretending to be "", which could put your confidential information at risk. Would you like to connect to the website anyway?


    So - is that pretty much it verbatim for the rest of you? Apple techs???? Helllllooooo??? Are you listening? Or is this why your stock is tumbling back down the hill, Jack? I have looked everywhere on my computers for viruses, malware and none seems to be there. So, why is Safari doing this and why isn't it fixed by now?


    Don't let the "genius" techs snowball you - they don't get that much training - a lot of turnover. How do I know? I worked there. This is shameful of Apple to ignore this problem so long. Steve must be turning over.

  • sister mary constance Level 1 Level 1 (0 points)

    I will be trying your suggestion Alan, however I am worried about leaving the Keychain open or accessible from outside. Why are the webpages asking for certificate verification for webpages other than the one I am trying to access? Do you have any ideas/input on that. Remember this isn't just a "mac" thing - I've had the same thing happen on my iPhone and my HP laptop. Yours seemed the most "techie" of the responses. Even though the other ideas of resetting, etc. work - it's always temporary and soon you will be back to missing images - request for certificate verificaiton, invalid website response (even though the very next time the page will load just fine).

Previous 1 2 3 4 Next