Previous 1 8 9 10 11 12 13 Next 186 Replies Latest reply: Aug 2, 2015 7:05 AM by Janice Fisher Go to original post
  • l u Level 1 Level 1 (0 points)

    Had 133 Phantom  "unread" emails.


    This was all I did to remove the incorrect notification bubble:



    Settings >  Mail, Contacts and Calenders


    Go to the account that the unread emails are supposedly from - tap on it - in the account info there will be a toggle switch to turn the account off -- do so - then hit "done" at the top.


    Turn off the phone.


    Turn it back on.


    Go back and turn the mail account on again.


    Phantom mail gone.

  • l u Level 1 Level 1 (0 points)



    There are two types of mail accounts: IMAP and POP3


    From my understanding of POP3 accounts they do not communicate the tag that a mail item is read.


    In other words.. your mail is on the yahoo server, if you go and look at it at yahoo and read through the mail it never will tell your phone, ipad, or anything else that this mail is "READ".


    On the other hand when you open your mail account on an iphone or android or anything else for a POP3 type of account the DEVICE will remember what you have read and haven't because it was read on the device itself.  (these mails in the case of pop3 accounts are actually COPIES of your mail and not the actual mail).


    So... then later on down the road you install a major update.  Since neither the yahoo servers nor the iphone communicates to the server that POP3 mail has been "read", when you re-add the account you will have all "unread" mail again.


    I tried to explain that in simple terms.. but the simple point is - It's the nature of a pop3 account.  (I'm not speaking of the "phantom mail" error, I'm speaking specifically of the situation where you re-add your account in a major upgrade and the mail is remarked as "unread").


    It's how POP3 email functions.  So, this would be why Apple hasn't addressed it.. because that particular behavior is expected and not related to the device.

  • l u Level 1 Level 1 (0 points)



    There should be no reason to have to reinstall your apps after an update.


    I know it happens to people.. but it's completely unnecessary.


    Before doing any major update you should do a backup, icloud backs up automatically every 24 hours or if you connect to itunes and back up that way it backs up every time it syncs.. BUT what doesn't necessarily happen automatically, and the step that people forget to do when backing up to the computer is to make sure to TRANSFER PURCHASES.  The option is under FILE > DEVICES > TRANSFER PURCHASES.


    You see, the device backs up every time you connect to itunes and sync (if you aren't set to backup to icloud) but it doesn't put apps / music / videos purchased from itunes into the backup.. that would be an incredible waste of space.  Those are stored in itunes itself and they all have to be there when you restore a backup to get them back.


    As long as every app / song / etc that you purchased is in your itunes library then you will get every one of them back..

  • neil136 Level 1 Level 1 (0 points)

    Gmail fix:

    I tried all the fixes here for an identical issue with my gmail account, but kept being left with 26,000+ allegedly unread emails on the iphone 5 after upgrading....

    Now, it seems to be OK after the following routine, done on my PC (NB not sure how applicable this is to other email accounts)


    1. (very important) - click on All Mail from the gmail menu on the left hand side of the screen (if you can't see this, it'll be revealed be selecting 'More' from the menu list).  (It would appear that the emails that the iphone is referring to are not, in fact, just the ones in the inbox..... )

    2. Click the 'down' arrow on the right hand end of the gmail search box (it's just by the blue button with the magnifying glass)

    3. In the 'Doesn't Have' field in the Search menu, enter some gobbledygook - like "asgjihg567vfd" - something that you are certain will not be in any email.  That means that all of the mail, including long-term deleted mail (not just the stuff that appears to figure in your bin), will get selected

    4.  In the left hand of the three grey boxes above the emails (the one with the square on it), select 'All'

    5. You will see on the bar above the emails that a message comes up saying - "All 20 conversations on this page are selected. Select all conversations that match this search".  Click on this to select, literally, all your emails - past, present, binned, spam, etc.

    6. From the right hand control box above the emails (the one saying 'More'), select 'Mark as read'.   This will take a few moments, but will work through them all.

    7.  When you go into the gmail account on your phone, you should see the unread email count miraculously disappear when it syncs. 


    This has worked for me and I hope it stays this way!   The trick is that you may have lots of unread emails that you binned ages ago - but these have been resurrected through the miracle that is iOS7.


    FWIW, I very much regret upgrading to iOS7 and have written to Tim Cook telling him that it's going to lose him customers - not that I expect that he will see my mail, or answer, or that he cares.......

  • jdb901 Level 1 Level 1 (0 points)

    I did the following as my yahoo and live accounts recently changed to IMAP on my iPhone 4 IOS 7.0.3 operating system. Deleted the oldd accounts on the phone and re-set as IMAP. Then did the same on my Outlook but also ticked the purge email after viewing in the Advanced Settings. This then cleared the bloody lot and I've not had a problem since........

  • haphazardly Level 1 Level 1 (0 points)

    G-mail user:

    Fixed my issue, but I only had 1 phantom unread mail. 


    I was having no luck with the select all -> unread -> read method.  But when I turned the device off, (iPhone 5 latest rev.) to clear the RAM and cache, I repeated the method.  Went into the mail app and retried it. 


    A mail from a few days ago popped up as unread.  So it fixed itself.  I'm OCD about notification badges on my screen, it gives me anxiety when I see one.  So even if I don't read the mail thoroughly, I still like to mark it as read. 


    Hope this might help some. 

  • Janine2013 Level 1 Level 1 (0 points)

    Many thanks gumdoc2.  Tried all the previous suggestions and then yours and it worked a treat!!

  • Bubblehead7 Level 1 Level 1 (0 points)

    Worked perfectly! Thanks!

  • kerribw Level 1 Level 1 (0 points)

    I was able to fix my gmail problem quickly with these tips:


    Select the mail folder (sent, trash, etc) & go to Edit, Select All

    Then go to Message, Mark, As Read


    This removed all the emails that were showing as Unread.

  • Zakhanz Level 1 Level 1 (0 points)

    This is what i did to resolve the unread emails in yahoo

    Go to mails > Accounts > select Yahoo account > select inbox > from top right hand corner > select Edit > from left hand bottom corner > select mark all as un read > wait few seconds then mark all as read. Then exit out the edit settings. It should resolve the issue .


    This worked for me.

  • prahas777 Level 1 Level 1 (0 points)

    @krtrice -- excellect description!  My problem:  the unread message was deleted, and then the trash was emptied!  So I can't un-delete it, to read it, to then reset it on both devices...  Any thoughts?

  • prahas777 Level 1 Level 1 (0 points)

    To be more clear -- the message was deleted and trash emptied on a computer by another user

    of the same account.  I've tried 8 of the solutions proposed in this thread, and none work.



  • prahas777 Level 1 Level 1 (0 points)

    After a while (perhaps because the email account received new emails after doing the 8 suggestions!) the phantom red dot disappeared.  I can relax again!!!!

  • mrnissan Level 1 Level 1 (0 points)

    I think I may have a suggestion Ive just had the same issue with a yahoo account, what I did was send myself a email,

    1) goto email in question dont open it just go to edit then mark all as read.

    2) goto to same email again and the set to mark all as unread.

    3) then goto email again and edit mark all as read.


    That worked for me and cleared the ghost email.

  • akirish Level 1 Level 1 (0 points)

    This worked for me!