1 2 3 4 5 6 7 Previous Next 94 Replies Latest reply: May 8, 2012 6:20 AM by lizcon76 Go to original post
  • 45. Re: Apps will not download
    FlyingChops Level 1 Level 1 (0 points)
    We tried my husband's Apple ID on my Mac Pro. Same thing. Downloads just hang in the 'waiting' phase in my dock.
  • 46. Re: Apps will not download
    jstuber Level 1 Level 1 (0 points)
    Followed all of your suggestions and still stuck in "install' limbo. Started yesterday,1/6. Don't even have the "waiting" message today. Incessantly spinning gear is it.(credit card info is current).
  • 47. Re: Apps will not download
    Dave Douglas1 Level 1 Level 1 (15 points)
    Finally got to try and use a second computer and the exact same issue occurs. This is clearly an issue with our accounts and not our Macs.
  • 48. Re: Apps will not download
    Casey Tourangeau Level 1 Level 1 (0 points)
    Mine account works fine on one computer but not the other, so it's not an issue with my account.
  • 49. Re: Apps will not download
    daveoran Level 1 Level 1 (10 points)
    Here's another user with the same problem. Perhaps the following info will help:

    - My main machine is a MacbookPro with mulitple interfaces active (Ethernet w/ three VLANs + Airport)
    - A second machine is a Mac Mini with one ethernet (airport is off) but also multiple VLANS.
    - All apps I purchased got either stuck in "waiting", or went into "downloading" but never downloaded a single byte.
    - killin the app store application, and/or the storeagent and restarting didn't help.
    - Rebooting didn't help


    However, if I turned off the Ethernet on my MacbookPro and disabled the VLANS, and just connected through the Airport. the apps then downloaded.

    However, disabling all but one of the VLANs on the Mac Mini didn't help.

    Perhaps it's people with multiple active interfaces who are experiencing this bug?
  • 50. Re: Apps will not download
    DYippy Level 1 Level 1 (0 points)
    Try logging out your account and re sign in your account. It work for me.
  • 51. Re: Apps will not download
    darious1472 Level 1 Level 1 (5 points)
    That fixed it. I've just turned off my bonded network links (Link aggregation in network preferences) to switch to a single network connection and bang, downloading fine.

    Looks like a definite bug is the software that Apple need to fix. I'll run on a single cable for now until they do.
  • 52. Re: Apps will not download
    Casey Tourangeau Level 1 Level 1 (0 points)
    I just unplugged my teamed Ethernet cables and went Airport only and - Boom! - it's working.

    So yeah, definitely a bug in the SW related to networking.
  • 53. Re: Apps will not download
    M&C Level 1 Level 1 (15 points)
    Got my downloads working finally! I didn't mess with my network connection, but just logged out of the Mac App Store on one Mac and then logged in on just one Mac and it started working. Then I did the reverse and got the downloads working on the other Mac.

    I did try this yesterday and this morning with no luck, so perhaps Apple have been tweaking things at their end in the meantime.

    It seems having two Macs logged in on the Mac App Store at the same time was the issue for me anyhow.
  • 54. Re: Apps will not download
    FlyingChops Level 1 Level 1 (0 points)
    Fixed for me too. Well, a band-aid, not a true fix.
    Switched from Ethernet to Wireless and it started working. Not going to work as a permanent solution for me, so I hope Apple fixes this quickly.
  • 55. Re: Apps will not download
    RamaSod Level 1 Level 1 (0 points)
    I took the suggestion to unmount my BOOTCAMP partition using Disk Utility and then restart the Mac App Store.
    I was able to successfully choose and install apps after that was done.
  • 56. Re: Apps will not download
    Ron Frederick Level 1 Level 1 (0 points)
    I've been having this problem since yesterday on my Mac Pro, and I can confirm that the problem for me was due to having multiple network interfaces. I had a private subnet on Ethernet 1 and an alternate VLAN on Ethernet 1 which had a public static IP that I usually used to go to the Internet. I also had Ethernet 2 set up as a self-assigned IP to talk to a Drobo using iSCSI. The downloads wouldn't work at all until I disabled my public VLAN and Ethernet 2, so I had only the native Ethernet 1 interface left. As soon as I did that, the downloads began working (after my private IP was NAT'd by my router to get out to the Internet).

    While I've been able to get a few apps downloaded this way, I'm not about to go shutting off the rest of my network and unmounting my Drobo every time I want to use this. I really hope Apple is able to fix it soon... I appreciate the hints in this thread that let me get this far, though!

    Message was edited by: Ron Frederick
  • 57. Re: Apps will not download
    matthewmiller1234 Level 1 Level 1 (0 points)
    Well you guys have to remember this is a version 1.0 product. Maybe either 10.6.7 will fix some problems or we may have to wait all summer for Lion.
  • 58. Re: Apps will not download
    Dave Douglas1 Level 1 Level 1 (15 points)
    I am happy to report after e-mailing Apple about my AppleID not working all of sudden I am now able to download and install apps! No e-mail from Apple stating that they did anything but I am a happy camper.
  • 59. Re: Apps will not download
    Bryan Prazen Level 1 Level 1 (15 points)
    The network connection solution did not work for me either. But I do have a minor victory. I created a new user on the same computer (not an administrator) and was able to purchase applications when logged in to my computer as this user. These applications are available to my standard user login. There must be something in my Users Preferences, Cache or other user defined data that is causing the App Store to trip up. I am tempted to start removing things until I find it.