Skip navigation

Cannot Send Mail - the username or password incorrect - help please?

67041 Views 57 Replies Latest reply: Aug 14, 2012 8:37 PM by Toolfan RSS
  • Kellykath Calculating status...
    My daughter is having the same problem on her 3rd generation Ipod Touch. I however am not having any problems on my Iphone 3gs. We are also on sbcglobal.net I hope apple acknowledges this soon.
    Dell, Windows XP
  • cknest Level 1 Level 1 (0 points)
    I think Yahoo was working out a new connection. Now on my iPhone mail, down under Accounts, it showed my 2 Yahoo accounts with the Yahoo logo and the same 2 accounts with no logo. The ones with the Yahoo logo have a different smtp than the old ones that were manually set up (using the smtp addresses supplied by Yahoo, BTW). I think they were making changes so that your iPhone can set up Yahoo accounts automatically and now the accounts were updated.. You know what I mean? Anyway, I went into the settings and saw the NEW ones showed "REQUIRED" under the password and needed to be entered. I put in my password, and it worked. I went to the original accounts and disabled them so that I didn't have the multiple inboxes with the same name, and all is working fine.
    Check your settings again, and check frequently until that Yahoo logo one shows up, and check to see if THAT is the one needing password info. My original ones had the correct info, so that is why I couldn't figure out what the heck was going on. Please let me know if anyone else has seen this.
    iPhone 4, iOS 4
  • wparnett Level 1 Level 1 (0 points)
    I've noticed that if I set up the Yahoo mail account manually - that is select 'other', I can send & receive emails but then there is no access to all my folders.

    If the account is setup by slecting 'Yahoo Mail' when adding the account then all the folders are present and I can receive, but can't send. I did notice, like others, that the last character of my password disappears shortly after it is entered
    iPhone OS 3.0.1
  • TGS1 Calculating status...
    I am a BellSouth/ATT customer, which is the same as yahoo mail. Starting yesterday, I too have been unable to send emails--keep getting the frustrating "user name or password" error. I have done all of the above that others have mentioned, from reinstalling, turning off/on, etc., to no avail!

    Hopefully someone at Yahoo or ATT will get it figured out SOON!
    iPhone 3G, iPhone OS 3.1.3
  • nnk123 Calculating status...
    Exact same situation - unable to send e-mail from my iphone and iPad as of today. Worked fine so far, no issues. i have sbcglobal.net accounts, main and sub-accounts. Same story for all of them. E-mails received, but cannot be sent from iphones/ipad, only from web account. Can smth be wrong with the yahoo server? So far i was unable to get any info, but judging by exchanges at this forum it is a common issue.
    iPhone OS 3.1.3
  • CB_Cyclone Level 1 Level 1 (0 points)
    I got mine working today by deleting the existing mail acct and adding it in again manually as discussed above. Just dont have my folders, but I'll get em.
    Gateway
  • travelkitty70 Calculating status...
    I too am a Bellsouth.net user accessing via my Iphone (1st generation) through Yahoo Mail. No problems for the past 2 years until this AM and I get the same username/password error. After someone commented on their password automatically changing I checked this as well and oddly enough after I enter my password an additional character is added (rather than one subtracted). I too have done what many others have tried. The only way I can send is by setting up an account in the 'others' category but then I cannot access all of my sub-folders, which I desperately need. Who do you call about this? Apple? Yahoo?
  • art_ski_bum Calculating status...
    Yup -- Me too. sbcglobal.net user. Exact same symptoms - Suddenly I can receive but not send email. It looks like the sbcglobal.net smtp server has gotten messed up somehow (?) It sure doesn't look like an Apple problem, since I didn't change anything when this suddenly appeared... Tried all the usual things (rebooted iPhone, re-entered smtp server info) Even tried creating a separate, secondary smtp server on the iPhone using the same info as Outlook uses on my laptop. No luck....

    **** - I hope they (whoever they are - AT&T? Yahoo?) fix this soon!
    Anyone have a fix other than creating an entierly separate mail account (manually) on the iPhone?
    3GS, iPhone OS 3.1.3, sbcglobal.net/yahoo e-mail
  • SBex Level 1 Level 1 (0 points)
    Just to report the same frustration - my two Yahoo accounts cannot send mail from iPhone 3G (on Vodafone) - has been working fine for a year, ceased to be able to send on 28 January. Like others, I have checked all the passwords, deleted and reinstalled the account, and powered off/on.
    I phoned BT and they say it's nothing to do with Yahoo because the accounts work OK from a PC - they had not heard of the problem being widespread. Could it be anything to do with Vodafone?
    S
    Windows 7, PC
  • TheOldBroad Calculating status...
    It's nice to know I'm not alone in my frustration with sending email via sbcglobal from my 3G iPhone.

    Everything has worked perfectly until yesterday when I needed to send an email telling my contract company that I couldn't make it to work. (Yup, in the Midwest and completely snowed in!)

    I had to call and wake my recruiter at 6:30 in the morning.

    I will be watching this discussion closely to see if/when anyone gets a resolution to this problem.
    MacBook Pro
  • moorparkfamily Calculating status...
    We forwarded a link to this thread to Yahoo! Customer Care. If we get a more useful response from them, will post it here. (Though I suspect Yahoo will blame AT&T, who will blame Apple, etc.)

    MEANWHILE, for those of you on sbcglobal, a workaround is to use SAFARI, go to mail.yahoo.com and log in from there. This should be equivalent to working from the website. You should be able to send mail and have access to your folders.

    But this is a patch, not a fix. Clearly, something changed, and someone needs to step up and fix the problem!
    iPhone 3gs, iPhone OS 2.x
  • moorparkfamily Level 1 Level 1 (0 points)
    Incidentally, we had the same problem a few weeks ago with our Google Apps account. That one was easier to "fix" by turning off the gmail SMTP server. It appears that AT&T wants everyone to use their own SMTP server. The problem in this case is that the iphone won't let you turn off the Yahoo! SMTP server for a Yahoo! mail account. And although the iphone supposedly tries the SMTP servers in sequence, it doesn't appear to be actually working that way.

    (Isn't it interesting that we're suddenly having trouble with AT&T just after Verizon announces they'll be selling the iphone?)
    Dell
  • Suela Level 1 Level 1 (0 points)
    Hi All !! Any news on why the Yahoo email isnt working i have the 3gs. I have 4 email accounts. 1 yahoo and 3 gmail. My gmail is working great. Please i need a solution....Anyone. Ive tried deleting and adding. I went under other emails but i really need my folders. Ugh!
    iPhone OS 3.1.3
  • Suela Level 1 Level 1 (0 points)
    in the meantime while Yahoo gets this fixed. i went to the app store and downloaded Yahoo, i can send and receive emails.
    iPhone OS 3.1.3
  • cknest Level 1 Level 1 (0 points)
    BTW, You can turn off any smtp's. And you can select which ones you want your phone to use.

    Double check to see if you suddenly have TWO accounts for the same email address. You will not know unless you go to your Settings and check your mail accounts. If you see your Yahoo email account twice, one will be new and needs the password, one is the original one you set up.
    iOS 4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.