Previous 1 2 3 Next 151 Replies Latest reply: Jan 16, 2016 4:15 AM by Dr. Osman Branched to a new discussion.
KerrBr Level 1 (20 points)
How can I change the (wrong) Apple ID from the password prompting dialogue when I am already signed in Apple Store with my own ID?

More details of my problem:
When I try the Apps' Update-All option in my iPod 4, the password dialogue prompts me with my girlfriend's Apple ID; YET, I AM signed in the Apple Store with MY own Apple ID.
I have already verified my ID under Settings/Store. I have also signed out, signing back in with my Apple ID, just in case. No problems there, for I DO sign in with my own ID ok. The problem is just the prompt dialogue for password, when I try to use the 'Update All' feature it prompts me for password with her ID, not mine.
If I go back to Apps and choose the Categories (or Top25) menu, at the bottom of the page, it shows me signed in (my Apple ID). If I try to update one Apps it will do ok. But if I try to Update All it will prompt me for password using her ID, waiting for me to type in HER password. I cannot change the Apple ID on that dialogue (static). If I use my password, it will return the "wrong password" dialogue.

How can I change the prompt for the Update All? What is going on here that I AM signed in but my iPod prompts me with her ID. My iPod is registered under my Apple ID. I have already tried the Hard reset by pressing Home and Power buttons simultaneously, to no avail. I am also using my own network to go Online. I am also with the latest OS in my iPod and my Mac's iTunes.
Thank you!
PS This problem is not occurring in my iPhone 4 (same account) nor my Macs.

iMac, MacBook, iPhone 4, iPod touch 4, Mac OS X (10.6.5), intel core 2 duo
  • lllaass Level 10 (175,785 points)
    It appears that you have some apps on your iPod that were purchased with your girlfriend's iTunes account. You must be signed into the account that purchased app in order to update apps.
  • KerrBr Level 1 (20 points)
    Thank you for your reply, lllaass, but I do not believe that is the case. All apps in my iPod were downloaded directly (free apps) using my iPod and my account.
    Thanks again.
  • KerrBr Level 1 (20 points)
    Forgot to mention: This request for password showing her ID only happens if I try to use the UPDATE ALL link. If I click to update only one apps, individually, the dialogue shows my ID requesting password.
    I did 8 out of 10 updates so far (one by one). Left a couple behind as a reference to this issue, but if no answers surface, I will finish them all individually.
    This is rather strange.
  • kas1 Level 1 (20 points)
    I am having the exact same problem with my iphone.
    I was trying to change my apple id which was an old email that Ino longer have.
    I changed it but accidentally it typed in the wrong ending .net instead of .com.
    I have finally been able to change my apple id in my itunes and in my iphone under the shopping setting.
    but unable to change it in my updates for apps. It's really frustrating as the old wrong id keeps showing up and it does not exist!

    I would love to know how to fix this.
  • FishComputer Level 4 (1,035 points)
    try doing a settings restore
  • Mr86p Level 1 (50 points)
    have u tryed clearing ur cache?

    Message was edited by: Mr86p
  • rmavery Level 1 (0 points)
    Under "Settings" go to "Store" and tap the current "Apple ID" then just log in with the new one.
  • Stairhopper Level 1 (15 points)

    I seem to have the same problem. I tried to update Awesome Note and some other applications but it prompted my for my old Apple ID password. I entered the password and it returned the message:
    'This discounted price is only available to customers who own a previous version of this item. To purchase this item at the full price, click Buy.'
    I am logged in with my most recent Apple ID which I have purchased almost all of my apps on so I don't know why it continues to prompt me with the wrong address. I have tried restarting, resetting, restoring and deleting and re-downloading some apps but whenever a new update occurs it still refuses to recognize the account from which it was purchased. The problem seems to have started since I upgraded to iOS 4.3.1. Updating applications worked fine before and since this is the first time I have tried to update since I upgraded I believe, and correct me if I'm wrong, the problem lies within the firmware.

    Any help on this matter would be appreciated since I usually update applications through the iPod, not iTunes,

    Update: It now seems that the problem has spread to downloading apps also. I tried manually downloading Awesome Note again but it still prompts me for the wrong password of the account on which I have not purchased most applications.



    Message was edited by: Stairhopper
  • WizGnomeX Level 1 (0 points)



    I have noticed exactly the same problem and have not been able to solve it.


    Whatever account that I am looged into, when I try to do an update it prompts for the password and logs into the first account.


    One thing I have not tried, is changing accounts on my MAC and syncing when logged in with that ID (I am away from home at the moment so I can't try it).

  • mchelb17 Level 1 (0 points)

    Hello -


    I had the same problem. Whenever I hit "update all", my old apple ID pops up for which Apple cannot find a password. I updated each and every app separately and all of them updated without prompting for a password. Weird.

  • janay21 Level 1 (0 points)

    So have u ever had a concrete answer yet? Because when I try updating one at a time it still dosent work.

  • marieofromania Level 1 (0 points)

    rmavery nailed it (above). Changing the settings in your iPhone itself will solve the problem.

  • andy.dickens Level 1 (0 points)

    Does not work for me. (My iPhone is not jailbroken.)


    I downloaded a paid app "Imray Marine Rules and Signals v1.5" in the USA with my original account (Account1) then moved countries and needed to create a new Apple account (Account2). If I get 'Info' for the app, it is registered to Account1.


    A new version 1.6 of the Imray app has now been released.


    I have set up only Account1 on the iphone (settings - App Store) and both Account1 and Account2 in iTunes on my computer. My iphone always tells me there is 1 app to update. However, when I try to update this app on my iphone, I get asked for the password for Account2, then the download fails as it says I do not have a paid earlier version to update.

    When I am logged into my computer iTunes as Account1 and try to update it on the computer iTunes, it says there are no apps to update (although my version of the app is definitely the old version).

    When I search for the app in iTune Store, it tells me I have already downloaded version 1.6 of the app and the download button is grayed out.

    If I temporarily delete the app from my iTunes then try to re-download, I am asked to purchase it again.


    If I log into iTunes as Account2 then try to download it, I am asked to purchase it.


    Any ideas? I feel I have tried every option and no success.

  • janay21 Level 1 (0 points)

    ok so i was on the phone for an hour and a half with apple tryin to figure this out..ima try and help u as best i can..if not plz dont yell at me.

    1.go to not sure if you have an apple id?

    3. type in all the possible email addresses that you know.

    4.after that either send email verification or answer the security questions

    5.after all of that is done, go into itunes and enter each apple id and if it says verify account then verify and continue to the next 1.

    6.after all of those steps are done, go on to ur device,click settings, scroll down to store,click the apple id that is shown and sign out.

    7. try signing into each of the apple ids and see if that works.

    8. if it does keep that particular id as the default for ur device so u wont have to do this again. if not you missed an apple id and you need to try the steps again.

    this is all i can remember at the moment.. i hope this helps at least a little bit.


    Message was edited by: janay21

Previous 1 2 3 Next