Skip navigation

Apple TV homesharing keeps dropping out ...

172181 Views 445 Replies Latest reply: Apr 5, 2014 10:18 PM by siamless RSS
  • Dundas Bunny Calculating status...
    Currently Being Moderated
    Mar 16, 2012 2:59 AM (in response to lantzn)

    Hi Guys

     

    I have the problem with what appeared as Homesharing going to sleep after about 10 minutes when using WiFi. I read all the advice on this discussion most of over my head I'm no Tech head.  Did some experiment with my IT dude at work today. we had success when we disconnect the modem from the net. The Apple TV configed and asked I wanted to continue without Internet I pressed yes .  No stoppages at all.

     

    I came home and set it out with No Internet connection - it worked continuously, so I plugged in the phone line for ADSL Internet to the modem - it kept working - so I tried to confirm the config again in Apple TV - the Apple TV then blacked out and refused to respond I shut off the power and powered up again

     

    The system has continued to play uninterrupted whilst on Wifi and connected to the net

     

    So we thought the problem was caused by the Apple TV streaming into the modem blocking the Homesharing - I can't explain how or why - connecting it up once it was running seemed to force something - not sure what but for the first time in 6 weeks it working.  Fingers crossed.- It is fixed - at last I'm again enjoying what I brought - use of my Library through my home sound system

  • beatmunga Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2012 4:54 AM (in response to Dundas Bunny)

    Thanks Dundas, that's a really user friendly and helpful set of instructions. I'll definitely give it a go this weekend.Not got a lot to lose!

     

    Glad you're enjoying your tunes again.

  • Dundas Bunny Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2012 10:23 PM (in response to beatmunga)

    Hi Beatmunga & other apple dwellers!

     

    Todays' experience in this imprefect Apple world - I fired it all this afternoon laptop, modem, apple Tv, and sound system - with the internet open and connected doing my email whilst listening hopefully to my music - surprise surprise Apple Tv stopped being able to connect after just 2 songs

     

    Rather than shut downong iTunes, I reconfig Apple TV with my modem - it started to work again

     

    By this time I had almost finished my mail - and praise the lord it has continued to work uninterpruted

     

    To all all the Apple boffins watching - Can I as a non-tech head suggest that it seems that Apple TV is acting an impaitent person when in a queue - rather than continuing to poll the modem it may be switching off it's request - hence my TV displays the song it was attempting to poll or download but the time is 0:00 at both ends of the timer

     

    Anyway I'm going back to George Thoroughgood while I can - see you next time

  • mogulsue Calculating status...
    Currently Being Moderated
    Mar 17, 2012 9:52 PM (in response to Jeet K)

    I am experiencing dropped homesharing connections to ATV2 about every 5 minutes. This started since installing the last iTunes and ATV2 updates.  I just watched 2 TV shows on Apple TV sourcing from iTunes homesharing on a home computer and lost the connection about every 5 minutes. To reconnect, I just turned off homesharing in iTunes and then turned it back on again. Solved the problem quickly every time, but very frustrating. I also notice that if I wait a bit longer without doing anything, the ATV2 "sees" the itunes again and is ready to accept orders again for itunes homesharing. But how do I stop the drops?

  • kirkmc Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 18, 2012 3:45 AM (in response to Jeet K)

    I'm seeing the same problem, but in my case it's clear that the Apple TV itself is dropping the connection. This is not a problem with routers and ports. When the Apple TV drops the connection, and I go to Settings, it doesn't see any of the networks in my home, nor those in surrounding homes that are visible on my Macs.

     

    I've documented this on my blog: http://www.mcelhearn.com/2012/03/18/new-apple-tv-constantly-dropping-network-con nections/

     

    For others with this problem, does your Apple TV see your network, or others, when you go to Settings > Network?

  • Jerome Del Ray Level 1 Level 1 (65 points)
    Currently Being Moderated
    Mar 18, 2012 11:53 AM (in response to Jeet K)

    I've had an ATV2 and just swapped it for an ATV3. 

     

    The 2 routinely dropped Home Sharing connections after having been awakened for new use.  About 2-6 minutes it would no longer see my iTunes collection.

     

    The fix was easy but ANNOYING:  whenever awakening ATV from sleep, reboot it with the remote control two finger trick.

     

    (What's even more annoying is that I find it necessary to do this with ALL the Apple products I own.  My iMac will drop the Airport connection RELIABLY once or twice a day, and a reboot is all that saves it.  My iPad (even the brand new one) will fail somehow after hours of use.  Last night it was sound -- sound wouldn't play unless I reboot.)

  • to.live Calculating status...
    Currently Being Moderated
    Mar 18, 2012 2:36 PM (in response to Jeet K)

    After the latest iTunes and ATV updates, my ATV2 has been dropping homesharing too.  I have used my ATV2 for over a year without any problem.  My modem is about 6 months old and has worked fine.  Apple I am waiting on you to this problem!

  • avale Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 18, 2012 3:30 PM (in response to to.live)

    I am in the same boat.  I have an iMac, Time Capsule and two Apple TV 2 and all are running the latest updates.  I rented and fully downloaded a movie to my iTunes account on my iMac.  When I tried to watch it my ATV2 would drop home sharing after 5-10 minutes.  I restarted my computer, router, ATV2 and that didn't fix it.  I logged out and signed into home sharing again.  None of this fixed the situation.  The same behavior is showing up on both ATV2.  If I disable and re-enable home sharing on the ATV2 I can get another 5-10 minutes before it boots me out again.  Clearly an issue with the latest updates and makes watching a movie near impossible.  I hope they fix this quickly!

  • beatmunga Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2012 3:48 PM (in response to Jeet K)

    Interestingly, Apple have been careful to make NO MENTION OF HOME SHARING WHATSOEVER on the UK store's new Apple TV3 details.

     

    They have obviously quietly dropped promoting this feature in light of the fact that they have screwed it up, big time.

     

    Thanks a bunch, Apple. Game over.

     

    Not impressed.

  • Joebuda Calculating status...
    Currently Being Moderated
    Mar 18, 2012 4:36 PM (in response to beatmunga)

    Hey all, I don't know what to say. I was having the same issues with home sharing and finally changed my wifi channel to a less crowded one and also created a direct connection to my apple tv and Mac in my airport express (entered the mac address of each ) into  DHCP Reservation slot under the network tab of Airport Utility and even though I don't know which change ( or maybe both together) fixed it. I haven't had a single drop for more than 2 weeks. But ever since the ATV update my TV shows no longer appear in a logical order ( movies are fine) anybody have a fix for this??

  • mogulsue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2012 4:50 PM (in response to kirkmc)

    kirkmc, For me, when my ATV2 homesharing connection drops, it is dropping only the homesharing computer that ATV2 is playing content from. The ATV2 can no longer "see" the dropped computer, but still "sees" the other homesharing computers (I have 3 ATV2 sets running, and 3 home computers all homesharing on the same homesharing account), and the ATV2 can still access internet content. I can solve the problem by (1) waiting - ATV2 will eventually see the dropped computer again (takes about a minute) and then I can start the content again, or (2) restarting iTunes.

  • avale Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 18, 2012 6:02 PM (in response to mogulsue)

    I got a response from Apple support.  They pointed to this thread and told me to "do the solution on page 44", https://discussions.apple.com/thread/2776955?start=630&tstart=0  There are a bunch of solutions on this and removing and installing Bonjour and iTunes 64 bit version seem like Windows things.  I'm on a Mac but I'm willing to try anything.  How do you easily delete bonjour and itunes without losing all your data?  I'm fairly new to this level of mac debug...

     

    BTW, I'm not sure I mentioned this.  I rent on my iTunes/iMac account and play on my AT2 as I like to rent a few ahead of time.

  • mogulsue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2012 10:02 PM (in response to Jerome Del Ray)

    I was hopeful that re-booting ATV2 would be the fix, but unfortunately it has not worked for me. I just completed that and attempted to watch a TV show on ATV2 via homesharing in itunes. Same problem - ATV2 dropped the connection about every 5 minutes. I gave up and connected my PC to the TV monitor with a VGA cable to watch the show.

  • spma3 Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 18, 2012 10:19 PM (in response to mogulsue)

    Have you tried applying any of the other configuration changes that people have presented other than:

    1) Cycling your power to the ATV

    2) Rebooting the ATV

     

    Neither of these work.

     

    Other recent suggestions which appear to have merit are:

    1) for windows users, uninstalling iTunes and Bonjour then re-installing

    2) turn off sync wirelessly for iPhone/ iPad and re-install ITunes.

     

    For me, making changes to my router fixed the problem.

     

    Everyone have read/ experienced the same issues being repeated over and over again.

  • philfromsakai Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 19, 2012 12:30 AM (in response to spma3)

    I tried restoring ATV / resetting to factory settings on at least six separate occasions, reinstalling itunes and bonjour and then resetting / restoring ATV, and various combinations of the above. It's probably the first thing I tried -- if in doubt, restart / reset.

     

    None of it worked.

1 ... 8 9 10 11 12 ... 30 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (15)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.