Previous 1 19 20 21 22 23 Next 448 Replies Latest reply: Feb 10, 2015 3:16 PM by John Zwiebel Go to original post Branched to a new discussion.
  • Jeet-do Level 1 Level 1 (0 points)

    I continue having the same issues even after updating the lastest Apple Tv and iTunes version.

     

    I cannot watch any movie from itunes to my Appletv... without dropping randomly.

  • okaytak Level 1 Level 1 (0 points)

    i can't stream itunes content to my APPLE TV3 smoothly!!!!

     

    It keeps stopping in between.

     

    Whats happening????

     

    Is apple doing something about this.

     

    Seems like almost everyone are having the same problem.....

     

    It was good when i first got it but after all the updates, home sharing / air play from itunes is laggy and takes forever to buffer.

     

    Youtube seems to be working fine though.

     

    Whats the solution?!?!?!?! Give me a fix!

  • Tacalifornia Level 1 Level 1 (0 points)

    I have both 1st Apple TV and 3rd Apple TV, but both haven't been working for a couple of weeks,

    I don't know why, they worked well before it happened.

    I usually use podcast function to watch video.

     

    I know 1st doesn't need Home Sharing function and 3rd does, and tried both ways, but anyway,

    it seems that the AppleTVs can't connect iTunes.

    AirPlay function and others like Youtube seems to work.

  • worralljc Level 1 Level 1 (0 points)

    My apple TV had been working very well until someone (I think the babysitter) accidentally upgraded to the latest software.  Then home sharing stopped working. 

     

    I thought, oh maybe I just need to update iTunes to 10.6.  Big mistake!  Then, home sharing stopped working on other iOS devices (iPad etc); stuttering video playback that others have described.

     

    I DOWNGRADED iTunes back to 10.5.3 using instructions found here: https://discussions.apple.com/message/17906595#17906595

     

    Note I needed to find a link to a 10.5.3 download - Apple doesn't make it easy.  (If you get the .dmg, hold onto it!)  I also needed to use Time Machine to find an old version of my "iTunes Library.itl" and other associated files (this is described in the link above). 

     

    I turned off home Sharing in iTunes and the apple TV.

     

    THEN, I changed the Apple TV to a static IP address.  To do this, I logged into my router and checked the range of addresses reserved for DHCP (dynamic IP).  Then, I went to apple TV - Settings - General - Network - Configure TCP/IP and chose set manually.  I entered an IP address outside the DHCP range.

     

    Then I turned home Sharing back on.  So far, it seems to be working, although I have not watched for long.

     

    Home this helps someone.

  • 2zzz Level 1 Level 1 (5 points)

    I think its working for me now ..

     

    I have been having the same problem with home sharing I believe everyone else has been experiencing. I don't have apple tv(yet, not until I can get this figured out), just home sharing with ipads, iphones, and my mac.  I got all the devices to see all the family libraries by following the normal instructions and then after awhile it would just drop off.  I would turn off/turn on home sharing on the mac and it work just to drop later.

     

    I looked at the router, the firewall, and pretty much what everyone else has been posting.  I think I have it working now (after googling other posts), so thought I would share ..

     

    I think its a sleep issue ..

     

    1. Select the finder apple, system preferences.

    2. Select Energy Saver

    3. Unselect Put the hard disk(s) to sleep when possible

    4. Select Wake for network access.

     

    Also, make sure itunes is running - all the time.

     

    Its pretty easy to test to see if this is the problem you're having.  On your mac/itunes, turn off then on home sharing. Go to your ipad(apple tv) and see if you can see the shared library.  Then, on your mac, select the apple and then sleep.  That's when it would drop off for me.  The default settings are to put your hard disk to sleep when possible and wake for network access unchecked.

     

    One other thing, if you're running more than one wireless network (like I do for guests) make sure your wireless device comes up on the same network your mac is on.  Sometimes my ipad picks the guest network and I didn't notice and I could not see the shared libraries.

     

    I'm running mac 10.6.8, itunes 10.6.3, airport extreme 7.6.1.

     

    Hope this helps.

  • Crispy8888 Level 1 Level 1 (0 points)

    For all those who have tried the various fixes without success (firewall, fixing Bonjour, clearing out iTunes prefs, reinstalling everything, restarting iTunes etc, etc, etc) I will suggest you swap out your router.

     

    I had a Belkin F5D8235, and no matter WHAT I did, Home Sharing would *not* work. Not between laptops (Win7 and Vista), nor between my Win7 laptop and my Apple TV 3. I just bought a Netgear N900 WNDR4500, swapped it in, and with the factory default settings, it has been working flawlessly. I'll give it some more time to soak, but in a single hour I'm experiencing more success than I have ever had before. I had even disabled my entire firewall, killed all of my antivirus programs, reinstalled iTunes, restarted the router multiple times, played with the sleep settings on the ATV3, done EVERYTHING I have found in two days of online searching to no avail. Home Sharing never worked between laptops at all, regardless of iTunes versions. So I can't conclusively say that the problem is the router in all cases, but when nothing else seems to work, give it a try. I'll update this post in a few days to let you know if it's still solid.

     

    My setup:

     

    Win 7 Home Premium 64-bit, HP G60 laptop, wireless-g

    Apple TV 3, wireless-n

    Netgear N900 WNDR4500

    iTunes 10.6.3.25

    Avast AV with no manual exceptions

    Windows Firewall with TCP and UDP ports 3689 and 5353 opened

  • Charmiepoo Level 1 Level 1 (0 points)

    Crispy.......it sounds like you may have also had a router problem.....But......if it were a router problem for everyone, then Homesharing would not have worked before that major ATV update either. Homesharing worked just fine for me with the same router before that update.

  • Mark-Mac-Developer Level 1 Level 1 (20 points)

    This IS NOT A ROUTER PROBLEM nor is it having to do with any computer settings. In the last release of Apple TV the very things they updated are what you are having trouble with. Many people are experiencing this problem. Just look at the APTV release notes. Acutally it was two releases ago the last one was a bug fix for the ausies.

  • Crispy8888 Level 1 Level 1 (0 points)

    I appreciate that the root cause of this issue may not be a router problem. In fact, I suspect it is not, and seems like it is related to some component of an ATV firmware update based on the hundreds of comments I've read over the last few days.

     

    However, I have about a half a terabyte of shows and movies in iTunes that my family and I would really like to watch. For me the shortest path to a solution was to swap out the router — without changing anything else — and it's been 110% solid now with zero dropouts or disconnects. I could have sat here on the forums and fumed and bitched at Apple, paid $29 to open a support ticket and have a 2nd level tech tell me "yup, it's a known problem and they're working on it"...or I could take a proactive approach and fix it myself.

     

    It's not a router problem, true...but it *is* a networking problem. The fact that replacing a single part of the networking chain makes everything work all of a sudden, is suspect. Unfortunately it's not clear if it's iTunes or the ATV at fault here. There's evidence from both sides. And I could run Wireshark traces all day, but without knowing the inner workings of either application, I couldn't point the finger in either direction.

     

    So what I *am* going to do is send my findings to Apple and reference this thread. Hopefully it will help them in some manner.

  • TitanBry77 Level 1 Level 1 (0 points)

    I am signed on to many other threads with the same exact issue.  I am fairly good with networking etc and have tried everything, it never happened until iTunes update 10.6.3.  I am going to try and do the downgrade to 10.5.3 and report back with my findings.  It is awful that the issue is this widespread and nothing from Apple yet.

  • Alley_Cat Level 6 Level 6 (17,910 points)

    TitanBry77 wrote:

     

      I am fairly good with networking etc and have tried everything, it never happened until iTunes update 10.6.3.  I am going to try and do the downgrade to 10.5.3 and report back with my findings.

    I though the same initially but I only updated one of my computers to 10.6.3 and I have Home Sharing issues with both.  I suppose it's possible 10.6.3 could be doing something that's affecting iOS devices and other iTunes instances.

     

    AC

  • Charmiepoo Level 1 Level 1 (0 points)

    I hate to break it to you but it is not an iTunes issue. I am still using 10.5.3, yet I have the Homesharing issue with the Apple TV.  Remember that all those updates were released on the same day. The major Apple TV update that was released that day is the culprit.

  • TitanBry77 Level 1 Level 1 (0 points)

    Yes I just found that out. Downgraded iTune and still the same dang problem. I am trying to figure out if I can downgrade the apple tv firmware. I know it can be done if you are jailbroke and have backed up your old shsh file but doesn't look good otherwise.

     

    I wonder why though restarting iTunes fixes the issue in my case?

  • jfrye77 Level 1 Level 1 (0 points)

    I just bought a 2 month old Apple TV from someone that never used it.  It is v5.0 (4099).  My iTunes version is 10.6.3.25. It seems to be working fine so far.  What version is everyone else using that is having problems?  I'm thinking that if it continues to work, I'll make sure not to upgrade the firmware on my ATV.

  • tarkin Level 1 Level 1 (15 points)

    My problems seemed to have started after an update. I tested the ATV on 2 Macs with the same Home Sharing issues. I even took it to an Apple Store where they did a DFU restore. 5 days ago I decided to try the restore again. I'm currently on 5.0.2 (4250) and it has been running flawlessly.  And that's with a G5 iMac!

Previous 1 19 20 21 22 23 Next