Previous 1 21 22 23 24 25 Next 449 Replies Latest reply: Mar 18, 2015 9:44 AM by UKBrian Go to original post Branched to a new discussion.
  • GoHerdIBG Level 1 Level 1

    I have updated all of my ATV 2's and 3's to the latest firmware and have been problem free for 2 weeks.  I do believe the major issue of not being able to connect after a period of inactivity has been corrected with the latest ATV firmware.


    I was not experiencing the cut-off in mid-song or mid-movie so I do not know if the update fixed that issue.

  • austinmac1 Level 1 Level 1

    Been working on similar problems off and on for last several months. I have a MacBook Pro (all software and firmware is latest for the MacBook and everything else mentioned here) streaming my iTunes library using airplay to ATV2 x 2 and Airport Express (Box) x 2. WiFi is through Airport Extreme (dual band with WPA2 connected to cable modem.) Sometime after upgrading to OS10.8.2 and iTunes 7, I lost consistent music playback without changing anything else that I'm aware of. After trying almost all of the various suggestions above, I left homesharing on for the MacBook and ATVs (so I could use the remote app to control everything) and connected the computer directly to the Airport Extreme using ethernet as some have suggested. This is what worked for me. I was previously connecting the computer to the network wirelessly. Now that it is hardwired to the AP Extreme, I have had no play loss, and have also noted significant improvements in using the Apple Remote app on my iPhone 4 to control things as I had previously. I can still use airplay to stream audio and video to the ATVs using various iPads and iPhones and can mirror the MacBook to the ATV, but cannot get music to stream consistently from the computer unless the computer is connected directed to the Airport Extreme. Thought I'd mention it - also, for me, updating the firmware on the ATVs and Expresses didn't do any good. Good luck.

  • xjonsolox Level 1 Level 1

    I was just looking at this thread and trying everything.  I just made DHCP reservations for my computer and Apple TV.  It started working immedeatly after that.  Hopefully it keeps working.

  • nalehp Level 1 Level 1

    I had to update my firmware on the router to fix this problem. I have had no problems since but it has only been 2 days.

  • m@lv Level 1 Level 1

    My ATV3 that works great at home would repeatedly drop the connection at a Users Group Meeting.  I discovered the problem.  Another person was using the mirroring feature from his computer to the ATV and a digital projector. However, my computer's iTunes still had homesharing turned on.  When I turned that off the interuptions stopped.


    Our club just bought its own ATV3.  Now every person who brings their computers to our meetings will have to make sure they shut off home sharing from their computer when someone else is presenting.  It is very distracting when the connection keeps dropping.


    I can see that haveing multiple devices connected to the Wi-Fi at the same time could result in the same problem if more than one has homesharing turned on.

  • hamdicarlo Level 1 Level 1

    You don't need to turn off home sharing on other devices.

    Simply go to airplay under setting on apple tv and set a passcode for it.

    This way anyone wants to connect to apple tv to mirror their device must enter the passcode that you set despite if they have home sharing on.

  • tarkin Level 1 Level 1

    I replaced my ATV3 two weeks ago.  I tried connecting via wifi through my router and had the same problem as the old one-no Home Sharing.  I then connected it via ethernet and it has worked flawlessly.  No issue at all.  I'm wondering if it's that I have an inexpensive router. 

  • Scary-Bunny Level 1 Level 1

    This is a very simple problem ... Apple have clearly 'damaged something' when they realsed the latest version of the AppleTV firmware that came out in August 2012. I'm not going to speculate what this is as I don't work for Apple; I'm just stating the facts as I see them with my device.


    My Apple TV3 worked 100% absolutely fine until that point, not a single drop out in over 6 months ... now after the firmware update it drops out at least once every time in the first 10-15 mins of a movie every time it is used (after resuming its usually OK for the rest of the movie) ... and as I said, this ONLY happened from immediately after the firmware update.


    Secondly nothing else has changed with my setup, same laptop used for iTunes (and its an Dell XPS Core i7 Ultrabook with 8Gb RAM on Win7Ultimate (64 bit) with iTunes (64 bit), so its not a performance issue), the same UK 'Sky' Router (a rebranded Netgear), same network cabling, same everything else ... the only thing that has changed is the Apple TV firmware update. So it has to be the firmware update that has caused the problem; there is no other logical explanation.


    Anyone else who's been seeing something similar happen before the firmware update in Aug 2012 clearly has a different issue.


    Come on Apple there's enough people on here complaining about this issue ... 23 pages of comments, 300+ comments and 65000+ views of this thread so loads of people clearly have the same issue ! ... I suggest you fix what you've broken with another firmware update ASAP .... or revert us back to the previous version that worked fine, I'd rather have an Apple TV that basically works without dropping out than what ever other updates you put in that I havent even noticed !!!!

  • don'tvexmeapple Level 1 Level 1

    I have this same problem, repeatedly, with my laptop which is currently running windows 7, it is a toshiba satellite l750d has more than enough spec, to deal with downloads and iTunes. But i have drop out outs regularly and i have come to the conclusion it is the number of devices i have, linked with my apple tv. I have an iPhone 5 that does what it wants, running iOS6 and an iPad, running the same doing & doing the same. Try turning off your apple tv with your iTunes still open, restart rather. Make sure your home sharing is on beforehand, this seems to make it realise the other devices and restart ****. Then play everything from your apple tv to your laptop, I have done this for two hours with my devices, ipad and i iphone re-syncing continuously throughout and no dropouts. So try it let me know if it's helped!

  • Loramarthalas Level 1 Level 1

    Hi all,


    After struggling with this issue for a few months, I've finally nailed a solution that works for me. It all came down to the type of wireless networking I was using. While this won't work for everyone, it might help folks who use wifi to connect to ATV3.


    The problem was that the 802.11g+n that I had my modem configured to was defaulting back to g. This occured because of the encryption I was using. The solution I found was to force the modem in 802.11n, and then use WPA2 with AES. What that does is force the whole network into n speeds -- 300mbs. Any other type of encryption restricts the network to 54mbs.


    As soon as I did that, my ATV connection became much more stable. On top of that, movies and music load much faster as well.


    Hope this helps someone out there.

  • JamesJLongIsland Level 1 Level 1

    My issue was the same with Home Sharing.  It would work fine for roughly 15-20 mins, then the image would freeze, and I would need to reset the Apple TV and close out iTunes and start it back up again.  I completely bypassed the wireless connection.  Ran a new CAT5 from my Network in the basement to the Living Room.  Installed a new 8 Port Switch and a Enterprise Class WAP.  Since connecting the Apple TV to the Switch, haven't had an issue with Home Sharing.  Wish it would just work as advertised through WiFi, but I've come to be disappointed in Apple, thus switching back to the Droid platform.  Samsung Galaxy SIII

  • Orest75 Level 1 Level 1

    Agreed!  I had no problem with homesharing until the 10.7 update was released.  I think Apple plans to do nothing about this until the release of the new iTunes; which if that is the case is some BS because they know that there is a problem but just refuse to address it. 

  • Forgotten Rebel Level 1 Level 1

    I am returning my ATV 3 for a full refund.


    Same home sharing problems as everyone else, drops after 15 minutes etc., but Internet / Netflix all still work fine it's just the home share ability that disappears. It disappeared before i purchased the ATV so its clearly an iTunes or IOS issue that really makes this ATV a pain to use so that's why it's going back. We have a few ipads and iphones and really wanted this to work but its to much of a pain to reboot iTunes all the time. Its just simply easier to do without and use my PS3 again. Personally, I am convinced this is an iTunes/ IOS issue and not a router or ATV issue. Atleast I'll get my money back.

  • RocketRobster Level 1 Level 1

    I've been reading these threads and suffering the same problems. I've tried several of the suggested fixes to noavail  However, I may have discovered the root cause. Apple products use multi-cast IP packets to discover other devices on the network but this may be blocked by your wireless router. Simply enable multi-cast packets in your router. This may be called IGMP in the config.


    Previously, I couldn't listen to more than one song before my Apple TV hung. We've been listening to music for an hour uninterrupted since making is one simple change. It may be coupled with some of the other fixes.


    Please try this and post your findings.

  • fvwessel Level 1 Level 1

    Here's my two cents on this one, it looks that most of you had similar problems as I had after upgrade to ITUNES 11 and upgrade of appleTV.


    My setup:

    IMAC hosting ITUNES with large library residing on 6 TB external firewire drive containing approx 3 TB of music and videos.

    Two aiport extreme routers combined into two networks (2.4 GHZ and 5 GHZ) , one downstairs connected to the internet provider modem, from there cable going upstairs to the 2nd router which has an ethernet cable connection to the IMAC.

    Appletv connected using the 5 GHZ wifi network, HDMI cable to the TV and optical cable to surround receiver.


    Problem description:


    After the upgrade to ITUNES 11 and upgrade of AppleTV movies stopped and returned to the main screen without any error message or with a message ' not connected to itunes library' .




    On the imac in 'system preferences', 'energy saver' changed setting to ' never sleep' but especially to unselect  the setting ' put harddisks to sleep when possible' did the trick.


    Since then AppleTV works flawlessly , quick responding when selecting movies from the library.


    For sake of completion an image of the actual settings used, now this is not really desirable as a standard setting but until Apple comes with a patch it has to do.


    Good luck to everyone with this issue,

    Frans van Wessel


    The Netherlands



Previous 1 21 22 23 24 25 Next