Previous 1 3 4 5 6 7 Next 449 Replies Latest reply: Mar 18, 2015 9:44 AM by UKBrian Go to original post Branched to a new discussion.
  • hankhane Level 1 Level 1 (0 points)

    I disabled WIFI syncing on all of the family iOS devices yesterday.  No drop outs have occurred since then.  Might be on to something!

  • Burgee67 Level 1 Level 1 (40 points)

    This worked great for me with no problems for weeks now.

    System preferences

    Network

    Wi-Fi

    Advanced

    TCP/IP

    Configure IPv6, Set to Link-Local only

     

    Screen Shot 2012-01-03 at 10.54.36 AM.png

  • Russcolli Level 1 Level 1 (0 points)

    Suspect I'm getting a similar thing. Running latest OS (Lion), and current iTunes connecting to the ATV via an airport express on a cable modem.  No problem at all with the wifi connection for the ATV - youtube etc.100% always there.  Issue is with Homesharing, or perhaps more precisely the ATV maintaining the connection for more than a few hours to the iTunes account.

     

    Homesharing as such is not I think dropping off as the ATV will still show the name of the Homesharing iMac - however when I access that iMac via the ATV it spins it's progress dial 'loading' then eventually provides some stock error message.  Only consistent way to get the connection back seems to be restoring the ATV which seeems to trigger the reconnnect.  Stopping and restarting homesharing on either end device does not consistently resolve issue, nor does restarting the airport express. 

     

    I'm sure it's a software issue with either the ATV or the current iTunes - some weakness re holding the iTunes account access via wifi perhaps.  Bloody annoying.

  • flippfox Level 1 Level 1 (0 points)

    I just un-boxed and setup my new ATV2 connected via cable, with my iTunes Library on a MacMini (also on hard wire connection to LAN) and I get a lot of issues with ATV2 connecting to library initially and then dropping out mid-movie.

    I suspect something along the lines of Power Settings on MacMini since latest Mac OS X 10.7.2 update, but even when I manually wake it up (although settings are set to 'Never') the ATV2 needs to be powered off/on before it recognizes the iTunes Library - VERY FRUSTRATING.

    Any suggestions folks?

  • Wizzmer Level 1 Level 1 (0 points)

    @flippfox: Start with Burgee67's suggestion above regarding IPv6. Next, turn off Wi-Fi Sync in iTunes. Not to say that's doing anything but can't hurt if you don't have any other Apple wireless device. Also, are you saying the macmini goes to Sleep even though you have it set to never sleep? Thats odd if so. iTunes NEEDS to be ACTIVE in order for AppleTV to work so if the computer goes to sleep, say Bye-Bye to AppleTV. It should re-conect upon awakening the computer though, so it's odd to say the least. If you are on any kind of router, try bypassing it so you're Apple TV is conected into the simplest wireless connection like a wireless modem in advance of the router. Units like the Apple Extreme are problematic for some users and there is no general known consensus yet as to why. Check your firewall setting and if you have it turned on, make sure it's allowing traffic from the ATV2. Aside from that, I'd try to boost your multicast strength to HIGH in your network settings. Not sure if it does anything really but it doesn't hurt although you may just have to do a one time re-boot of your system. Also, have you verified that the signal strength between teh ATV2 and your computer is pretty strong (under NETWORK setting on the ATV2)? If it sounds like we're grasping at straws it's because nobody knows what the true source of the problems are but it's highly unlikely it's the ATV2 unit itself. Good luck and try varying just one thing at a time if you continue to have problems. Document your connection and as strange as it sounds, TRY to make the connection FAIL. Knowing what doesn't work can be just as important.

  • dunkxs Level 1 Level 1 (0 points)

    see the response above

     

     

    System preferences

    Network

    Wi-Fi

    Advanced

    TCP/IP

    Configure IPv6, Set to Link-Local only

  • djpower Level 1 Level 1 (0 points)

    This isn't a wifi setup issue.  If it was, Netflix etc would be encountering the same dropping issue, but it doesn't.

     

    This is specific to homesharing.  There is an issue between the aTV and itunes.

  • flippfox Level 1 Level 1 (0 points)

    Thanks Wizzmer - so far I have set my Ethernet (no wireless in play) IPV6 to Local-Only and looks better. Now I have my Apple-Hat on I am more intune with what to check/not check so will monitor and get back to this thread.

  • Russcolli Level 1 Level 1 (0 points)

    I agree with djpower that this isn't an real issue with the network setup (everything else works fine other than homesharing) - the problem is definitely with ATV and/or iTunes but it does relate to how they maintain the network connection in respect to Homesharing.  However, since I set IPV6 to local-only I have had no problems with Homesharing (so far so good for 3 days now). 

     

    I does not make sense that the change would resolve matters but if it works.....  At a guess I think there is some weaknesss/conflict in either HS or iTunes with regard to reliably maintaining the HS connection. 

  • nrezabek Level 1 Level 1 (0 points)

    this is absolutely an ATV -> iTunes problem centered around Home Sharing. My home sharing isn't even showing up in my sidebar of iTunes any longer even though it says I am Signed In. Then when I log out, and log back in, it will show up for a second in the iTunes window and then disappear.

     

    Currently I have a black box with a wee little light in my living room, unable to do anything I want it to because of this problem. Please fix.

  • Wizzmer Level 1 Level 1 (0 points)

    For those users saying this is not a Wi-Fi issue, well I agree in the traditional sense. I'm not computer expert but what if the source of the problems is merely some stupid permissions thing or leftover settings in a cache somewhere. Going back may years when a lot of users had syncing issues between apple tv and itunes, it turned out that a lot of issues were fixed by repairing permissions (which we didn't know were even broken) and clearing out old caches (probably not going to fix anything but ****, why not). Here a little known program called AppleJack (not the breakfast cereal) that was used by many to fix the problem. If you dare, install and run: http://download.cnet.com/AppleJack/3000-2094_4-40293.html?tag=mncol;1

     

    If you're firewall is on, check advanced and make sure you have iTunes set to allow incoming communications. Point being make sure you don't have any permission based software like a firewall program running (or installed at this point of debugging). Strip it off teh computer and remove it as a possible source of the problem. We're looking to simply teh connection between iTunes and ATV2 as much as possible and firewalls can mess with communication of files and packets of data in weird unpredictable ways. If it's not the problem, you can always reinstall or re-enable it later.

     

    As a last ditch effort, I might consider turning off home sharing and resetting the Apple TV then starting fresh.

     

    As always, the more details you can provide of you configuration, the better. The solution may be fixed one way for MAC OSX users but could not work the same way if running under a version of Windows. See comments from user TOPMANPAF in this thread: https://discussions.apple.com/thread/3507281?start=15&tstart=0

     

    Also, just to re-iterate (for anyusers that have come in mid-thread) user DGANDE wrote " ... ITunes wireless Sync uses the same ports as Home Share and that wireless sync would lock up the ports and not give Home Share Access. He suggested turning off wireless sync on iTunes and the devices that connect to it, and "Bam" Home Share started working."

     

    Anyone want to create a checklist for users to help with debugging? Volunteers?

  • beancounter_1 Level 1 Level 1 (0 points)

    Okay, as I originally posted, my ATV 2 was working fine for almost a year, and then all of a sudden Home Sharing turned off after a couple hours of inactivity.  I am not using wifi, so I don't see how the previous suggestions would assist me, but I did change one setting within "System Preferences" that seems to be working.  It's still a little early to say, but I checked the box that says "System Preferences->Energy Saver->Wake for network access".  I went to work this morning and when I came back my ATV 2 was working.  It's worth a try for anyone dealing with this same situation.  On a different note, I was using wifi with ATV, but I found being hard wired to be much more reliable and quicker.  Hope this helps.

  • DP06 Level 1 Level 1 (0 points)

    Try setting the time zone on Apple TV to manual instead of Automatic. Worked for me using latest versions of itunes and Apple TV OS.

     

    The Apple TV and computer running home sharing have to be on the same time zone and they sync over the network sometimes. I *think* if they are slightly out it causes home sharing connection to drop.

  • SuperSizeIt Level 3 Level 3 (575 points)

    I have tried that. It doesn't work.

     

    https://discussions.apple.com/thread/2776955

  • philfromsakai Level 1 Level 1 (0 points)

    Am absolutely incensed by Apple support staff ignoring this problem. No even a 'relax, people, we're working on it.' My ATV was working perfectly until after a system update (4.3 I think) and then started dropping out with the 'turn on home sharing' message. Have checked router etc, reinstalled ATV, iTunes etc, to no effect.

     

    It is bull**** to expect the average PC user to navigate complex firewall settings, pore through network settings etc to fix a problem that is almost certainly a software bug from the update.

     

    I dislike the refusal by some of the posters here to countenance the possibility that this is an Apple problem. Too many people here have had the same problem at the same time (immediately after update), and appear to be too technologically literate to have simply forgotten to plug in the router.

     

    I am calling on an Apple representative to explain the situation right away, I am on the point of chucking my ATV out the window.

Previous 1 3 4 5 6 7 Next