1 2 3 Previous Next 84 Replies Latest reply: May 27, 2013 2:02 AM by yameste
G8mb1t Level 1 Level 1 (0 points)

My iphone 4 been running on 4.3.1 smoothly until I upgraded my software to 4.3.3 this week.

I cannot connect to my wifi(apple timecapsule) all my other devices still running 4.3.1 can connect.

 

Reading the forums, I did the following.

1. Reset all network settings-did not work

2. Hard reset-did not work

3. Restore and setup new phone without restoring backup to 4.3.3-did not work

4. Trying to downgrade to 4.3.1 did not work as itunes ays that its not eligalbe for this build after going into DFU mode.

 

The bad for me is I never jailbreak any device and still going a legit route i now only have a 3G working.

 

Is this a confirmed bug?

If anyone has the same issue but solved let me know.

  • 1. Re: After iphone 4 4.3.3 update wifi not working
    travisfromlouisville Level 1 Level 1 (0 points)

    I have the same problem, I upgraded my iPhone 4 to 4.3.3 and now my wifi isn't working. I tried resetting network settings and that didn't work either. I upgraded my iPad 2 to 4.3.3 and the wifi works fine.

  • 2. Re: After iphone 4 4.3.3 update wifi not working
    G8mb1t Level 1 Level 1 (0 points)

    It was my last try, I went and once again did a full restore of iOS 4.3.3 and tried to use the wifi but it still defaulted to 3G.

     

    However after restoring my phones backup, I came back and it just worked, now that was strange, really strange.

     

    Hope this helps someone else.

  • 3. Re: After iphone 4 4.3.3 update wifi not working
    AndiXXX Level 1 Level 1 (0 points)

    I have the same problem. After upgrade to iOS 4.3.2 the wifi did not work. Only my wifi at home to what the iphone was connected during upgrade does not work. Other wifi's at work and in other places were detected and connected to.

    Reset all network settings-did not work

    Switch power off and on - did not work

    choosing others in settings/network/wifi and entering the name and password of the network - did not work (Error: "could not find the network")

    upgrade to iOS 4.3.3. - did not work

    The WiFi address (setting/about) is CC:08:E0:5E:CD:F4

    Is anyone having the same problems and knows how to solve?

  • 4. Re: After iphone 4 4.3.3 update wifi not working
    athschmid Level 1 Level 1 (0 points)

    I upgrade to 4.3.2 about a week ago, and since that point have not been able to use my WiFi connection.

    Weird thing is, at first it said (no WiFi) under the network options, then a few days ago it changed back to the normal on/off WiFi option. Tried to enable it but didnt get a network list with available networks. typing in my network settings didnt do it either; got the same error you did.

    Even tried restoring old iPhone backups but that just didnt do nothing but screw up my calender and contacts, not rollback iOS version like I thought it would.

    still stuck with no Wifi and probably a huge phone bill!

     

    d/l'ing 4.3.3 not to see if that helps any.

  • 5. Re: After iphone 4 4.3.3 update wifi not working
    Steve Langlois Level 1 Level 1 (120 points)

    Resetting the network settings worked for me although my problem could have been different. Mine would connect into an authenticating wifi network like at McDonalds or in a hotel but when I opened a web page, the login page would not come up so I was connected but could do anything. Reset the network settings and then it worked. First time I have ever had this problem with upgrading.

  • 6. Re: After iphone 4 4.3.3 update wifi not working
    enzyme69 Level 1 Level 1 (15 points)

    Same here. I realized it just few hours ago. I updated my iPhone last night. Apparently today I have been using 3G data without my knowledge. Wi-Fi Internet is not connecting... 

  • 7. Re: After iphone 4 4.3.3 update wifi not working
    enzyme69 Level 1 Level 1 (15 points)

    UPDATE: Strange enough, I went home and login to my home network. No problem, I got Internet like normal. Wifi adjust itself on top of 3G.

     

    It was not like that at the office network. No matter I reset the network and restart the iPhone, all I am getting is just network connection, without Internet connection.

     

    Very strange.

     

    I am sure this is in relation the the latest update. I did not update my iPad 2, it is working fine with office wifi network.

  • 8. Re: After iphone 4 4.3.3 update wifi not working
    Roger Kaufmann Level 1 Level 1 (25 points)

    Guys,

     

    I've been following a ton of threads with this problem and am ever hopeful that I've found a "solution", even if it would need to tested over time:

     

    My TimeCapsule had the channel setting at 'automatic' and defaulted to channel 11, so I manually changed it to another channel (tried to pick one that doesn't come up too often when scanning for other home wireless networks). So far, my connectivity issues with my iPhone 4 (and iOS 4.3.3.) have vanished! My iPhone connects immediately and (so far ... about 2 hours) has remained connected.

     

    Sure, there should be a fix to this issue to come from Apple (iOS 5?, if not 4.3.4), but as a workaround it seems to work.

     

    Hope this helps somebody.

  • 9. Re: After iphone 4 4.3.3 update wifi not working
    AndiXXX Level 1 Level 1 (0 points)

    I tried to change my time capsules channel settings - did not work

    Resetting the time capsule channels to automatic - did not work

    Hard reset -did not work

    The apple support line recommended to do a restore as a new device to factory settings. All my personal data and settings will be lost!

    I am very unhappy to do so, but no other chance

  • 10. Re: After iphone 4 4.3.3 update wifi not working
    Roger Kaufmann Level 1 Level 1 (25 points)

    Factory reset of the iPhone? Hmmm, well next time you sync with iTunes you should have your content back, at least.

     

    I'm going to hold off on that ... manual channel setting does it for me.

  • 11. Re: After iphone 4 4.3.3 update wifi not working
    AndiXXX Level 1 Level 1 (0 points)

    Factory reset did not work! The iphone can't detect my time capsule WiFi. After the unsuccessful attempt to  connect to the WiFi, I could at least do the sync with iTunes and got my data back. Maybe the problem could be solved by undoing the upgrade to iOS 4.3.3 and reinstalling iOS 4.3.1. Does anyone knows how this has to be done?

  • 12. Re: After iphone 4 4.3.3 update wifi not working
    andrefromportoalegre Level 1 Level 1 (0 points)

    I had the same problem, after update my iphone iOS to 4.3.3 version it could not connect to my home wifi network anymore (but it could connect to wifi at work with no problem), and now it just fail some times, taking like 5 minutes to connect when it fails and the solution was change the Wifi Security from WEP to WPA-PSK/WPA2-PSK. The problem is still there, but now i can use the iPhone at wifi. We hope that the next update fix this problem (i didn't have any problem with 4.3.2 version). My Router is a D-Link DI-524/150.

     

    I have tried reset network settings, reboot router, change channel and nothing works.

  • 13. Re: After iphone 4 4.3.3 update wifi not working
    Steve Langlois Level 1 Level 1 (120 points)

    Thought I would correct myself... resetting worked ok for the hotel I am staying in but then it did not work at Burger King this morning. Very frustrated. I hope Apple understands that this is an issue. They don't make going back all that easy.

  • 14. Re: After iphone 4 4.3.3 update wifi not working
    ivdf Level 1 Level 1 (5 points)

    Same problem here until yesterday. I restored the network settings on my iPhone and now wifi is back to normal. Try it.

1 2 3 Previous Next