Previous 1 7 8 9 10 11 Next 186 Replies Latest reply: Jan 21, 2016 1:25 PM by Sam Katz1 Go to original post Branched to a new discussion.
  • Gordito4u Level 1 (20 points)

    I had very similar issues.  In fact I noticed more issues during prime time viewing and with more popular shows.  Not all movies or shows failed on me.


    I was even able to stream those troubled shows at the same time I had issues on my PCs, iPad, etc without trouble. 


    I suspect that netflix uses a conent delivery network to get their videos out to increase perfomance.  Not all titles stream from the same sources.


    Took me months to figure out.


    I even went as far as to do packet captures during my issues to see what was going on.  Network issues are very hard to pinpoint.  Especially where there is hardware trouble.  Switches will continue to process packets (with errors caused by the switch).  Very hard to locate the issue on a cheap switch other then swapping it out.

  • D.R.C. Level 1 (145 points)


    You're 100% correct that they are using a Content Delivery Network.  Different titles gets served from different servers (depending on load and capactiy), and depending on location. That's why I suspect that changing DNS can impact the result. I also suspect that Netflix has failed to adequately optimize their CDN capacities for subscribers in Canada.  I've read many reports of problems disappearing when the DNS setting was changed from one's ISP-provided DNS to an alternate (Google, Level 3, OpenDNS, etc).


    The Error 139s that I get occur when trying to start playing a title. IE, it's not a streaming issue. It's as if the selected title doesn't happen to be available on the CDN node that my ATV has been directed to.


    My next troubleshooting step is to relocate the ATV to a friend's place: different LAN and different ISP, but same city.

  • Gordito4u Level 1 (20 points)

    Great idea.  Let us know what the results are.



  • Gotsoul..UK Level 1 (0 points)

    I understand this has been covered before but after having the same issue with my netflix on my apple tv2, I chose to try and login to netflix through a computer on the same network as the apple tv and try and watch content. It worked ok so i then went back to my apple tv and the problem seems to be resolved.


    Give it a try, it worked for me.

  • Joseph F. Level 1 (0 points)

    I just got off the phone with tech support. I have the apple tv 3 running software: 5.3 the solution was to unplug the apple tv for 1 minute and plug it back in. The problem was solved! Hopes this helps many!

  • T_N_P Level 1 (0 points)

    Have the problems with atv been with changing the dns locations? I can get Canadian no problem but not us, I understand its the update but all my other apple devices work. Does any one have any suggestions?

  • vazandrew Level 6 (17,986 points)

    If you're getting one and not the other then that would suggest a DNS issue

  • GroovyJunior Level 1 (0 points)

    I have had this problem on and off for over a year. Finally, I tried unplugging the router,  then plugging it back in. Then I unplugged the Apple TV and plugging it back in. That rebooted everything and it works fine now. Next time I will try rebooting the Apple TV rather than unplugging it.

  • larrylintz Level 1 (0 points)

    I tried the last option on this thread but no success.  SOOO frustrated, paying for Netflix AND unblock-us (i'm in Canada) to access US netflix.  No problem accessing netflix on my laptop.  There were periodic "Netflix currently not available" notices but for past week it's been almost though not competely permanent.


    I'm not good with technical stuff and not crazy about messing with DNS numbers as i had to put a special DNS number in to make UNblock-us function.  But anyone who understands this stuff -- please tell me the simplest solution, reading all these options, some of them incomprehensible to me, is almost as frustrating as turning on a useless service. 


    I'm really ****** off with Netflix, i phoned them and they just sent me their trouble-shooting website and blamed my internet connection.  How the f* they aren't aware this is an ongoing problem with many users, and wouldn't acknowledge that to me, is beyond me. 

  • personalized1 Level 1 (0 points)

    yes i have issue with my apple tv.


  • AliceWandersAbout Level 1 (0 points)

    Have the same issue.  Not happy about having to reset the box.  It should actually work as stated.


    This will be the second reset, and last time, it didn't work (so we got a different internet provider, thinking it was network speed).  Still doesn't work.  Everything else seems to be working, just not Netflix (which works fine on computers and devices on the same network, just not Apple TV).

    Too bad, because as with others, it's a primary reason we got the Apple TV box.

  • dialacliche Level 1 (0 points)

    My Apple TV kept dropping signal and restarting and then I would have to press play and in another 20 mins or so it would do it again. I too tried unplugging every item in my entertainment center, then plugging each item back in one at a time (waited 20mins between each plugged item) to see exactly where the problem might stem from in terms of  capsule, tv, Mac mini, etc) and still the problem persisted and to no avail I was extremely frustrated. I even moved each and every  item   (Apple TV, router, time Mac mini....) to different parts of the room to see if the problem was coming interference. Nope that was not the problem. Next I checked all the electrical plugs and wiring and they all worked. Hmmmm! As you can see I am a very patient person but I was dumbfounded so I returned my Apple TV because I thought it was faulty (although it had been working just fine for 6 months after I purchased it) and got a new one. Well the problem persisted. So I again read Trouble Shooting in the back of the the AppleTv instruction book and it mentioned make sure my port connections with my tv were tuned correctly to the input. Yes they were. Then I had an idea to set my tv back to it factory setting. Hallelujah !!!! worked and no more problems.


    The last thing I suggest is  unplugging every hdmi cable connected  (before you returning tv to factory) and as you put each one back in one at a time (go to each input setup) on you television go to the input and return each of those to factory setting before plugging back hdmi cords.....hope this lengthy testimonial helps someone

  • iRonManNCSU Level 1 (0 points)

    Nice work. I noticed the same pattern when streaming from my ATV2.


    Pretty ridiculous this problem persisted over this holiday weekend when i'm sure many families were trying to stream. I have a hard time recommending an AppleTV to friends/family or getting one for people as a gift.

  • iRonManNCSU Level 1 (0 points)

    The first hump is the ATV2 trying to stream Netflix. The second hump is the iPhone 5 streaming netflix, while sending it via AirPlay to the very same ATV2.


    It's pretty clear Netflix on the ATV is horribly broken at this point. I was going to give 2 of them as gifts this year, but I can't in good conscience do that, or even recommend one.


    This is with the static IP settings. Note the first line reprensents about 1.5 Mbps.

    Screen Shot 2013-12-04 at 8.20.50 PM.png

  • bodosom Level 1 (20 points)

    iRonManNCSU wrote:


    The first hump is the ATV2 trying to stream Netflix. The second hump is the iPhone 5 streaming netflix, while sending it via AirPlay to the very same ATV2.

    When you use AirPlay to send Netflix to another device it runs the Netflix client on that device.  The target device authenticates, negotiates a stream and streams directly from a content distribution network.


    Although some folks swear by using AirPlay to work around the current ATV3 issue it's not a reliable solution for me.

Previous 1 7 8 9 10 11 Next