Skip navigation

Cannot activate iMessage

129132 Views 146 Replies Latest reply: Dec 1, 2013 12:55 PM by socialbutterfly112 RSS Branched to a new discussion.
  • CarbonEX2 Calculating status...
    Currently Being Moderated
    Jan 24, 2012 2:50 PM (in response to AverageComputerGuy)

    Thanks alot pipid your solution worked !

    (by the way i figured that this solution only works when a message appears telling you to "check your network connection" This message most likely appears because imessage is blocked in your region and this is why you have to change your DNS settings. if you get a message related to email verification then this solution won't help)

     

    Pipid suggested you try doing this:

     

    1. go to the settings icon on the homescreen.

    2. select wi-fi from the list.

    3. click on the white arrow in a blue circle which should be right next to your networks name.

    4. scroll down and click on DNS.

    5. change your DNS to 8.8.8.8,8.8.4.4 (its important that you right it exactly the way i wrote it, and don't forget there is a comma "," after the fourth "8")

    6. browse the internet ( any website ) to make sure it works.

    7. log back into imessage and it should work now

     

    *thanks again pipid*

  • Aidenarw Calculating status...
    Currently Being Moderated
    Jan 24, 2012 9:10 PM (in response to AverageComputerGuy)

    Right people I had this problem for two days and finally solved it

     

    Right make sure your iDevice is 100% activated in iTunes this is what caused my iMessage to fail.

     

     

     

     

    If your using a jailbroken iDevice feel free to email and I can help with that as it can't be discussed on here

     

    < Email Edited By Host >

  • Zfly Calculating status...
    Currently Being Moderated
    Jan 26, 2012 9:38 PM (in response to AverageComputerGuy)

    I don't know if this has been covered I haven't read all of the replies but I had the exact same issue and then I just restored my iPhone and after iMessage and Facetime worked.

  • Paddyinoz Calculating status...
    Currently Being Moderated
    Jan 28, 2012 11:28 PM (in response to fdm1979)

    Yes Yes Yes. I set my time in General - Settings  to " Set  Automatically  ( ON ) "  and iMessage on my iPad 1works now. Thank you.

  • cheppy Calculating status...
    Currently Being Moderated
    Jan 30, 2012 6:19 AM (in response to AverageComputerGuy)

    I have a solution... without trying the DNS... you should set your date and time automatically

     

    it worked

  • oneredpanther Calculating status...
    Currently Being Moderated
    Feb 1, 2012 10:31 AM (in response to AverageComputerGuy)

    Setting Automatic time zone in general settings fixed both iMessage and Facetime for me!

     

    I've struggled with this for weeks, thank you so much!

  • Kelly75 Calculating status...
    Currently Being Moderated
    Feb 1, 2012 11:26 PM (in response to fdm1979)

    Thank you, fdm1979! Setting the date and time to automatic was the only thing that worked for me!

  • felobazo Calculating status...
    Currently Being Moderated
    Feb 4, 2012 8:24 PM (in response to AverageComputerGuy)

    I know how to solve this, for an achievement in Fruit Ninja, i changed the day, cause i needed to play a game every day for 5 consecutive days. This unselected the "set automatically" button. I saw the last reply and said that turn on the set automatically option, i did it and it worked. I think that it didnt worked cause the message history were too "un-update" (with a 5 day difference), i think thats why it caused this issue. Reply if it worked to u please.

  • kerd01 Calculating status...
    Currently Being Moderated
    Feb 10, 2012 2:28 AM (in response to Aidenarw)

    my e mail is kerd 01@hotmail.com plse tell me!!!!???

  • GPA2012 Calculating status...
    Currently Being Moderated
    Feb 11, 2012 9:24 AM (in response to AverageComputerGuy)

    cheak if you have the wrong password i had the same problom and it worked when i did it again

    if it dose

  • 8weaver Calculating status...
    Currently Being Moderated
    Feb 14, 2012 9:11 PM (in response to Blasphemer1978)

    I agree!!!  After trying forever and spending hours doig research this finally worked. How weird.

  • Night Ed Calculating status...
    Currently Being Moderated
    Feb 19, 2012 11:06 AM (in response to fdm1979)

    Thanks so much for the Date and Time fix. I've been looking for a solution to this for more than a week and this worked straight away...

  • derailedpinoy Calculating status...
    Currently Being Moderated
    Feb 29, 2012 1:18 PM (in response to lbgmailcom)

    thanks it works for me. i tried imessage facetime and viber no problem  for my ipod touch 4g and im thinking this will work with other router? but anyways really appreciate your post! salute from thailand

  • Poopsiedoodle Calculating status...
    Currently Being Moderated
    Mar 7, 2012 6:23 PM (in response to CarbonEX2)

    Well, I tried this, and it put a space after the comma for some reason, and it still says I'm not connected even though I am.

  • indraneel76 Calculating status...
    Currently Being Moderated
    Mar 11, 2012 9:52 PM (in response to fdm1979)

    I am from India. Resetting the date and time settings to Automatic, restoring Facetime first followed by iMessage worked for me. Thanks...

1 ... 6 7 8 9 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.