Previous 1 2 3 4 5 Next 148 Replies Latest reply: Jun 15, 2015 4:13 PM by mrb815 Go to original post Branched to a new discussion.
  • Joen37 Level 1 (0 points)

    Thanks for sharing, after turning on FaceTime, iMessage work now. Was trying to look for a solution, glad to find it here!

  • LesArtistes Level 1 (0 points)

    Go on general/restriction then turn on FaceTime then iMessage will work that's what I did...

  • fdm1979 Level 1 (0 points)

    Ok... This morning, I found out something very ackward.... Something that I'd never link to iMessage issues ! I'll say in advance that this for sure won't solve everyone's problem with iMessage/Facetime but strangely, fixed mine !


    I believe that there are two main troubles with it: Not being able to activate and after activating, not being able to send or receive anything... For me, it had been very strange cause after reseting, I could activate and make it work and after a few hours, stoped... iPhone 4 AND iPad 2...


    After trying everything and reading the forums, I had the answer to my specific case but I think it worth a try to others...(Many people mentioned activating Facetime or changing DNS - which I seriously discarded cause if you are on 3G, you won't have this option)...


    Anyway, this morning I tried to call my girl using Facetime and for my surprise, it said something like "Unable to call ... Check your TIME AND DATE SETTINGS..." So I immediatelly thought: This thing is crazy cause I have everything set ! But, there was one small detail: I'm from Brazil and here, after Saturday to Sunday at midnight, we had summer time change, advancing 1 hour our time in the South/Southeast region. I'm right now in the North of the country where the summer time is not applied. Regarding all my Apple devices, I never set my time and date to "Automatic".


    End of story, after setting it to automatic... BINGO ! I had everything working perfectly !


    I know it sounds nonsense but it's another attempt I'm throwing here for discussions !


    Hope it works for at least some of .

  • lbgmailcom Level 1 (0 points)

    I found that if you go to settings/Wi Fi/(then press the blue button on the right of the network your joined to)/Then look at the numbers to the right of "router" and put these numbers into your internet browser you will come up with a login page put in the password (may be "admin") and then look at the Primary DNS and write this down then insert it into settings/Wi Fi/(blue button)/and then insert the numbers you wrote down into the DNS section.

    If you have trouble logging into your router call customer support for Internet Service Provider (ISP) and find out how to find thE DNS

    Hope this helps all and happy messaging

    oh and this works for FaceTime as well!!!

  • shirleyk88 Level 1 (0 points)

    Thank you. Enabled Facetime in Restrictions. Imessage finally working.

  • alexander293 Level 1 (0 points)

    after one week trying to get imessage activated it worked today.


    what I did:


    1) changed my apple-id password --> apple now requires at least 1 uppercase letter, my old one didn't have one (maybe the issue???)


    2) restarted iphone


    3) settings/message/receive at --> touch the apple-id, log-off, log-on again with the new password and it activated immediately with my phone number.

  • Myverypersonalopinion Level 1 (0 points)

    THANK YOU SO MUCH! after reading your story, i set the 'TIME AND DATE' to 'AUTOMATIC' as you said you did, and IT WORKED PERFECTLY. I now have activated my imessage and facetime as well.


  • kanyiva Level 1 (0 points)

    Thank you! It finally worked.

  • mrstee Level 1 (80 points)

    Ugh. I have my iPad 2's Date and Time set to Automatic and Facetime works. My Apple ID password contains at least one uppercase letter. And yet I can't get Messages to work. The only thing I haven't done is to change the DNS.... A bit reluctant to do that. I don't want to mess up my wi-fi connection to my iPad.    It says something about the person I am trying to send the message to is not registered-she has an iPhone 4. Her name comes up highlighted in red. I tried another person that has an iPhone 4S and her name isn't highlighted in red but when I tap on the blue Send button, nothing happens. Not feeling the love with Messages... Any ideas? Judy

  • lbgmailcom Level 1 (0 points)

    Don't worry about changing the DNS it doesn't stuff up any internet connection but if you get it right it works and gives you additional things and features. Also if it's wrong now then it's not stuffed up is it?

    Hope this helps!

  • mrstee Level 1 (80 points)

    True. Will try it. Thanks for 'holding my hand'! Judy

  • mrstee Level 1 (80 points)

    Changed the DNS. Shut down the iPad. Started up and it's still not working. Before if I had my sister's iPhone number in the To box and typed a short message the Send button would turn blue-it wouldn't send but at least it wasn't grayed out. Now it's grayed out and still not working. Sigh. Heavy sigh. Judy

  • oiled Level 1 (0 points)

    Thank you! Greatttt!

  • Adamb14113 Level 1 (50 points)

    Awesome! The date and time thing worked! I set it to automatic and ka-boom! I also changed the DNS to, but I'm not sure if that had anything to do with it because it didn't fix anything til I set the date and time to automatic.

  • Tommrn Level 1 (0 points)

    My issue is that the messages I send, won't turn into normal messages if the device I'm sending to doesn't have Internet-connection. The message will wait until the other device gets the connection back, which means that it's not possible to send normal messages between iUsers, but it works just fine between an iPhone and a normal phone.. Suggestions?

Previous 1 2 3 4 5 Next