Previous 1 2 3 Next 129 Replies Latest reply: Aug 11, 2015 5:27 AM by aidanmonahan1
clevercubed Level 1 Level 1 (0 points)

After iCloud was introduced, I did this:

  • bought an album on iTunes via my Mac
  • downloaded the album to my iPhone via the iCloud service in the iPhone Music Store
  • Synced my iPhone with my Mac.

 

Now that new album is on my iPhone twice! Well, the album shows up once, but each song is in there 2 times.

 

If I un-check the album in iTunes and sync, it no longer shows as doubled, but now those songs won't play when I'm playing the album in iTunes (since iTunes skips un-checked songs).

 

How do I get the iCloud-downloaded songs OFF my iPhone??


iPhone 4, Mac OS X (10.6.7)
  • istealth Level 1 Level 1 (5 points)

    The exact same thing happened to me just now.  Songs are on my iphone twice, but only show in iTunes once.

  • Linda Custer Level 2 Level 2 (320 points)

    I am having a somewhat similar problem. I am surprised I do not see more people commenting about this.

     

    I turned on iTunes cloud sync on my Mac (iTunes 10.3.1) and on my iPhone and iPad (running the very latest iOS 4 revision). I purchased music on the phone, and it showed up on the iPad and Mac immediately (nice), but then ended up being on the Mac iTunes TWICE once I did a manual sync of the iPhone (and perhaps a third time when I synced with the iPad). OK -- so if I never manually sync, and purchase all my music going forward from Apple, that would be fine. However, until iOS 5 drops for all, I still need to manually sync to back everything else up. Am I supposed to disable music syncing? That presumes I'll never get music from anywhere else and also that I never change playlists or anything else about music organization.

     

    Maybe I've done something wrong, but I don't think so, because all I do is sync. Shouldn't iTunes just work, and just know that the copy on the iPhone is identical to the one on the Mac because they were both pushed due to the same purchase?

     

    Who wants to be deleting duplicates all the time? That's more frustrating than just old-fashioned manual syncing, no?

     

    I've disabled iCloud sync on my Mac, my iPhone, and my iPad, at least until this all gets straightened out.

  • Michael Allbritton Level 6 Level 6 (16,785 points)

    Yeah, getting this done is not intuitive. But here's how you do it:

     

    1. Connect your iDevice to your computer via USB;

    2. On the Summary tab select the option to "manually manage" the media on the iDevice and click Apply;

    3. Expand the menu and select what media you want to delete, such as Music;

    4. Highlight all the songs you want to delete and pull down and right-click (or Control+click) and choose Delete;

    5. When prompted click Remove;

     

    Once all this is done return all the options back to their original options.

  • Joseph Delaney Level 3 Level 3 (590 points)

    Didn't there used to be a "transfer new purchases" option, for when you bought something on your iPod and wanted it to transfer automatically to the mac (prior to icloud)? I can't find that now. But I think it may be "stuck" on, so it's causing a double-sync.

     

    The same thing happens with contacts and calendars if you sync via mobileme but don't turn off the sync-via-usb options. It should be simple to fix, if anyone can find the setting.

  • Spongeman1022 Level 1 Level 1 (10 points)

    I'm still looking for a solution to this and so far none of the Betas have fixed it. It's really annoying to see duplicates of my songs. iCloud is killing me!

  • Joseph Delaney Level 3 Level 3 (590 points)

    Spongeman, try this - go into the iTunes preferences and click "advanced" then click "Reset Warnings". When you sync your ipad, ipod or iphone, it should eventually ask you if you want to automatically transfer new purchases (maybe only if you've purchased something on the ipad, iphone or ipod) - say "no" (since you already have them downloading automatically).

  • Spongeman1022 Level 1 Level 1 (10 points)

    Thank you for the help. Still geting duplicates though. For example, when I add the song (that has been "automatically downloaded" to my Mac) to a specific playlist in iTunes, then sync my iPhone, the song shows up twice in my iPhone Music library. The only solution that I have found is to completely Restore my iPhone, then set it up from a previous back up. It's time consuming, but the songs don't show up duplicated once everything is done. 

  • CAMori Level 1 Level 1 (0 points)

    Ok, here is another person having this problem. 

     

    Every new song I have purchased since turning on iCloud is showing up on my iPod twice.  I have changed the genre on a few of them, and I see the iPod has one version with my edits (and playcounts), and another version with the original info (and no play count). 

     

    I really don't want to have to manually manage my music.  Apple?  Where are you guys on this?

  • георгий Level 1 Level 1 (0 points)

    The exact same problem. The MAC 600 songs on the iPhone in 1200 and did not like and tell me to fix that??

  • bdv91 Level 1 Level 1 (0 points)

    This just happened to me too! This was my solution:

     

    On your iPhone/iTouch:

    Temporary turn off iCloud for Music - Setting > Store > and Automatic Download for Music OFF.

    *Make sure everything you want on your device is on your computer, or you well have to [re-]download that now.*

    Then go to your Music, and Delete songs, albums, or artists by side swiping them (and confirming the delete).

    Next, you will need your USB cable and Sync "the old fashioned way". xD (I'm obviously kidding about it being old fashioned everyone!!!!!)

     

    Duplicates should be gone now; at least it worked for me!   Let me know if it worked/didn't work for you, or you need me to explain steps more!

     

     

    Apple should fix this! Maybe a setting - so if we wanted, we could get a notification asking if we want it to sync "right now" or "later" though iCloud, or "manually" (by a USB cable)!

     

    P.S. Go ahead and take my idea Apple Inc., I know it's a good solution!

  • RolliePohlie Level 1 Level 1 (0 points)

    Having almost the exact same issue except my music wasn't even purchased through the iTunes store. When I re-sync it shows the appropriate amount of music storage but then afterwards it shows double what I have in my library and has duplicated all my songs on my iPhone.

     

    I've tried managing the music library manually and resubmitting all my music into iTunes after removing it. Nothing has fixed it. Hopefully Apple will update something soon.

  • twigboy29 Level 1 Level 1 (0 points)

    Count me in as another victim of duplicate songs purchased from iPhone then iCloud downloaded to iMac.

    Only one copy is on my iMac.

    Even deleting via swiping on iPhone and then syncing only adds the duplicates back.

     

    Quite annoying when I take pride in having exact record of plays and last played times.

     

    Help us Apple!

  • cosmicity Level 1 Level 1 (0 points)

    Yes, me too.  2 of every song purchased since iCloud launch on my iPhone.  I also have this same problem with old (pre-iCloud) calendar entries.  Doubles of all.  I'm a fan of iCloud in theory, but so far this is a pretty crap launch.

  • Anthony Badaracco Level 1 Level 1 (0 points)

    Same here. Duplicates on my new iPhone of everything purchased from the iTunes store.

     

    Any advice, Apple? Would be appreciated.

Previous 1 2 3 Next