Previous 1 2 3 4 Next 48 Replies Latest reply: Dec 30, 2014 4:18 AM by Tarek Hamouda
jamesfrompalos verdes peninsula Level 1 Level 1 (0 points)

iPhone 4 no longer recognized by Windows 7, 64-bit desktop. The iTunes diagnostic shows everything working satisfactorily, and Windows Control Panel, under Devices and Printers, shows the "Apple Mobile Device USB Driver". The Properties for that device show the driver as working properly. However, when I plug the iPhone into a USB port (using both a port and cable that formerly worked fine with this iPhone), Windows attempts to install a driver, and fails. The resulting message is "MTP USB Device Device driver software was not successfully installed". Further investigation gives me a message "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)".


iPhone 4, Windows 7, 64 bit
  • Navigat0 Level 1 Level 1 (0 points)

    I had the same iss - it's a known issue whereby Windows attempts to use the wrong driver to access the phone.

     

     

    BACK UP YOUR REGISTRY!!! Editing the registry can be (read: IS) dangerous and can cause no end of pain if done incorrectly.

     

    - To Back Up your Registry: Click Start menu and click "Run". Type "regedit". Click File, then choose export and type "iphone driver fix registry backup".

    - Click Export and let it export the the registry to a file.

     

    - To fix the issue: Follow the folder tree on the left to: hkeylocalmachine > system > current control set > control > class

    - Find “{EEC5AD98-8080-425F-922A-DABF3DE3F69A}” down the LEFT hand side and click on it.

    - Under the list on the RIGHT hand side find "UpperFilters"

    - Right-Click UpperFilters and click delete

    - Close the registry editor and restart your PC (without the iphone attached).

    - Once restarted and logged back in, plug in your iphone and voila!  Windows will actually choose the correct driver and you'll be in like flynn.

  • Ahall1975 Level 1 Level 1 (0 points)

    Please be advised all who look at this with the dreaded MTP USB error - it works!!!! Iphone 4 with Toshiba Satellie - USB MTP error across the board until I tried this nugget!!! MANY THANKS!!!

  • stemfour Level 1 Level 1 (0 points)

    I dont have the entry "UpperFilters" 

  • Navigat0 Level 1 Level 1 (0 points)

    What is the exact error you are getting?

  • SupersonicDuck Level 1 Level 1 (15 points)

    I have the same problem in windows 7 ultimate 64bit. Not only my iPhone 4 but also a digital camera (Canon EOS) give following messages when I connect them to my pc's USB port:

     

    "installing device driver software", immediately followed by "device driver software was not successfully installed"

     

    Under device manager - portable devices there is an entry " ! iPhone" with a yellow exclamation mark. Double clicking it gives "Reinstall the drivers for this device (Code 18)". When I click the button labelled "reinstall drivers" and search for online drivers I get "the best driver software for your device is already installed" for "MTP USB Device". When I click uninstall drivers button and scan for hardware changes I get same error and this time "This device is not configured correctly (Code 1)"

  • SupersonicDuck Level 1 Level 1 (15 points)

    Complete format and reinstall of windows solved the problem for me!

     

    Since I was not sure whether this would solve the problem I first created a full disk image of my main C: drive so that I could always return to the present state of my pc. Saved the image on external usb hard drive.

     

    Then rebooted the pc with the windows cd in the drive. Deleted the partition, created a new one and then installed windows 7 ultimate 64bit from scratch. After successful install I connected my iphone and now it appears correctly in windows explorer under my computer. Same for my canon camera.

     

    Spent a week reinstalling all my software and until now still works fine, as well as itunes and wifi sync and sh1t.

     

    Maybe user error by using registry cleaners or other cleanup and performance tools, or maybe a bug after a certain windows update, I don't know.

  • madshk Level 1 Level 1 (0 points)

    Just thought I'd mention my experiences with the problems discussed in this thread:

     

    I have an old 2G iPhone Touch with a connector issue which often causes various other problems. But today, it suddenly started acting up with the "Device driver was not... etc." error on Win 7 64-bit. This resulted in iTunes freezing until I disconnected the device. I didn't have the registry key mentioned above in my registry, either.

     

    Fortunately, before trying to apply even more drastic measures I found out all it took to get the device to connect again was a forced restart (press and hold the Sleep/Wake button and the Home button at the same time for at least 10 seconds). D'oh!

     

    Just FYI, at least try this before messing with the registry or reinstalling Windows...

  • angelfinder Level 1 Level 1 (0 points)

    Thanks madshk!  My iphone4 wasn't recognized after an iTunes update to 10.6 - I just restarted it while it was connected to the Win 7 pc and it suddenly became available.

  • auto-xr Level 1 Level 1 (0 points)

    Like some of the people above, I didn't have the problematic Registry Entry.  After some searching, I found this article. It is one of the best articles on how to fix this annoying problem (obviously Microsoft's idea of messing with Apple).

     

    http://support.apple.com/kb/TS1538

     

    Note: Windows 7 Enterprise 64bit. iphone 4S. iTunes 10.6.3.25

     

    While it didn't exactly describe how to fix my issue, it helped point me in the right direction.  Here is what did to fix my issue.

     

    1. Open up Device Manager

    2. Portable Devices > Apple iPhone (in my case had an exclamation point on it)

    3. Uninstall the driver.

    4. Right click on the the computer in Device Manger and scan for hardware changes.

    5. Go back to Portable Devices.  If this works for you, the Apple iPhone icon should not have any exclamation points any longer and it will be accessible via My Computer.

     

    Good Luck.

  • vince_is_here Level 1 Level 1 (0 points)

    I tried the regedit thing but "UpperFilters" is not listed in that folder at all? What else can I do.. I went to the device manager and uninstalled the driver and then refresh to look for new devices.. But just came back with the same problem.. Any other suggestions?

    Vince

    vince_is_here@hotmail.com

  • SwissBank Level 1 Level 1 (0 points)

    auto-xr, I hope that you see this ... .....!

     

    Thanks very much for your advice.

     

    It saved me a lot of time and trouble.

     

    What a relief that I could fix it myself.

     

    Best wishes,  SwissBank

  • kjolnir Level 1 Level 1 (0 points)

    auto-xr, your suggestion fixed my problem perfectly.  Thank you!

  • redsoccerteam Level 1 Level 1 (0 points)

    Many Thanks auto-xr! I was this close to re-installing Windows.

  • Vanzelot Level 1 Level 1 (0 points)

    This problem is very simple to solve. NO UNINSTALLATION REQUIRED.

     

    If your experiencing with this problem, please follow the steps below:

     

    1. Completely Turn-OFF your Apple Device (iphone, ipod touch or ipad)

     

    2. Connect your Apple device to your windows PC or laptop USB.

     

    3. Once it is connected, your apple device will turn-ON automatically.

     

    4. Once it is ON, Enter your password or if you have. You will notice "Installation of driver" at the right side of your task bar. (icons located below at the right side of your monitor near the clock)

     

    5. While it is installing, wait for the Notice "Failed Installing the driver".

     

    6. Do not close the message.

     

    7. Right click My Computer and click Manage. Click Device Manager and right click "Universal Serial Bus Controllers" then click Scan for hardware Changes"

     

    8. After that, you will notice, windows will again "Install the driver".

     

    9. Driver Installation Successful.

     

    10. Right now, you can open and view your pictures from your Apple device in your computer.

     

    Note: The good thing of this solution is you can apply it in any windows OS computer where you get an error or problem once you connect your Apple device in it.

     

    I hope this will help.

     

    Message was edited by: Vanzelot

Previous 1 2 3 4 Next