Previous 1 2 3 Next 93 Replies Latest reply: Jul 27, 2013 10:18 AM by Denbo_1
melodysnowleopard Level 1 Level 1

I just installed the latest update to safari. Now it crashes almost right away.. I have it set up to open in top sites. I click on any page it goes grey to bring the page forward, then crashes. When I end program, I notice I have in my windows task manager under processes webkit2webprocess.exe. I've tried to open safari a couple times, only to have it crash every time. After trying three times, I have ended safari program, only to have three of these webkit2webprocess files still showing up on my task manager processes. What's going on?!

Safari, Windows XP
  • Jonathan Hieneman Level 1 Level 1

    I am having the same problem.  Thought it might be a firewall issue, but I disabled the firewall briefly to test and the same problem continued to occur.  I notice that when Safari is attempting to connect, both safari and the webkit2webprocess.exe processes become resource hogs.  The webkit is pulling 50% of my dual core processor.  That seems to be where the hang up is occurring.

  • Brian Wiltshire Level 1 Level 1

    Same here on 2 of my Win7 machines that I've upgraded to Safari 5.1. Holding off on PC number 3 until this is resolved.

  • alexanderfromkiev Level 1 Level 1

    I have the same on my Windows 7 machine... WebKit2WebProcess.exe error pop-up.

    On MacBook Pro works fine without any messages.

  • Fallen Anjel Level 1 Level 1

    Yup, I got the same thing, but it seems to only happen with my Proboards message board, which has Java Script enabled, so I wonder if it's anything to do with JS.   I am able to go on any other site (including Facebook and here) and have no problems.  


    I just updated Safari on the 21st and first noticed the Web2Webprocess tonight.  


    I am on a Gateway m7301u Windows Vista Home Premium X64 laptop.   I haven't tried it on my Asus Win 7 laptop yet. 

  • elceph Level 1 Level 1

    I have the same problem... Now, what can I do about it? Should I revert to Safari 4?

  • Brian Wiltshire Level 1 Level 1

    I did a lot of troubleshooting of this problem yesterday and came to no conclusions, other than the updates caused some major complications, at least on some Win7 systems.


    I've tried disabling all non-MS services and startup items. Also Safe Mode with Networking. I've messed with the firewall, turning it off, and also adding WebKit2 to allow. Nothing makes any difference.


    Right now, my desktop Core 2 Quad with Win7 x64 system has Safari uninstalled, and seems OK, except that MobileMe Sync runs at 25% CPU load until I end the process. I've disabled sync for the time being.


    My laptop, which has Win7 x86 and AMD Athlon X2, still has some issues after uninstalling Safari. AppleMobileDevice service runs at 50% and so does PC Tools service (related to Spyware Doctor with Antivirus...I have this on all 3 of my PCs). This maxes out the CPU, of course, until I end the AppleMobileDevice process. I have set this service to Manual in Services. Hopefully this will resolve further issues until a fix is found.


    My main PC with Win 7 x64 and Core i5 760 has not been updated and will remain so for the time being.


    Thankfully, my Mac Pro 1,1 has enjoyed a smooth transition to Lion and am enjoying all the great things about the new software.


    As for installing an earlier version of Safari, I haven't been able to find one on Apple's site. The download link to Safari 5.0 takes me to the 5.1 link. I'm using Firefox in the meantime on the PCs.

  • elceph Level 1 Level 1

    Yeah ok... Well, I'm no computer wiz or anything, I have a 3-year old custom-made clone... I've never been attracted to Apple products in the past. However, I started using Safari when I had trouble with Explorer (don't remember which version), because a guy at a store recommended it to me and I've got to say, he was right. Before this problem, I considered Safari excellent and I wouldn't want to switch to another browser...


    Anyway, I know Safari 4 isn't available on Apple's website, but it can be found somewhere else on the net, no? Or is this too risky of «catching» a virus or something in the like?

  • Fallen Anjel Level 1 Level 1

    Try   I haven't looked yet, but I will.  I am thinking of reverting back to 5.0 or 4.0 until this is resolved.


    Either that, or I'll either switch back to Explorer, or start using Google Chrome more.

  • inesinhh Level 1 Level 1

    I also have problems since I downloaded the Safari update yesterday.  For instance, I can open my hotmail all right but whenever I write an e-mail it shows the webkit2webprocess.exe error and it closes the window.  I have Safari since I bought an iPhone last year, but must admit I was much happier with Chrome.  Do I have to use Safari for my iPhone sync and updates?

  • Brian Wiltshire Level 1 Level 1

    You don't need Safari, but you do need iTunes to sync. That is, until iOS 5 is released in the near future.

  • ade_m Level 1 Level 1

    I've got the similar issue.  I updated Safari and iTunes at the same time on my Win 7-64bit Macbook... and now this process consumes 50% CPU whenever I try to use Safari - and I can't actually reach any website.

    My firewall tools tell me that safari.exe is opening TCP sockets to the remote site, but it never sends any data to the server, so no response comes back. Safari just sits there doing nothing.


    iTunes seems to suffer the same problem, but its the AppleMobileDeviceService.exe process that seems to hog the CPU, but again, iTunes can't reach the Stores at all.


    No other programs on the PC having any issues.  Just Apple..

  • Brian Wiltshire Level 1 Level 1

    I wonder what the common things are on these computers? Since I have updated 2 of my 3 PCs, both have experienced the same issues. It doesn't seem to be a software or driver conflict since Safe Mode with Networking experiences the same issues. It doesn't seem to be a hardware issue since both those PCs are entirely different. One is a Core2Quad desktop with Gigabyte P45 mobo and Radeon 5750 graphics, Win7 x64. The other one is an Athlon X2 notebook with nVidia 9100M graphics, Win7 x86. It must be more related to how WebKit is reacting with Win 7 somehow.


    Of course, my Macs with Lion are running with no issues whatsoever. LOL

  • 100 Watt Walrus Level 1 Level 1

    This seems to be the way Safari 5.1 interacts with the web:

  (bottom of the page)

    New Process Architecture

    Everything you do in Safari is more stable and responsive. The new process architecture divides the heavy lifting for smoother sailing. One process handles everything coming from or going to the web, while the other manages interactions with the Safari interface — such as creating a bookmark or searching your history. Now an unresponsive website won’t affect Safari, so you can keep browsing and browsing.

  • inesinhh Level 1 Level 1

    ha ha ha, that's funny!  I still can't write e-mails, so after trying different things I'll just have to de-install Safari and install it again.  Hope that works.  By the way, I called Apple Support and they didn't know what I was talking about, apparently nobody had this complaint so far.

Previous 1 2 3 Next