Previous 1 2 3 4 5 6 7 Next 93 Replies Latest reply: Jul 27, 2013 10:18 AM by Denbo_1 Go to original post
  • shqtth Level 1 Level 1 (0 points)

    Basically, safari is not able to access the inernet. I turned off the firewall, no change.

     

     

    I know this becuase it says connecting. So I go open a new tab, and close the home page tab. All my quick launch/previews are there, but if I click on one it says connecting, and it never loads.

  • shqtth Level 1 Level 1 (0 points)

    Opening a new tab, then closing the start page tab (first tab), makes the cpu usage drop. And WebKit2WebProcess is no longer using cpu usage. (safari is notr using the internet hence it is not using cpu usage)

  • Blue Ghost Level 1 Level 1 (0 points)

    That does seem to work.

  • DrDtroit Level 1 Level 1 (0 points)

    I'm getting the same thing (WebKit2WebProcess.exe error) *every* time I access Google Maps now that I have updated Safari... I'm thinking of going back to the old version.

     

    So far with the new Safari

    - sometimes will not open (but the Safari process is running)

    - will often open and then take upwards of 60s to open the first page

    - had two force-closes (even though I just upgraded Friday)

    - WebKit2WebProcess.exe error when I visit Google Maps... which is made even more annoying in that it attempts to reload the page... I get the error... send the report... automatically reloads the page... get the error... send the report... reloads automatically... get the error...ugh. I have to go to Task Manager and kill the process.

     

    *** happened, Apple?

  • NovaMan Level 1 Level 1 (0 points)

    About a month ago my iTunes store stopped loading.   First on my XP computer, then on my Windows 7.  I just noticed tonight Safari does not load on either.   I noticed that Webkit2webprocess.exe was using alot of resources.  After this email chain it is real clear the Safari 5.1 update and Webkit2webprocess.exe is the problem.  I also noticed no Apple response on this.  Hmmm.  And my Apple Software update is corrupted and will not load Safari 4.  So I cannot "buy" anything from the Apple Store.   I get stuff elsewhere.  And not use Safari.  It will be interesting to see if Apple has any solution to this.  I may call and "pay" somebody to determine something.  Too much!

  • jakkals2011 Level 1 Level 1 (0 points)

    im experiencing the same  problem.  initially I thought it was facebook virus as another user used my connection to open facebook.  there has been a significant increase in lag as it uses up to 300mb of memory and im on a old computer(windows xp pro )with only about 500 mb memory available which was more than enough for work. 

    previously i spotted a similar virus that was disguised as a windows process and that also used the cpu.  as far as i know your processes shouldnt use the cpu.

    furthermore there has also been a increase in cap use and im wondering if this process isnt the culprit.

    Btw it has only been evident on this computer. my home computer is a new computer with 3gigs ram and a ssd hdd which rockets its performance.  Safari loads instantenous there and i experience no lag.  cant recall this on  my home laptop as well which has about 1 gig ram.  so wondering if it is somehow related to the koobface virus .  perhaps a safari version.  But yes switching browsers seems to be a definite option.  perhaps i would suggest a lite version of safari if this feature is targeted at windows 7 functionality and newer types of computers.

  • Anavel0 Level 1 Level 1 (0 points)

    I had tried nearly everything on my XP machine, with service pack 3 and all other major updates, to fix the WebKit2Process.exe error.

     

    Just tried uninstalling Windows Live Essentials (just Live Messenger part), and the issue stopped instantly. I didn't eve have to restart my computer.

     

    Just go in to Control Panel, then Add/Remove Software. Choose Windows Live Essentials, then click remove. It gives a choose of which components to uninstall. Select just the messenger and click unisntall.

     

    Worked like a charm for me. Hope this helps everyone else too.

  • DrDtroit Level 1 Level 1 (0 points)

    I'm glad that tricked worked on your machine... and I hope it lasts. My machine (XP... work machine) doesnt have Windows Live Essentials or Windows Messenger installed at all (never did) and I have the issue... so either it's pure chance / timing that you fixed worked, or there are multiple ways this error happens... *sigh*

  • NovaMan Level 1 Level 1 (0 points)

    I just tried that on mine, but it did not help.   Again iTunes Store and Safari stopped on my XP machine and my Windows 7 one.   Works fine on the iMac.   What a surprise!    And since I am using the iMac, I can just blow off iTunes on the Windows ones.   I can get away doing that.  But what a pain otherwise.

  • AKAJEF Level 1 Level 1 (15 points)

    The new features in Safari 5.1 does not work in Windows. Rediculous!

     

    Why do Apple even bother to make an upgrade when it doesn't work properly anyway. Everyone who still want to use Safari here in this thread, make sure you never update Safari in the future. I will definitively revert back to the previous version. Once reverting, do I just download the previous version or is it other ways to work around it?

  • marywebsurfer Level 1 Level 1 (0 points)

    I'm having the same problem, but not so much Safari crashing but other sites, such as Facebook, Snapfish, etc. I'm not a computer geek, so if someone could (in simple English) tell me how to fix the problem I would very much appreciate it. I'm running Safari 5.1.1.  on my HP Pavillion running Windows Vista with Service Pack 2.  HELP!

  • AKAJEF Level 1 Level 1 (15 points)

    Hi

     

    But I think in the new update which I update two or three days ago solve the WebKit2WebProcess.exe problem.

    I'm using Safari 5.1.1 now and I don't have any problems now.

     

    http://support.apple.com/kb/DL1070

     

    AKAJEF

  • hel_len Level 1 Level 1 (0 points)

    Yes, after the upgrade "everything" worked, but ...

     

    2Gb / 2GHz (Win 7/32) my PC is not enough for normal work in Safari and other programs simultaneously.

    Safari eats twice::: Safari.exe + WebKit2WebProcess.exe

    =>

    revert to 5.05 - all flies.

  • AKAJEF Level 1 Level 1 (15 points)

    But but but...

     

    Now it's Safari version 5.1.1. This version works perfect. There was a problem with WebKit2WebProcess.exe process in the previous version. 5.1.0 I think or only 5.1. I don't think it's necessary to revert back to version 5.0.5 anymore.

  • Brian Wiltshire Level 1 Level 1 (10 points)

    I have resolved all issues with Safari, WebKit2, iTunes, iCloud, and other Apple software on my PCs. The culprit seemed to be my anti-virus, Spyware Dr. with Antivirus. After upgrading to the latest version (2012), all is well again. I confirmed on PCTools discussion forum that the previous 2011 versions of Spyware Dr. with Antivirus was indeed incompatible with Safari and the other Apple software. Previous to upgrading Spyware Dr. I was unable to use Safari or even iTunes as it caused my CPU to max out. I was also unable to sign into iCloud, with the error there was a server error being reported from iCloud control panel.

     

    Much relieved!