Skip navigation

error reading settings in wiki and profile manager

25992 Views 33 Replies Latest reply: Sep 20, 2013 8:15 PM by jugalbandi RSS
1 2 3 Previous Next
er33 Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 21, 2011 10:10 AM

I have just upgraded from Snow Leopard Server to Lion server.


I now have the following errors in server app:-


Wiki : message "Error Reading Settings"

Profile Manager: message  "Error Reading Settings"


What do I do to get my wiki back!


When I visit my default ssl Wiki I get the following:-

Collaboration::PGCConnectionError in Sources#index

Showing /usr/share/collabd/coreclient/app/views/layouts/application.html.erb where line #5 raised:

FATAL:  role "collab" does not exist


Extracted source (around line #5):

2:      :user => @user,3:      :entity => @entity,4:      :owner => @owner,5:      :service_client => service_client,6:      :controller => controller7: }) %>8: 



Rails.root: /usr/share/collabd/coreclient

Application Trace | Framework Trace | Full Trace
app/controllers/application_controller.rb:325:in `service_client'app/views/layouts/application.html.erb:5:in `_app_views_layouts_application_html_erb___1616978790_2215846900_0'app/controllers/application_controller.rb:44:in `render_server_error'app/controllers/application_controller.rb:43:in `render_server_error'






Show session dump

Show env dump






Please help

osx server, server
  • Alexander Weiss Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 21, 2011 1:12 PM (in response to er33)

    I don't know about the Wiki, but my Profile Manager also had the Error Reading Settings error.

    I found a shell script named wipeDB and ran it. It now works again, though my profiles are gone of course.


    I ran the following in terminal; sh /usr/share/devicemgr/backend/

    It'll empty the db and the error was gone for me.

  • coolspider88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2011 10:35 PM (in response to er33)

    samething here,


    Collaboration::PGCConnectionError in Sources#index

    Showing /usr/share/collabd/coreclient/app/views/layouts/application.html.erb where line #5 raised:



    no chance to recover wiki is just nor working, wondering if Apple could fix that I like the old server much more



  • Spinland Level 1 Level 1 (50 points)

    After running all fo the scripts in the directory mentioned in the following thread my similar problems went away:


  • rickblackdog Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 19, 2011 2:17 AM (in response to Spinland)

    Had to fight with this myself, after running the I ran this...


    sudo launchctl load -w /System/Library/LaunchDaemons/


    All sorted.

  • MDallimore Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 10, 2011 6:06 AM (in response to er33)

    I agree with @e33. I don't think Lion Server is ready. I have a clean install and like you I have these issues, expect I can't move to 10.6. I have the Wiki and Profile Manager errors, and despite a Lion reinstall, disk wipe, restore from a back up I can't get these services to work.


    This is the first real trouble I've ever had from a Mac product. It's a real shame.


    Thoughts anyone on what I could do next?

  • Spinland Level 1 Level 1 (50 points)

    Have you tried running the setup scripts described in the thread I linked above?

  • Spinland Level 1 Level 1 (50 points)

    Note there are some dependencies. If a script gives you errors skip it and try again at the last.

  • MDallimore Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 10, 2011 7:17 AM (in response to er33)

    Hi Spinland I have tried you can tell get a little fustrated. Machine is under one week old....


  • Spinland Level 1 Level 1 (50 points)

    Sorry it didn't work, and I can relate about Lion Server being frustrating. If I wanted to play scavenger hunt through obscure read me files and Internet forum posts to get things working right I would have gone with Linux instead of with Lion.

  • hendogg02 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2011 7:02 PM (in response to er33)

    I ran Disk Repair Permissions in Disk Utility and it fixed everything locally until I tried to access it remotely with the Server App and then it became corrupt again. Not sure why it worked momentarily.

  • andrew2011 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2011 2:28 AM (in response to er33)

    I have also had the 'Error reading settings' problem in Profile Manager, despite trying everything in the discussions and clean reinstalls (which work for a little while only).


    It seems that various different fixes work for some people but not others; and the underlying cause of the problem has not been resolved.


    There are now numerous threads on this problem (there are yet others with similar problems):



    I have posted this in each to try and pull things together a bit.


    Does anyone know if Apple has acknowledged the issue and offered an official response?

  • biolayer Calculating status...

    I have contacted apple support about my problem with services "error reading settings" and they said my issue was due to me changing my IP address after the initial setup screen. So I have had to reinstall yet again, fingers crossed the issue doesn't persist now! His advice was to image a 'virgin' copy of Lion so I don't have to re-download again if I'm still having trouble. What I don't get is when you do change the IP the server app tells you and give you the option to recover/reset the services??


    Hope this helps others too

  • bloofish47 Calculating status...
    Currently Being Moderated
    Nov 3, 2011 9:34 PM (in response to er33)

    I did a clean install of Lion/Lion Server, but I ran ino the same problem too with "Error Reading Settings" for both the profile manager and the wiki.


    INVESTIGATION: I checked to see if the postgres database (which I presumed was were the settings were being read from).



    # sudo serveradmin fullstatus postgres

    postgres:dataDirHasBeenInitialized = yes

    postgres:PG_VERSION = "9.0.4"

    postgres:dataDir = "/var/pgsql"

    postgres:postgresIsResponding = no     # !!! why isn't it responding???

    postgres:dataDirIsDirectory = yes

    postgres:PGserverVersion = 0

    postgres:dataDirExists = yes

    postgres:setStateVersion = 1

    postgres:state = "RUNNING"



    PROBLEM: The postgres service hadn't been started properly; I found this by doing the following:



    # sudo serveradmin stop postgres

    postgres:state = "STOPPED"

    # sudo serveradmin start postgres




    FIX: The postgres service couldn't create the log file because it didn't have permission. I did this to fix it, then simply restarted it and all was well:



    # sudo chmod 777 /Library/Logs/

    # sudo serveradmin start postgres

    postgres:state = "RUNNING"



    I hope this helps someone.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (7)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.