Previous 1 2 3 Next 84 Replies Latest reply: Mar 20, 2015 12:17 PM by Gib Henry
Easybourne Level 1 Level 1 (110 points)

Since upgrading to Lion I've noticed an oddity when I do a 'Get Info' on any of my files.

 

It appears there is a Group that the system can't identify. The Sharing & Permissions section displays 'Fetching…' but never actually resolves this into a Group name. Here's a screen grab.

 

Fetching.jpg

This is only happening on one of the two Macs I upraded and while it doesn't seem to be causing any problems in the context of daily use, I'd like to get to the bottom of it if possible.

 

Any ideas?


iMac 27" 3.06 C2D, iMac 24" 2.8 GHz, Mac OS X (10.6.5), Time Capsule 1TB; AppleTV 160GB; iPod Touch 2nd Gen 32GB; iMac G
  • wgrahame Level 1 Level 1 (75 points)

    Same problem here, any solutions?

  • jsd2 Level 5 Level 5 (6,200 points)

    It's apparently a minor bug, and has been reported to Apple.

    Newly created users in Leopard, Snow Leopard, and Lion have "staff" as their primary group, but users left over from Tiger have a primary group that has the same name as the username.  In my system, files and folders created by Tiger-originated accounts show the proper ownerships in Terminal, but if you Get Info from Lion's Finder, the Sharing & Permissions section apparently can't find the proper group name, and continues to display "Fetching…"  If I create a new account, it correctly shows "staff" as the group.

  • Easybourne Level 1 Level 1 (110 points)

    Thanks for the helpful explanation.

     

    Seems like I shouln't be too concerned about it then. So far it has had no noticeable effect on anything, so I expect it'll get fixed in a point update.

     

    Thanks again.

  • snoofox Level 1 Level 1 (0 points)

    strange, noticed the same and somehow it was to do with this post: https://discussions.apple.com/thread/3202232

     

    Files that do have the "fetching..." permission can be copied, files without it cannot... (confirmed ist both on my external HDD and SD card, same effect!)

  • cosmo-lv Level 1 Level 1 (0 points)

    Same problem here, i connot copy or write in my external disks hope apple it correct somehow or there are some fix for that?

  • maxcasal Level 1 Level 1 (35 points)

    Same problem.

    It is the casa my account has been inherited from Tiger.

    I hope they will fix it...even if everything is working fine.

  • Xoncention Level 1 Level 1 (0 points)

    Whatever you do, don't remove the "fetching" user.  I added my own name and took ownership of the resources etc, then deleted the "fetching" credentials - result - could not log back onto my Mac.  Had to get back on using the disk utilities, restore permissions etc.  I have since found that there are permission issues with upgrading to Lion that are still being worked through - so it seems that we are left with this problem for a while yet.  The 10.7.1 OS X update did not resolve this issue.

  • rpowellweb Level 1 Level 1 (0 points)

    It is worse than that for me. I cannot delete some files (mostly downloaded from the net). When I get info the permissions say 'fetching' and an attempt to delete them results in 'file can't be found error -43.

     

    Strangely. if I change the name I can sometimes delete them.

     

    This sounds like it is connected to the Lion permissions bug....

  • Andrew Dumke Level 1 Level 1 (105 points)

    If you are comfortable with Terminal, do the following:

     

         1) Fire up Terminal and type:

           $ id

         uid=501(andrew) gid=501(andrew)        groups=501(andrew),402(com.apple.sharepoint.group.1),401(com.apple.access_scree nsharing),403(com.apple.sharepoint.group.2),12(everyone),20(staff),33(_appstore) ,61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),10 0(_lpoperator),204(_developer)

     

    The "id" cammand shows your group membership. Sometimes, the membership to "staff" is lost in the upgrade. If that happened, try:

     

          $ sudo dscl . append /Groups/staff GroupMembership `whoami`

     

    That will restore your membership to the "staff" group and should cause the 'fetching...' thing to go away.

  • rpowellweb Level 1 Level 1 (0 points)

    Thanks Andrew, I was not a member of staff and now I am - but it didn't fix the 'fetching' issue, or my original problem.

     

    Any other thoughts?

     

    Thanks

     

    Russell

  • Garrett Howe Level 1 Level 1 (25 points)

    I had this fetching problem and did figure out a way to resolve it. My situation was as follows.

     

    1 - sparsebundle backup of my imac on my time capsule

    2 - Had wiped my imac and installed freash copy of lion.

    3 - Trying to pull out and restore individual items/files from sparsebundle images rather than importing everything from the time capsule backup. (like to start a new OS on a clean slate)

    4 - Can't see items in my time capsule backup because they show up as fetching and have the red cicle with the line through it. So for instance I want items from my documents folder but I can't see what is in it. ~/documents. Not all folders had this issue just some. Documents / music folders were screwed but ~/pictures was somehow fine. *shrug*

     

    Solution -

     

    Create a new folder at the root level of the Imac's hard drive. For some reason a folder in my home folder will not work. Example = I created a folder /stuff. It will requires you to enter admin rights just to make this folder and then it should show up correctly with you as the owner. Or even if it doesn't so long as it has permissions that aren't stuck on fetching, you can manipulate and fix them.

     

    Next copy the entire documents folder into this new folder. COPY do not move, if don't see the + symbol when dragging and dropping its a move not a copy. When done it will still show up with the line through it and you can't see inside it and you still can't use it. This is to be expected.

     

    Next copy the entire folder AGAIN to any folder inside your home directory. Now the folder shows up correctly with no red line and has the proper permissions.  However, it may contain items/folders that are still screwed up. I had to do this for several folders and some were more messed up than others. Now that the main folder has correct permissions I can do apply to enclosed items and that corrects all items within. At that point you can move/copy the files/folders wherever you want and permissions should be good to go.

     

    This wont fix browsing of time machine backup files and/or searching them. But worst case if you know what you are looking for you can get it still.

     

    This procedure worked for me for numerous folders. Again I tried just going straight to a folder in my home directory from the sparsebundle but for some reason this simply woudln't work. Only worked if I copied to a folder outside of my home directory.

  • Deep Sky Diver Level 1 Level 1 (0 points)

    This "minor" bug is causing *major* problems when a Tiger user (with full administrator's rights) is migrated (through Leopard and Snow Leopard previously) to Lion.  Whenever that (old Tiger) user is trying to restore folders from a Time Machine backup, only the folder itself is restored and not its contents.  The error being displayed reads "The operation cannot be completed because you don't have permission to access [filename]".  Strangely enough, restoring files individually (directly from within the folder) seems to work flawlessly.

     

    I have been doing some tests during the last few days and have narrowed down the restore problem to this "Fetching..." user or group.

     

    On my system I had previously (under Snow Leopard) created a second account, for testing and de-bugging purposes.  This account seems to have been migrated to Lion flawlessly, as it can restore the very same folders and files without any problems!

     

    Moreover, when I look from within the old "Tiger" user account at the "Get Info" panel's sharing and permissions settings of the files that are subject to this "permissions" bug, the "Fetching..." user or group is present.  When I look at the very same files from within the new (SL > Lion) user account, the "Fetching..." user or group is replaced by "staff".

     

    Also, the old user account's primary group ID is "501" (identical to its UID), as to be expected in Tiger... but perhaps not in Lion!  The new user's primary group ID is "staff" (which is to be expected).

     

    Summarizing my situation concerning the "old" Tiger user, having been migrated to Lion (during a normal and seemingly flawless upgrade some months ago): that user can write and read any file in any program he's using so far, he can write and read to external hard disks, he can backup using TM, but he cannot restore most of the folders from the same TM backup without running in the permissions error and thus ending up with empty folders being restored without their contents...  This is making Time Machine's backups under Lion totally unreliable!  In my opinion, an *enormous* bug that should be dealt with as a top priority.

     

    FYI: Erasing the TM backups (using Disk Utility to re-format the TM external drive) and starting a new TM backup from scratch did not resolve or alter this issue.  Neither did repairing permissions on my HD make any difference.

     

    What I haven't tried yet (but I'm very reluctant to proceed with it as I have no time to become a debugging programmer for Apple) is to do a "Reset Home Directory Permissions and ACLs" from within the Mac OS X Utilities Screen, and then, obviously, start a brand new Time Machine backup, yet again.  Unless someone with far more experience can tell me this should be the solution.

     

    A second, even more drastical approach would be to go into Terminal, create a new user home directory, clone ("ditto") the old Tiger user home directory to that newly created home directory, then exit Terminal, go into Users and Groups in System Preferences and create the new user for that new directory.  But I would like to refrain from doing that as it might cause other perhaps unforseeable issues.

     

    As far as I can tell, all user accounts having been created under Tiger and having been migrated (through Leopard and Snow Leopard) to Lion, are or will be suffering from this huge restore problem within Time Machine, obviously connected to the "Fetching..." user or group issue.

  • Krissypaps Level 1 Level 1 (0 points)

    Wow.  I too have seen "Fetching . . ."  when using Get Info.  My MacBook Pro dates back to late 2006 and came with Tiger, which I later upgraded to Leopard, Snow Leopard and then Lion.  The transition has gone without any issues whatsover, or so I thought.  Now I'm wondering if my Time Machine backups are actually worthless.  Is there an easy way to test this without actually trying to attempt a full restore from the Time Machine backup?

  • Deep Sky Diver Level 1 Level 1 (0 points)

    Yes, it is possible and rather easy to test this without any need for a full or partial restore. 

     

    You can test it out in both ways: either by using the TM interface and opening a backup from any date that is listed, or by dragging and dropping a backed-up folder from a Finder window.  Again: any file by itself can be restored flawlessly, but one can not (always) restore a whole folder together with its contents (see below which folders can be restored without a glitch and which ones cannot).

     

    When trying to restore a folder together with its contents in one go, be sure to choose a folder that you have created yourself in the past (*before* Lion was installed on your system!) and that has been deleted by yourself (so it's not present anymore on your current system, except on TM's backup drive).

     

    Now simply go into the TM interface and browse back to the chosen folder, select the folder and then click on "Restore".  If you use the alternative method by opening a Finder window, opening TM's backup disk, and then browsing all your way through to the folder in question, you can simply drag & drop that folder onto your desktop and wait to see what happens. 

     

    The folder itself will indeed be copied to your desktop but all or most of its contents will not because a pop-up window will open and tell you that "The operation cannot be completed because you don't have permission to access [filename]"...  The result is that the copied folder on your desktop remains empty or (sometimes) contains a few of the files that reside within. 

     

    Try to restore several different folders from several different locations, all to your desktop, and see what happens.  Try also folders that were created recently (after Lion was installed).  Some folders are restored flawlessly, others are not. 

     

    It seems to be very random... but it isn't!  Folders containing files that do *not* have the "Fetching..." group in the Sharing & Permissions list of their "Get Info" window, but instead have the "wheel" group listed, will not be restored with their contents - only the empty folder itself will.  Folders containing files with the "Fetching..." group listed in the "Get Info" permissions list, will be restored normally, with their contents.

     

    To repeat it once more: restoring the files themselves from within any folder *will* always work.  The problem happens when trying to restore "certain" folders with "certain" files within them, as a whole.

     

    This is apparently a permissions' problem, but quite a weird one, because it's only happening within TM backups and only (so far as I can tell) when trying to restore complete folders with their contents.  Anything else, e.g. creating, deleting, changing, renaming, editing... folders and files on my Lion system works flawlessly.  Restoring complete folders from a TM backup is a mess.

     

    One more clue pointing at a very serious permission problem for "migrated Tiger users" who are trying to restore folders from a current Lion TM backup, is that I have no problem whatsoever restoring complete folders together with all their files from a second user account that I created when my iMac was running Snow Leopard.

     

    I seriously hope that the Apple Team is working hard to fix this very disturbing problem.

Previous 1 2 3 Next