1 2 3 4 Previous Next 48 Replies Latest reply: May 13, 2014 7:23 AM by gianic
jonathan612 Level 1 Level 1 (0 points)

I have a 27inch 2.7Ghz mid 11 model w Lion and iTunes 10.4. Getting an error message from iTunes "This movie requires QuickTime, which is not supported by this version of iTunes." Happens to some video podcast. For example, I did a search on el bulli and came across a list of Podcast Episodes. Video:A Day at El Bulli Book Lunch Party works but El Bulli: Cocina conc... by Emprendedores does not.

 

I must point out that it also says that I can not gather any information on Emprendedores because it's not available in the Australia Store, not sure if that's the reason why I can not view the video.


iMac, Mac OS X (10.7)
  • 1. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Tomeranaray Level 1 Level 1 (80 points)

    The easiest solution seems to be to run iTunes in 32bit.

    - Close iTunes, right-click it in Finder and go to "Get info"

    - click the "open in 32-bit mode" option

    - restart iTunes

     

    This seems to be related to plugins that are not 64-bit compatible yet.

  • 2. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    derrenvt Level 1 Level 1 (0 points)

    I was receiving the same error message after updating 3 of my macs to Lion. Switching to 32 bit mode made no difference whatsoever. I suspect my situation is quite different and I'll post my solution here just in case anyone else has such a wacked out installation as mine.

     

    Here's my situation:

     

    - 1 PowerMac G4 with 7 terrabytes of eSATA discs functioning as a file server (obviously can't be updated to Lion or even Leopard, but works fine as a file server and let's me use eSATA discs). I've ripped my entire DVD and CD collection ( _hundreds_ of DVDs CDs)

    - 1 MacMini in the entertainment center which mounts a volume from the file server and which the mini uses as it's storage for iTunes. The mini is the "primary" iTunes library that the other machines access via Homesharing

    - my MacBook Pro

    - my daughters' iMac

    - oh, also an AppleTV in the entertainment center

     

    We used Homesharing to be able to watch movies and TV shows on the "remote" machines. After updating to Lion on the macbook pro, the iMac and the mac mini, I was getting the above error message "This movie requires Quicktime, which is not supported by this version of iTunes." Trying to play the same movies, etc, directly on the mac mini didn't generate the quicktime error, but rather, the error about not being able to find the files. After showing iTunes where the files were, the error message went away on the mini, and the "remote" machines were able once again to play the movies and TV shows without the error, even when in 64 bit mode.

     

    I know this is a wacked installation, but other than the file server, I'm guessing lots of people have a "big" mac somewhere with all of their media that they access via homesharing, so this might help someone.

  • 3. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Emma Foster1 Level 1 Level 1 (5 points)

    Fantastic - I was stuck with this error, I have turned 32 bit on for iTunes in the Info and my MOV files are playing again.

  • 4. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Trefoil160 Level 1 Level 1 (0 points)

    I access my itunes library remotely (using a Time Capsule) and was encountering this error message. Switched to 32bit and all my artwork loaded and a few other errors went away as well. Thanks for the help folks!

  • 5. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Kramerica Industries Level 1 Level 1 (0 points)

    I can vouch for the effectiveness of running iTunes in 32bit mode. I actually spent about 30 minutes on the phone w/Apple tech support and he tried a number of the basic troubleshoot processes with me that I had already tried (making sure software updated, permissions repair). He put me on hold and in the meantime I found this discussion so I tried it for myself and bam, it worked!

     

    It was so odd because after I upgraded to iTunes 10.4 I saw that about a dozen of my movies had lost/missing album art. I figured that it was a glitch in the upgrade, not thinking to see if the movie would actually play. So when I tried to play one of my movies that was missing the album art, I got the message that heads this discussion. I was confounded. Anyway, when he came back on the phone he was going to have me reinstall iTunes. I told him that I found this forum and tried the 32bit trick and it worked. He was as surprised as I was.

     

    Needless to say, I'm content for the moment knowing that I can play all my media now in 32bit mode. However, I fully expect an upcoming update to Quicktime to support whatever plugins aren't 64 bit compatible. In my opinion, iTunes seems to load and perform more responsively in 64 bit mode.

     

    Thanks for the great discussion and workable solution!

  • 6. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Tomeranaray Level 1 Level 1 (80 points)

    I found relevant information on this page: http://www.aroona.net/VideoDrive/Lion.html

    It seems some missing 64bit plugins prevent non-native iTunes videos from playing correctly. Hope this will be fixed with an update of Perian or so, but I'm affraid it will be like this forever.

  • 7. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    tom54430 Level 1 Level 1 (0 points)

    Switching to 32 bit worked perfectly for me

    OSX lion

  • 8. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Hilittle Level 1 Level 1 (0 points)

    Thank you so much for the Aroona link, Tomeranaray! Switching to 32 bit did the trick for me. I'm running OSX Lion too. Yay!

  • 9. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    brentopolis Level 1 Level 1 (0 points)

    apple has a knowledge base article for this now: http://support.apple.com/kb/TS3771.  however, the article refers to "older media".  i'm having this issue with media that just came out on the itunes store - specifically, doctor who season 6 part 2 and futurama season 8.

  • 10. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    timcharper Level 1 Level 1 (0 points)

    Switching to 32--bit fixed it for me! Thanks! (xvid videos weren't playing in iTunes any longer in Lion, even though they played in Snow Leopard, and I got them working in QuickTime)

  • 11. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    objectivist Level 1 Level 1 (0 points)

    Hi!

     

    I just ran into this same problem. Setup:

     

    - iMac 27" circa late 2010

    - OS X 10.7.2 Lion

    - just (today) upgraded iTunes to 10.5.1 (42) in 64-bit

    - Downloaded latest episode of "Fringe"

    - Launched the episode, got the "This movie requires Quicktime" error

     

    I followed the "More Info" button and got the Apple response mentioning "do this if you have 10.4 or Lion" and swtiched the 32-bit mode.

     

    Launched iTunes and tried to re-launch the episode. Episode launched ..... but with no sound.

     

    Quit iTunes and reset it to 64-bit mode.

     

    Launched iTunes again, and re-launched the episode. Episode launched ..... with sound!

     

    Does Apple not have many Quality Assurance engineers? There are lots of kids out of high school looking for jobs, and this sounds like something you could throw lots of hardware at lots of minimum-wage kids to find....

     

    My guess is that (maybe) iTunes 10.5.0 was 32-bit only and 10.5.1 is 64-bit (default) and somehow the episode came in with a bit flipped and it got all confused. Or something.

     

    Hope this helps the next one to come along!

     

    Cheers,

     

    karl

  • 12. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    objectivist Level 1 Level 1 (0 points)

    And it's happened again with the next downloads I did! Just added a new season of "Criminal Minds" and same problem. Quit, reset to 32-bit and relaunched, with no sound. Quit, reset to 64-bit and relaunched, and everything back to normal.

     

    PLEASE WOULD SOMEONE AT APPLE LOOK AT THIS STUFF! *** DO YOU PEOPLE DO ALL DAY?!?!?! WHAT DID YOU BREAK?

  • 13. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    Ezat Level 1 Level 1 (0 points)

    I got this problem after updating to iTunes 10.5 under Lion. Basically, if you download a new episode from iTunes, it won't play in iTunes and gives this error message. I found it odd since the files that were downloaded were recent TV shows.

     

    This is what I did:

     

    - in iTunes, select the files that give this message

    - delete them from the library BUT KEEP THE FILES in the filesystem

    - then in iTunes, select 'File>Add to Library...' and find the deleted files on your hard drive. It's somewhere in '~Music/iTunes/'. You can actually selected a folder if you deleted a whole TV series.

     

    The files will now play in iTunes without a hitch. Maybe my problem is different from yours since mine occurs with files that were recetly downloaded by iTunes and added automatically to the library. Must be a new bug in that mechanism.

  • 14. Re: "This movie requires QuickTime, which is not supported by this version of iTunes."
    rickpond Level 1 Level 1 (0 points)

    Ummm... Apple, this is just DUMB. I bought a TV Show from YOU and can't play it in 64bit mode on Lion? REALLY? I'm actually shocked. Apple doesn't seem to make rookie, first-run-at-an-operating-system-errors like this.

1 2 3 4 Previous Next