Skip navigation

iTunes 10.5 does not load shared library files

107757 Views 239 Replies Latest reply: Sep 17, 2012 6:14 PM by Carlo D RSS
1 2 3 ... 16 Previous Next
e4effect Calculating status...
Currently Being Moderated
Oct 11, 2011 9:56 PM

Since today's update to iTunes 10.5 from 10.4.1. iTunes can no longer access the shared music library I have on my iomega NAS disk. It sees the disk and lists it as a shared library, but when I click on the library it goes into an endless loading cycle. In the past it might take a minute or so to load the library, but since the update, iTunes never actually does load it.

 

There is no error message, not even an operation time-out. I can't see anything rrelevant in the console. It just goes on for ever trying to load the shared library.

 

It was loading the shsred library just fine until this evening when the update downloaded.

 

Any ideas?

Mac Pro, Mac OS X (10.6.8), iTunes 10.5
  • Clive Webber1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 11, 2011 11:22 PM (in response to e4effect)

    I'm having the same problem, also with an Iomega server. Brings back memories of the original iTunes 10 launch which suffered a similar problem with shared music libraries. Hopefully there will be a patch soon. Apple's quality control just gets better and better...

  • PeeDib Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 11, 2011 11:28 PM (in response to e4effect)

    Mine too, iTunes 10.5 break firefly media server again....

  • yy1 Calculating status...
    Currently Being Moderated
    Oct 12, 2011 6:56 AM (in response to e4effect)

    This is happening with my Linksys Home Media Server as well,it loads it,then it ejects it right away.... Linksys sure isn't gonna upgrade this thing, and it worked fine in 10.4 yesterday, why do they keep messing with this? I don't have any OS 5 devices, so am i stuck at 10.4, where would i go to get 10.4 and reinstall that?

  • woodmeister50 Level 4 Level 4 (3,690 points)
    Currently Being Moderated
    Oct 12, 2011 7:05 AM (in response to yy1)

    I learned my lessons in the past and always download

    the full installer and not use software update.  Then, I

    always keep a copy of the previously working installer

    as it seems old version now get removed from the

    servers when new ones are released.

     

    Also, keep backups of libraries because some version

    upgrades change the libraries and won't be recognized

    if one rolls back to a previous version.

     

    Also, using the full installer, you sure to be replacing

    all the files and not overlook some old baggage that

    the updater may have missed.

  • Diesel80 Calculating status...
    Currently Being Moderated
    Oct 12, 2011 7:41 AM (in response to e4effect)

    Same problem here using firefly with 10.4 for months without a problem.  There does not appear to be a way to go back to itunes 10.4.   Can we please have a fix for this, or do we have to buy an apple specific product? 

  • lupunus Level 3 Level 3 (995 points)
    Currently Being Moderated
    Oct 12, 2011 7:49 AM (in response to woodmeister50)

    woodmeister50 wrote:

     

    Also, keep backups of libraries because some version

    upgrades change the libraries and won't be recognized

    if one rolls back to a previous version.

    iTunes keep always a copy of the previous library for you.

    On that there is no need to backup the library again.

     

    Lupunus

  • yy1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2011 8:16 AM (in response to woodmeister50)

    Was wondering if i could use Time Machine to get the older version....

  • lupunus Level 3 Level 3 (995 points)
    Currently Being Moderated
    Oct 12, 2011 8:20 AM (in response to yy1)

    yy1 wrote:

     

    Was wondering if i could use Time Machine to get the older version....

    That's what Time Machine is for

  • Brahm Calculating status...
    Currently Being Moderated
    Oct 12, 2011 8:36 AM (in response to e4effect)

    I'm having the same problem with a Buffalo Linkstation LS-WTGL/R1-V3 NAS and iTunes 10.5 on both Mac OS X 10.6.8 and Windows XP.

     

    It's not quite an endless loop, though. It takes about 20 seconds, then the song listing flashes briefly on the screen but goes immediately to the local Music listing in the Library. If I right-click on the NAS's entry and choose "Open in a New Window", the window opens, shows the barber pole throbber for about 20 seconds, then closes, again going back to the local Music listing.

     

    There's about 117GB in the iTunes Music folder on the NAS.

     

    This worked fine under iTunes 10.4.x.

  • waggermama Calculating status...
    Currently Being Moderated
    Oct 12, 2011 10:23 AM (in response to e4effect)

    Ditto with a Qnap TS210, iTunes server appears in Shared but then when I click on it, it bounces me out.  Hope Apple can sort this one as it's obviously not down to one particular 'other' manufacturer.

  • lupunus Level 3 Level 3 (995 points)
    Currently Being Moderated
    Oct 12, 2011 10:46 AM (in response to e4effect)

    e4effect wrote:

     

    Since today's update to iTunes 10.5 from 10.4.1. iTunes can no longer access the shared music library

    You (all) should check that the NAS support the latest version of NetaTalk and Apple's latest implemented authentication version for shared drives (NAS).

     

    Lupunus

     

    Lupunus

  • Diesel80 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2011 10:53 AM (in response to lupunus)

    I am able to access all my other files with using NetaTalk, I don't think NetaTalk is realted to the issue.

  • Brahm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2011 11:04 AM (in response to Diesel80)

    Agreed. I can access all of the files on the NAS via Netatalk/AFP just fine. The problem only occurs in iTunes. And it happens with the Windows version of iTunes as well, so the problem seems to be in code common to both implementations, not an OS-specific component (such as the newer Netatalk 2.2 that was introduced in Lion... I'm not even running Lion).

  • waggermama Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2011 11:08 AM (in response to Brahm)

    I know with previous vesions it was something to do with forked MT DAAPD and Apple had to rework iTunes for some backwards compatibility.  Possibly they forgot to include that in the latest update.

1 2 3 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.