Skip navigation

Solution: iTunes 10.5 using 100% CPU / Not backing up your iPhone.

35686 Views 55 Replies Latest reply: Feb 26, 2013 9:12 AM by Powerlift17 RSS
  • Psyco Acoustics Calculating status...

    Thank you so much! I even had my PC and I-Pad at the Apple store and they didn't know what to do. This command prompt thing fixed my Windows XP machine. As other people have said, everything runs faster, and now my I-Pad will back up to my PC. It wouldn't for the past two months!

     

    Thanks Again!

  • Comodus Calculating status...

    Hi,

    I have the same problem with my LSp. What fix did you provide to work with Safari browser and Itunes?

    Thank you!!!

  • Comodus Level 1 Level 1 (0 points)

    Hi,

    I have the same problem with my own LSp. Please give me a hint of what Safari browser does that  I can't intercept

    traffic.

    Thank you!!

  • WSWARTZ Calculating status...

    OK, I have been to **** and back since updating  iTunes to version 10.5.3.3. Basically it hogs 100% of your CPU. I read all the articles and forums I could find and tried out everything including Win socket resets, re-installations etc. Nothing worked. My objective is purely to get iTunes in any version format to work so I can use iTunes again.

     

    I am now smiling and using iTunes. This is what I did.

     

    SYSTEM RESTORE POINT

    As always, create a system restore point so you have something to restore to in case something goes wrong

     

    UNINSTALL PROPERLY

    Go to control panel, programs and uninstall the below Apple related applications

    • iTunes
    • Quicktime
    • Apple Software Update
    • Apple Mobile Support
    • Bonjour
    • Apple Application Support
    • iPhone
    • any other Apple related product you can find

     

    Delete or move any *.itl files (iTunes databases)

    You need to remove these as when you install an earlier version of iTunes it will not be compatible with the newer version

     

    Clean registry

    Run a registry cleaner. I used the free one as part of the Tweaknow Power pack

     

    Manual registry clean up

    Run Regedit in admin mode and search for anything Apple and iTunes.  (F3 to do next search).

     

     

    NEW INSTALL

    Go to http://www.oldapps.com/itunes.php and download iTunes 10.1 (64-bit).  I tried later versions but had the same CPU issue (not sure why as I was on the second latest iTunes version which worked find until the upgrade).

     

    Caviat

    The above worked for me and was done at my own risk. If you choose to try the above you do so at your own risk and I accept no responsibility and liability what so ever.

     

    I will not be updating iTunes again until I see an official Apple iTunes fix for this issue.

  • Joe from St. Croix Calculating status...

    7:39 AM, Friday, March 02, 2012

     

    I just tried this and it worked, but I wasn't logged in as Administrator.  Just reseting winsock did the trick. Many thanks to whomever. I've been without Itunes for some time - Itunes Help was helpless.  Thanks again.

  • Wolfey101 Calculating status...

    Hey i'm in the same boat with everyone else...so i went to command prompt typed in ' netsh winsock reset ' and it comes up with
    ' The following helper DLL cannot be loaded: WSHELPER.DLL.
    The following command was not found: winsock reset. '

     

    WHYYYYY i just got my first iphone yesterday and straight away problems

    someone please help

  • Kzoom Calculating status...

    On a Dell D630, the problem was Wave Systems software from 2007, a "Winsock provider" whose biolsp.dll did not play well with other. Fine on iTunes 10.4, 100% CPU usage on 10.5 or 10.6

    This Wave s/w is for the Dell fingerprint reader and a couple of other security features on the laptop. Uninstalled the Wave Systems through the Add/Remove s/w feature in Control Panel...all better now.

  • Talons918 Calculating status...

    Thank you!!  After many hours searching for a solution to this problem, this is what finally worked.  Very relieved here.

  • Michael -MT- Tom Calculating status...

    Hi all,

     

    I'm using the latest iTunes 10.7.0.21.

    Same problem with AMDS hogging up 50% of CPU Usage.


    Try this:

    http://support.apple.com/kb/TS4123

     

    I found out that my Speedbit Video Accelarator was 1 of the software that has a conflict with Apple software.

    I tried uninstalling it, and Voila.

    Apple Mobile Device Services (AMDS) stopped hogging up the CPU. I can now sync my iPod.

    Maybe by uninstalling all other softwares that were indicated as a conflict by Apple, this can solve the problem.

     

    Let's see if this works for everyone else?

     

     

    Cheers,

    MT

    from Indonesia-Singapore

  • Gloveman69 Calculating status...

    Omg!  This worked like a charm thanks sodaboy!  How did you come across this!  I really hope apple fixes this compatibility issue with windows 7 64bit.   It's a huge headache!

  • Powerlift17 Calculating status...

    A few days back I ran the NETSH WINSOCK REST from the command prompt and all issues relating to the applemobiledevice.exe hogging CPU have ceased.  I am running Windows XP Pro on an old Dell PC.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.