Previous 1 2 Next 26 Replies Latest reply: Jan 3, 2015 6:44 PM by Janelleyfish Go to original post
  • Tony Gilmore Level 1 (5 points)

    Apple servers were down. It should be working again.

  • claudettevargas Level 1 (0 points)

    I think I may have a solution for your prob, it just happened to me yesterday at 11pm and I kept on reading and reading and trying but nothing. Then I starting watching videos on youtube. And I finally fixed my problem at 3:00am haha.

     

    Here's a possible solution for you.

     

    Settings > Wi-Fi (select your current wi-fi connection and press the blue circle with the arrows > Go down to where it says DNS and press it, delete the current number and put this:  8.8.8.8, 8.8.8, 4, 4

     

    Don't try on waiting with iMessage or Face Time it'll still will say "waiting for activation" but try on sending a message. It'll work, it work for me.

     

    As soon as a put those numbers my Push Notifications started working so good and so fast.

     

     

    Hope this helps!

  • NFH. Level 1 (15 points)

    claudettevargas wrote:

     

    Here's a possible solution for you.

     

    Settings > Wi-Fi (select your current wi-fi connection and press the blue circle with the arrows > Go down to where it says DNS and press it, delete the current number and put this:  8.8.8.8, 8.8.8, 4, 4

    This is exactly the solution I had already posted above together with an explanation of why it works. I'm glad it worked for you too.

  • smat9073 Level 1 (0 points)

    I was having this same problem.  Using the DNS codes may work for some, but I tried something else and it worked the first time.  I went into Settings -> Messages -> Send and Receive -> Apple ID -> Log Out.  Then I started over with turning iMessage on, logged in again, and everything was working perfectly.  Hope this helps. 

  • ahaavaa Level 1 (0 points)

    THANK YOU SO MUCH! IT WORKED!

  • Tillybug101 Level 1 (0 points)

    Had this problem with my new iphone 4s that came today was told by another site to make sure the time and date was set to auto update and hey presto it fixed the problem, facetime and imessage now working x

  • Stevedurko Level 1 (5 points)

    Hi,

     

    This solution does not work for me.

  • purplereyn Level 1 (0 points)

    This solution does not work for me either. 

  • collegebarlow Level 1 (0 points)

    When I updated to IOS8 it happened to me and this worked for me:

     

    • Open Settings then go to “General” and scroll down to “Reset”
    • Choose “Reset Network Settings”
    • then when it reboots go back to 'Settings'
    • then to the WiFi
    • select wifi you want
    • enter wifi password if needed
    • then go back to 'Settings'
    • then to Messages and turn imessage on
  • purplereyn Level 1 (0 points)

    Thank you for your suggestion, but this did not work for me. iMessage still says "waiting for activation"

  • MayHT Level 1 (0 points)

    Restart you phone and that should work

  • Janelleyfish Level 1 (0 points)

    Worked for me !!!! THANK YOU

Previous 1 2 Next