Previous 1 2 3 Next 125 Replies Latest reply: Oct 25, 2014 2:42 AM by Arh. Nestor Branched to a new discussion.
Yo_talk Level 1 Level 1 (0 points)

How can I setup my Voicemail number in the iPhone 4S to allow a call to my voicemail from the voicemail button ?


iPhone 4, iOS 5
  • FlORkY Level 1 Level 1 (0 points)

    Hi I have the exact same question ! I had a 3GS it was working, I had a 4 it was working. Since I switch to the 4S, it is no longer working. My carrier provider could not help, they provided me some "code" to enter via the keypad but nothing ... I would like to set this button back !!! I did a full restore and reset all settings already, but it did not help. Thanks anyone

  • wxe Level 1 Level 1 (0 points)

    Same question and same problem. On previous models *5005*86*[YOUR VM NUMBER]# used to work if you entered this into the phone dialer and pressed Call, but doesn't seem to work on the unlocked 4s.

     

    Perhaps someone on the forums can let us know the new dialer codes to change the number the Voicemail and 1 button dial.

  • Marlyss Hollyer Level 1 Level 1 (5 points)

    I had the same problem and got a helpful woman at AT & T who had been down this road with many other new iPhone 4S folks. Call the AT & T Web Assist number at 1-866-755-0451 and they can help and they can do some resetting of your voice mail password over on their end. She'll also want you to shut off the Wi-Fi and be on 3G. She had me up and working in about 15 minutes.

  • geert3012 Level 1 Level 1 (0 points)

    Same issue with provider Base in Belgium, the button won't activate. I followed the instruction on their website related to the iPhone 4 but this seems not to work on the 4S. A friend of mine using another provider in Belgium seems not to have any problem, his button is configured correctly.

  • 00-jesterking Level 1 Level 1 (0 points)

    I have the same issue (Canada, Saskatchewan), and phoned my mobility provider / Telus about it. They told me they were aware that some of their customers were having this problem and that it was being worked on, and that I could expect it to start working in the near future (although no dates were given, of course).

     

    I don't have much confidence that my voicemail button will magically start working on its own based on the rep's words, but figure I'll give it a few weeks before phoning them again.

     

    Anyone else have any luck fixing this?

  • ST666 Level 1 Level 1 (0 points)

    I have the same Problem. 2 unlocked iPhone 4S's on 2 different carriers in Thailand. One is USA Phone and the other is Hong Kong phone.

     

    One is OK and the other one need the number programed, but the code *5005*86*XXXXXXX# does not work on 4S.

     

    Doesn't matter which handset I use, the problem is related to the Carrier Bundle.

     

    On previous iPhones using the code would flash the VM number to the SIM card.

     

    I have tried many solutions including getting a new MicroSim from the Carrier.

     

    Maybe someone from Apple could chime in here and give us the new code Please.

  • rew0 Level 1 Level 1 (0 points)

    Same issue here.

    Please Apple let us know if there is a new code as this is a basic hygiene feature found on most other phones.

  • Pål A. Level 1 Level 1 (0 points)

    Just want to support this question. My carrier have no idea why the *5005*.... code don't work on iPhone 4S. So they have given up on helping me

  • c0stantin0s Level 1 Level 1 (0 points)

    Same issue there:

     

    Use the *5005*86*xxx# on iPhone 3GS, iPhone 4 and iPhone 4s.

    Only the iPhone 4s was not able to work with that..

  • webwbr Level 1 Level 1 (0 points)

    This should solve it:

     

    *#5005*86*+1XXXYYYZZZZ #

     

    (note the # sign BEFORE the 5005)

     

    Working for me on an iPhone 4s.

     

    I want to know how to put in a pause, so I can program my PIN in too. Any idea?

     

    PS - I've owned an iPhone for less than 24 hours... so bear with me.

  • Pål A. Level 1 Level 1 (0 points)

    Does not work for me. The number I want to add is +4747919191.

    Even tried +15556667777 just to see if it only accepted US numbers. That did not work either.

     

    On both tries I entered the code, hit the call button, waited about 10 seconds before I turned the phone off and back on.

  • rastapete Level 1 Level 1 (0 points)

    webwbr I guess your tip got me a little closer - the iphone at least recognized the string as a network command, but it still doesn't set my voicemail.

     

    BTW press & hold the asterisk for a comma, which represents a pause in phone-speak.

  • lrover Level 1 Level 1 (0 points)

    I am having the same issue with a facoty unlocked iphone 4s using a small gsm carrier and hope someone figures this out for us. I had the same issue a few weeks ago with a 3gs and used the hack as mentioned above but from another forum and it worked but my poor high $$ 4s seems broken.

    Thanks to everyone for working on this.

  • webwbr Level 1 Level 1 (0 points)

    Odd... this string is still working perefectly for me (AT&T), but when I add the pause (thanks rastapete)

    to add my PIN it isn't recognized as a network command.  Close, but no cigar.

Previous 1 2 3 Next