Previous 1 2 3 Next 38 Replies Latest reply: May 24, 2012 8:40 AM by mhargl
gueylergh Level 1 (0 points)

I have an iphone 4 with iOS 5, it was working propertly but since 2 days ago the phone is searching for network and stays with no service, can anybody help me how to fix it?


iPhone 4
  • fox2319 Level 1 (0 points)

    Have you got a PIN on your Sim card? I did originally with mine but it really caused huge headaches including slow bootup (incl need to reboot) and loss of network several times even while I was just sat in my office. I turned the PIN off and it's been behaving better.

  • gueylergh Level 1 (0 points)

    Thanks for answer, actually the PIN is off, i have never turned on since I got the phone... I do not know whatelse to do, I reset the phone settings several times, also i installed the iOS 5 again, but the phone keeps "searching" and with No service...

  • mcv75 Level 1 (0 points)

    I'm having the same issue. Have you taken your phone to an Apple retail store?

  • angus cooney Level 1 (105 points)

    1. Go to "Settings" Next "General" Next "Reset" and last "Reset Network Settings"

     

    2. It will tell you" This will delete all network settings " tap the red "Reset Network Settings"

     

    your phone will reboot..

     

    3 . Now this is the trick..

     

    Go back to settings and turn "Airplane mode" on then back off! and it should connect after that.

  • gueylergh Level 1 (0 points)

    No I have not, have you?, do you know if apple is taking care of this problems?

  • gueylergh Level 1 (0 points)

    No I have not, have you?, do you know if apple is taking care of this problems?

  • gueylergh Level 1 (0 points)

    thank you for taking the time to answer. I did  just like you wrote... sadly it didn't work, I still have the problem... I'm just about 5 seconds to throw the phone to the wall (LOL)..

  • BIGsir Level 1 (0 points)

    Has anyone successfully corrected this problem?  I am really dissatisfied with the iPhone 4s...I should have never upgraded...

  • michelle531 Level 1 (0 points)

    iPhone 4s/at&t here.

     

    I'm having the same problem as well. I think there is some bug in the io5 software too because my phone has never had network/connection issues until after I downloaded the io5 update. When the problem started, I went to at&t who replaced my sim card but they still coudn't figure out the network problem so they referred me to the Apple Store. Apple replaced my original phone with a refurbished one (free of charge since it was under my year), but now the replacement phone is doing the same exact thing! I tried hard reset, soft reset, turned off location services, turned off 3g, cellular data, and notifications. NOTHING has worked.

     

    It will blink on and off "Searching..."  to "No Service", then it finds service, and then it just repeats the cycle. This is so annoying. I hope they patch the bug up in the next update. UGH! If anyone figures this out or knows what is causing the problem in the meantime, please let me know.

  • michelle531 Level 1 (0 points)

    I tried this and didn't work =/

  • musica_ms Level 1 (0 points)


    I hope it will works fine after trying your solution

  • musica_ms Level 1 (0 points)

    Cooney

    i have my iphone 4 keeps searching for network carrier or it get weak after upgrading from IOS 4.3.3 into IOS 5.0. Now i have just applied the setting and hopefully it will work! Iphone sometime is really frustrating.

  • michelle531 Level 1 (0 points)

    I think I just fixed mine. I opened iTunes and backed up my phone to iCloud and iTunes (important if you don't wanna lose contacts, apps, etc), then I restored it to the factory settings. Now my network is staying connected.....

     

    Crosses fingers.

     

    (An Apple employee recommended doing this to fix the problem)

  • gueylergh Level 1 (0 points)

    Hi, is your phone still working propertly?. Restore it to the factory settings didn't work with mine. I've read something about the 5.0.1 is about to be out, but it does not say anything about the issue our phones have...

Previous 1 2 3 Next