Previous 1 2 3 4 5 6 Next 75 Replies Latest reply: Dec 18, 2014 12:23 AM by Raya adwan Go to original post
  • Ponsieh Level 1 Level 1 (0 points)

    OHHHHH GOD it worksssssss, its just simple
    thank you soo much

  • wiserangel Level 1 Level 1 (0 points)

    Mine just activated successfully on its own after about 3 hours.

  • B3N1992 Level 1 Level 1 (0 points)

    This hasn't worked atall nothing is. What else can I do tried everything and every suggestion help please

  • LiefParks215 Level 1 Level 1 (0 points)

    My iMessage has been displaying some weird number when I text someone. Does this number look familiar to anyone +1 (926) 391-6? If so how can it be fixed

  • Lenaa805 Level 1 Level 1 (0 points)

    I am in the US and I am having the same problem. The # it shows for me is +1 (1) 0236837. VERY FRUSTRATING!!!

  • lcs123456 Level 1 Level 1 (0 points)

    Sharing what helped me solve this problem. Rather simple steps that instantly fixed everything:

     

    http://www.imore.com/having-trouble-imessage-or-facetime-ios-7-heres-how-fix-it

     

     

    iMessage and FaceTime are wonderful, empowering, enabling technologies that... can frustrate the crap out of you at times. One of those times is when you update or restore your iPhone, iPod touch, or iPad to a new operating system - like millions of people just did with iOS 7 - and it stops working. If you're having trouble with iMessage or FaceTime, if they won't activate or simply won't work, here are some things you can try:

    1. Turn FaceTime or iMessage off and then back on in Settings.
      1. Launch Settings by tapping the icon on the Home screen
      2. Scroll down to Messages or FaceTime
      3. Toggle the switch from on (green) to off (white)
      4. Wait a minute
      5. Toggle the switch back to on (green)
      6. Wait for it to re-activate
    2. Hard reboot your iPhone, iPod touch, or iPad
      1. Make sure you're on Wi-Fi
      2. Hold down both the Home button on the front, and the Sleep/Wake button on the top of your device
      3. Wait for the Apple logo to appear
      4. If it still doesn't work, repeat step 1 (turning FaceTime or iMessage off and on)

    One of those, or a combination of both, should get you going again. If it works for you, or if you find any other ways to trouble shoot, let us know in the comments!

  • khosro125 Level 1 Level 1 (0 points)

    May be your number is related to another apple ID in Icloud backup in Itune. Have you changed your appleID?

  • drantoniadis Level 1 Level 1 (0 points)

    DrantoniadisAthens

     

    1. Go to settings, Icloud and delete account. Put your Apple id  to delete but keep content in your Iphone.

    2. Go to settings, itunes and appstore and click on your apple id and select sign out

    3. Then go to imessage, send and receive, click on your apple id and select sign out

    4. Do the same with facetime. At this point imessage and facetime is turned off and e-mail info and apple id are not set for appstore,icloud,imessage and facetime.

    5. Power off your phone and wait for 10 minutes

    6. Turn on your phone. Go to imessage and turn it on and wait for a couple of minutes to activate. DO NOT use your apple id for imessage because that's the reason the # does not register. After your # is ok then you can add another e-mail and sign in your icloud and appstore account.

     

    Greetings from Greece

  • labyrinth0 Level 1 Level 1 (0 points)

    thank you for being simple! it worked

  • kat.toronto Level 1 Level 1 (0 points)

    THANK YOU MOMDOGZZZZ, you are my HERO!!

     

    i have tried to activate my imessage & facetime for 4 months! in between i gave up because i really DID NOT UNDERSTAND what the F i did wrong. i did like you said:

     

    i signed into my apple id, deleted my home number and evening number and ONLY used the mobile number field.

     

    it took about a day now to activate but NOWWWW it WOOOORKS! woohoo, i cannot believe it. it's all good and i am the happiest little iphone owner.

     

    everybody else: do exactly that and perhaps you're lucky, too!!!

  • Joseph The Jordanian Level 1 Level 1 (0 points)

    It is very simple. I had the same trouble for two days. I did the following and it really worked right away:

     

    1- I corrected the area code on my apple account by signing on to my account https://appleid.apple.com

    2- I made sure that I dont have a zero balance on my prepaid card.

     

    Trust me this is it.

  • Rowena Harry Level 1 Level 1 (0 points)

    Thank you this works for me!  I actually did it from my iPhone and when I look at my iPad the change things and it asked me if I wanted to add my phone number and voilà; all set!

  • Joseph The Jordanian Level 1 Level 1 (0 points)

    sounds great

  • Judy Level 4 Level 4 (2,235 points)

    No need to delete your account on the iPhone.

    I have several apple IDs and use the same phone numbers for both. So no need to make sure they are unique, just correct. 

     

    Here is what I did:

     

    Solution: 

    1. Check Apple ID to make sure it has correct iPhone number. Do this at appleid.apple.com

    2. iPhone, settings - turn off wifi. Turn off messages. Turn off FaceTime.

    3. Make sure you have strong cell signal. Reset, reset network settings.

    4. Try SMS messaging on iPhone now. If your speech bubbles are green that is SMS. If they are blue it is not SMS.

    5. If it works turn on messages. Wait for activation.

    6. Check settings to see if phone number is now acceptable for sending and receiving messages. Phone number will be black with a check mark next to it.

    7. Turn on FaceTime. Wait for activation.

    8. Check settings to see if phone number is now acceptable for sending and receiving FaceTime. Phone number will be black with a check mark next to it.

    9. Turn wifi back on.

  • rwharry Level 1 Level 1 (0 points)

    Your country code will be 0061, then your area code or mobile service provider code will be the first two digits of your mobile number with the '0' dropped off the front (ie: if your phone number starts with 049, then in the second box you'd type '49'), followed with the rest of your phone number in the last box.

     

    Hope this helps you! I was having exactly the same trouble and adding the correct country code to my apple ID solved this prob for me