Previous 1 2 3 4 Next 57 Replies Latest reply: May 10, 2012 11:25 AM by pamelus Go to original post
  • DyeMacPro Level 1 Level 1 (0 points)

    a brody:


    Thanks for all your comments but so far I haven't be availble to make my samsung scx 4300 scan work I downloaded the driver from the link u said and nothing! And its very hard to contact samsung!


    When I downloaded that I open it and find a lot of file of all types of printers and when I find the scx 4300 only 4 files appear:



    gray HT

    ink tool

    modell info.....


    Nothing else!

  • patachou Level 1 Level 1 (0 points)

    And if I can't find in my library?

    In the folder you named there is not such a file...

    If I just install the driver you suggest nothing appens. scan still not work.

  • patachou Level 1 Level 1 (0 points)

    I finally found the, delete it and install the driver...nothing changes, still not scan...

  • patachou Level 1 Level 1 (0 points)

    I did it! It works!!!

    I followed again all the instructions, then unplug and replug the printer works!


  • lubomir.gavrilov Level 1 Level 1 (15 points)

    To resume, here is the procedure to replace the bad SamsungPrinterDrivers2.3, coming with the last update of Mac Os X 10.7.3, with the older but working SamsungPrinterDrivers2.2


    1) Go to the following link (or another if this one does not work more) c-OS.shtml

    and download SamsungPrinterDrivers2.2.dmg

    2) Go to "Activity Monitor", double click on the program samsung scanner and quit it

    3) unplug your printer

    3) Open SamsungPrinterDrivers2.2.dmg and follow the installation instructions

  • IvanLion Level 1 Level 1 (0 points)

    Проблема не решается !

  • lubomir.gavrilov Level 1 Level 1 (15 points)

    my printer is scx-4500, it might be different for scx-4300

  • DyeMacPro Level 1 Level 1 (0 points)

    Hey a brody,


    Did u have any luck contacting Samsung, I'm desperate and so far I haven't been available to use my scanner....



  • a brody Level 9 Level 9 (64,180 points)

    I don't own any Samsung scanners.   It is best if you contacted them directly.  I just simply gave you the best generic advice that one would use no matter what scanner you have.  If I called them, they'd just say since I'm not a customer they can't help me.

  • jimlondub Level 1 Level 1 (0 points)

    Regards lubomir.gavrilov's tip, it worked. I had the same issue with the 'file in use' message when trying to delete the 'Samsung', so unplugged the scanner, force quit the finder and then deleted the 'Samsung'. Then installed the new update courtesy of the link provided by lubomir.gavrilov- c-OS.shtml

    All fine now. Pity Samsung or Apple didn't make it a little easier. I ah using the SCX4300.


    Thank you lubomir.gavrilov.

  • chit kian Level 1 Level 1 (0 points)

    i downloaded the samsung printer driver 2.2 for mac but image capture still doesnt detect my scanner..

    my scanner is the scx4300.

  • lubomir.gavrilov Level 1 Level 1 (15 points)

    did you unplug/plug your printer, restart the computer?


    Otherwise, a possible reason is that your samsung printer driver 2.2 is not installed (and 2.3 is still working). To check this, you may go to

    file=> go to=> /Library/Image Capture/Devices

    Then click on SamsungScanner and open the package to see the version. If the version is the bad one, you can delete the SamsungScanner (but quit it first through Activity Monitor).

    Finally install properly the 2.2 samsung driver.

  • LawDaddy Level 1 Level 1 (0 points)

    Thanks for this, after following these steps, I was able to get my scanner working again. Now I can get those expense reports turned in!

  • asina Level 1 Level 1 (0 points)


    I'm having the same problem as you with samsung scx 4300, the scan doesn't work...can you help me.Can you show me all the steps I have to do to make this work.

    Thank you

  • christianbryan Level 1 Level 1 (0 points)

    I was having a similar problem. After a software update I was unable to scan with my SCX-4500, though it could still print. I removed the /Library/Image Capture/Devices/Samsung and installed this driver package. I did not restart, and I have successfully scanned a poster.


    It seems that the 2.3 update did remove scan support for this device. Unfortunate! I hope Apple and Samsung restore scan support in a new version of the software. Finding this support thread and having the chops to fix this is beyond most users.