Previous 1 2 3 Next 33 Replies Latest reply: Jun 21, 2013 12:52 PM by Roger Walters1
Roger Walters1 Level 1 Level 1

Up to now it hasn't bothered me much, but today I wanted to download iBank 4 Quick Start Guide. When I clicked on the link for the guide, Safari went to a pdf page and displayed the first page of the pdf. When I selected "Save As" it gave me a name for the file and the download destination. When I said OK, I got this error: The document “iBank_4_Quick_Start.pdf” could not be exported as “iBank_4_Quick_Start”. This happens for every pdf page I try to download. I get an error every time. The only work around I've found has been to right click (control click) on the button that takes you to the pdf file and select "Save linked file to the desktop" Safari used to allow you do a "Save As" for all pdf's. Does anybody know how to fix this?

Mac Pro, Mac OS X (10.6.8)
Solved by Linc Davis on Feb 20, 2012 2:31 PM Solved
Quit Safari. Open the Library folder in your home folder by holding down the option key and selecting Go ▹ Library from the Finder menu bar (Lion), or by selecting Go ▹ Go to Folder… and entering “~/Library” (without the quotes) in the text box that opens (pre-Lion.) Delete the following items from the Library folder: Caches/ Preferences Relaunch Safari and test.
  • Linc Davis Level 10 Level 10

    Quit Safari.


    Open the Library folder in your home folder by holding down the option key and selecting Go ▹ Library from the Finder menu bar (Lion), or by selecting Go ▹ Go to Folder… and entering “~/Library” (without the quotes) in the text box that opens (pre-Lion.)


    Delete the following items from the Library folder:




    Preferences/QuickTime Preferences


    Relaunch Safari and test.

  • Roger Walters1 Level 1 Level 1

    Thank you. Quicktime preferences was a little hard to find in the Preferences folder, but once I found it, it fixed my Safari PDF downloads.

  • dcnicholls Level 1 Level 1

    OK, same problem, tried the solution (after fully closing Safari 5.1.5), but the problem was not fixed.  Since I have been able to save PDFs in the past from Safari, I wonder if it's a new(ish) bug?  This is the first time I've noticed th problem and I haven't tried saving a PDF for a few weeks.


    When I mouse over the PDF in the Safari window, a toolbar appears at the bottom, one control being a "save" icon, which works.  But the "Save as" menu option doesn't.


    The URL in question is D&data_type=PDF_HIGH&whole_paper=YES&type=PRINTER&filetype=.pdf



  • Roger Walters1 Level 1 Level 1

    I'm using OS 10.7.3 (Lion) and since I removed and deleted the files listed above, the PDF files I click on are immediately downloaded to my desktop. (which is my chosen download destination) I might suggest that the files in question were in my "User Library" and not the system library. The User Library is not normally visible in Lion, but I found a small application to make it permanently visible to me. Otherwise, using the "Go" option mentioned above will get you to the User Library. This is a screenshot of the files I deleted:


  • Roger Walters1 Level 1 Level 1

    I forgot to mention that I'm now using Safari Version 5.1.5

  • dcnicholls Level 1 Level 1

    They were the same files I deleted.  Also using 10.7.3 and Safari 5.1.5.  I have Acrobat Pro installed, as well as Skim.  I'm wondering if the latter might not be playing nicely w. Safari.  Anyway, the toolbar that appears when I mouse over the PDF allows me to save the file, so I'm not stuck, but I'm awlays curious why things start to break.



  • dcnicholls Level 1 Level 1

    OK, I found the problem.  When I installed the latest Acrobat X update yesterday, it installed a new Safari plugin, AdobePDFViewerNPAPI.plugin, into the directory /Library/Internet Plug-ins  (ie System Library, not User Library).


    I deleted the NPAPI plugin and things are working as they used to.  I noticed that the NPAPI plugin was also hogging the processor (76%) on some PDFs.  It seems like bad news, and is probably not necessary.   (I left in place an earlier plugin, AdobePDFViewer.plugin.)



  • Roger Walters1 Level 1 Level 1

    I was just researching Adobe plugins because I remembered someone mentioning deleting one of those to solve this, but I couldn't find the thread where I had seen it. I'm glad you figured it out.

  • Fred L Johnson Level 2 Level 2
    Mac OS X

    I just had the same problem after updating Acrobat Reader. Moving the AdobePDFViewerNPAPI.plugin to my Diabled Plug-Ins folder solved my problem. (Deleting it also worked).

    I have no idea what I now can NOT do in Acrobat Reader after disabling this plug-in. Any help on how I've compromised Acrobat Reader?

  • dgivan Level 1 Level 1

    This worked for me as well.  But I also had to remove the AdobePDFViewer.plugin.  I assume the apple WebKit takes over the functions when this is removed and works as it did before I updated my Adobe Acrobat and Reader applications.  Thanks for the help.

  • Wally Himself Level 1 Level 1

    This worked for me - removing the AdobePDFViewerNPAPI.plugin - from the Library.



  • Brian_P Level 1 Level 1

    Thank you. Thank you. Thank you, dcnicholls. This has been bugging me all through the last several days (apparently ever since I updated my Adobe PDF plugin on April 12), frustrating my ability to save pdfs needed for tax preparation and college financial aid applications. If not for the update, I could have been done last Friday. Instead, the update cost me a whole weekend of grief, as I worked around the problems, going back and forth between my Mac and my wife's Dell and printer.

  • Peaeye Level 1 Level 1

    Thanks.  Deleting the new plugin worked for me.


    Is there a way to make Safari just hand off .pdf files to Acrobat if you have it?  I've just moved over to using Safari more after years with Firefox, and I can find the Safari equivalent to the Firefox content settings that allow you to tell it how to handle different kinds of files.  Any tips?

  • Roger Walters1 Level 1 Level 1

    You might want to read this thread: and read the comments to the end of the thread. Also, I was successful at getting PDFs, that I had downloaded, to open in Adobe Reader by right clicking (or control click) and selecting "open with" Adobe Reader. Alternately, you can select the PDF file, do a "get info" (or command I) on that file, and select Adobe Reader as its default to open it. Then if you select the "change all" button, all your PDFs will open automatically in Adobe Reader. Mine all open in Preview, but that's OK with me. I haven't been able to find anything to change that option in Safari, but once you've been successfull in downloading them, you can use Adobe Reader to handle them from there.

Previous 1 2 3 Next