Previous 1 2 3 4 Next 57 Replies Latest reply: Jan 12, 2014 5:03 PM by FabioPOBrazil Go to original post
  • matvideo Level 1 Level 1 (0 points)

    Thanks Norman,

    Your work around worked perfectly but we can't go on editing without a fix. I hope someone from FCPX development team read that and will look at it very carefully.

    Take care,

    Matthieu

  • Norman Jayo Level 1 Level 1 (0 points)

    Matthieu,

     

    I am glad the work around helped.

     

    I agree with you about hoping that someone from FCPX development steps-up. It is clearly a bug. I have dealt with three such bugs, plus more spinning balls, hang-ups, and crashes than I have ever faced with any professional app. Since this is a new app and not an upgrade to FCP7 that is to be expected. What bothers me is some people in the Pro App Department are claiming that FCPX is working perfectly and wanting to charge $99 per issue or $700 plus per year to fix these bugs. That is staggering, unprofessional, and more like Wall Street than the authentic traditional technical support that I have experienced and been promoting for over three decades. That is not the spirit Apple has established. It is a rub against the costly time and missed deadlines it takes to deal with these bugs. It is an insult to injury when Apple should be advancing a support policy to those who took a chance on FCPX to stay with Apple rather than running toward Adobe or Avid. We are in a period of debugging and Apple would do far better to have its Pro Apps people connect with all users, listen carefully, separate the troubled new users who are making real mistakes from the experienced users who know a bug when they face one in production and gain from their knowledge.

     

    I do not mean for this to be a rant on Apple. I am trying my best to raise an issue of critical importance.

     

    Good luck on your work Matthieu,

     

    Best professional regards,

     

    Norman

  • tomatms Level 1 Level 1 (0 points)

    It happened to me again today - third time in the last two months. It ALWAYS happens when I am attempting to insert gaps.

     

    Come on Apple - get it together.

  • Tom Wolsky Level 10 Level 10 (110,580 points)

    Nobody from Apple here. Use feedback. Do it often.

  • williamsjase Level 1 Level 1 (0 points)

    I've had the same issue here. The XML export work around worked for me. Would be nice to be able to choose an older version to reopen (Autosave Vault).

  • ismagom7 Level 1 Level 1 (0 points)

    Hi everyone,

     

    Same thing just happened to me a few hours ago when I came across this discussion. This is a really important project! The XML solution didn't work for me. WHen I tried it the files were all unorganized in the new timeline.

     

    I don't know what to do. I mean how can I even edit again with FCP X when I can lose a project just like that.

     

    PLEASE HELP ME!

  • ismagom7 Level 1 Level 1 (0 points)

    So I guess no one has an answer. Great. I hate my life right now

  • ismagom7 Level 1 Level 1 (0 points)

    Hi Norman,

     

    Same thing just happened to me a few hours ago when I came across this discussion. This is a really important project! The XML solution didn't work for me. WHen I tried it the files were all unorganized in the new timeline.

     

    I don't know what to do. I mean how can I even edit again with FCP X when I can lose a project just like that.

     

    PLEASE HELP ME!

  • fronzey Level 1 Level 1 (0 points)

    ismagom7, I'm sure you've already done this, but the best I can recommend (unfortunately) is to try everything listed here again (and be TOTALLY certain you didn't skip over anything the first time). That, or you could go digging through Time Machine for the most recent working version. I'm sorry either of these are unlikely to help, but I was just as stumped as you until I found this thread.

     

    I finally submitted official Feedback to Apple (www.apple.com/feedback) saying they absolutely MUST fix this bug, and I hope everyone else here will do so as well. This kind of problem definitely constitutes a critical bug, completely unacceptable in a pro application.

     

    If anyone else has suggestions for ismagom7, please chime in.

  • Norman Jayo Level 1 Level 1 (0 points)

    Hi Ismagom7, Sorry I haven't been able to respond sooner. I am in a tight deadline, as we all are. Fronzey's points are important, so re-step your steps.

     

    I will add this: Since I have been having a number of problems, like vanishing timelines and projects causing FCPX to crash, I have come to realize that one of the dynamics that may be causing these bugs is commonly related to the file structure and meta data coordination in the FCPX code — programmed to operate in the background.

     

    As you know, you can edit sub sections of a project sections locate the storage of that project (think of it as a sequence in FCP7) within a master folder in the Project Library. If you have been doing this (creating sub-folders within a project) you may be contributing to the bug becuase you are causing layers of background data that must be processed constantly tracked.

     

    You might go to the finder level and remove any sub-projects from the master folder and store then at the root level in the Finacl Cut Project folder. Reopen FCPX and export (again) via XML. Close FCP, maybe even clear all you cachés by resetting you Mac's PRAM and NVRAM (option-command-r-p) during an OSX reboot. Re launcg FCPX and then re-import the XML file. Before going any further, do not try to open the project timeline. First, duplicate the project by highlighting in in the Project Library using (Command D) and save it on another drive if you have one. After you've done that then open the project timeline from the XML version you have just re-imporrted.

     

    Somehow, I have noted, this process cleans up all the conflicting meta data and processing data that becomes fowled up with this bug ——  I am seeing is that the meta data managment (controlling the locations of the files, the editing command(s), timeline data, etc) is a lot on information on line at one time. The procesing is — I belive — where they problem may be rooted. It does not simply appear to be related to a single comand, such as adding a gap, or changing the specific elements of an edit, but rather in the process of coordinating the paths to the data and the related editing instrucitons.  If FCPX had a face, like a human being, I think it's eyes would be rolling and it's heart would be beating a 200 bpm, while breating hard and out of breath.

     

    Several of procedures I am constantly using are to make sure I am limited the demands on the heart of FCPX's processing. I have "background render" turned off in the app's perferences. I render at the end of the editing proicess, rather than during it, thereby taking that task away from the processing load. Secondly, I am nowusing a $4.99 app called Even Manager X that hides all projects and events that I am not working with, even projects that are really sub-edits that I have already complete or need to work on later related to the Master project. This stops the processesor from having to connect to that data, as a background process, and allows the more important processing focus to be on the edit at hand.

     

    Here is the site for Even Manager X

     

    http://assistedediting.intelligentassistance.com/ 

     

    Re-iteration:

     

         1. Stay away from sub-folders (it may not be a problem, but it could very will be  part of it, becuase of the data paths necessary to me remembered by the processors).

              — Keep all projects at the root level of the Final Cut Libraary on your drive(s)

         3. Cut down on any background processing that is not necessary while you edit.

              — Manage your projects by hiding the ones not in use (Event Manager)

              —  turn off background rendering

         4. Constantly back-up (Time Machine) or Duplicate Project Only (Command D in the Project Library.

              — This is insurance against these bugs.

        

    Ismagom7, I am not sure this will resolve the problem you are having, but this is just a bit on information I am coming to, as I am constantly dealing with the inevitable bugs of this new verion of FCP.

     

    I hope this helps,

     

    Norman

  • ismagom7 Level 1 Level 1 (0 points)

    Hi Norman,

     

    Thank you so much for the reply and tips. It still didn't work for me. I did everything over and over. When I export to XML and later import I do get the project but all the shots are misplaced, not the editing I had.

     

    And this is my first project on FCP X. Meaning I only have one event, one project and a few folders. I was using 7 before and I think Im going back to it.

     

    I jost lost a really important gig because of this. It's really sad that Apple lets these things happen

  • Norman Jayo Level 1 Level 1 (0 points)

    I am sorry to hear you have been cut short. Many of us are experiencing the same situations: missed deadlines, contact crashes, vanishing data, and spinning balls. I cannot cross back to FCP Legacy at this stage, so I have to see it through. I know it will straighten itself out, one way or the other, but right now Apple's Pro App people are missing then reality of what pro users — who are making a living with FCP — are having to deal with.

     

    Hang in there ismagom7.

     

    Best, Norman

  • Tom Wolsky Level 10 Level 10 (110,580 points)

    I would strongly recommend getting Pro Versioner from Digital Rebellion for automatic incrmental backups.

  • jw005 Level 1 Level 1 (0 points)

    Norman Jayo,

     

    Thanks so much for your extensive letter - I experienced this a week ago and its taken me five days in researching and troubleshooting everything I could think of before I luckily found this thread.

     

    I too have the exact same issue with everything you've mentioned, so went directly to your seven-step work around, however I am having an issue with step 3 - reimporting the XML file - everytime I click import xml, fcpx "shuts down unexpectedly" and I have to reload the software, again facing the same issue. FCPx will not allow me to import the exported XML file - therefore I am unable to continue to the next steps. Screen shot 2012-06-04 at 2.50.17 PM.png

     

    I attempted your longer work around with the "right clicking" - but I cant select any element because they're invisable - maybe you could explain this?

     

    If you would know of a work around with the importing of the XML file that would be perfect - because I am far too carefull to begin this project again incase of a repeat.

     

    Ps - Would timemachining the project bring back an "unglitched" version? I've unfortunately manually backed up all my projects, and I hadn't backed up my most recent edits with this project before the glitch occurred.

     

    Thank you very much,

     

    Jill

  • EibelstadtAktuell Level 1 Level 1 (0 points)

    Hello everybody.

     

    I have the same ******* problem.

     

    I have most of the things that were addressed in this discussion personally experienced. I talked also with Apple's Pro-Advisors. They always said - "FCPX" is a professional software and professional services for software costs money. In my opinion, a lot of money. 99euro for a one-time assistance. Professional software?

    In my opinion, professional software don´t have such bad errors.

    FCPX may be many, but not professional software.

     

    HAS ANYONE ANY INFORMATION, HOW TO PUT THE VIDEO BACK TO THE STATE BEFORE THE DISAPPEARANCE OF THE TIMELINE ?

     

    I bought recently a MacPro for almost 4000Euro ($ 5,000.92).

    I have worked before with Windows software on a Windows machine and I thought - now everything is professional.

    But that - was a mistake ...

    Apple has dissapointed me in the sector-software. Sad but true

     

    Max