1 2 3 4 Previous Next 52 Replies Latest reply: Jun 28, 2014 8:41 AM by Old Toad
ddease2 Level 1 Level 1 (0 points)

In iPhoto 11 (9.2.3), I cannot send emails through iPhoto as designed. I keep getting the error, "Your email did not go through because the server did not reply. Check your Internet connection. If the connection is working properly, the email server may be down. Try sending your email again later."

 

1. My internet connection is fine

2. I have entered my email account information correctly (and in multiple different accounts)

3. I have no firewall running

4. I can choose to send via Mac Mail (although I prefer to use iPhoto) and it works with no problem

 

From my Google searches, this seems to be a VERY common problem. However, I have yet to find anyone with a solution.

 

So I am going to "the source" here on the Apple forums. Does anyone know how to fix this obvious bug?

 

Thanks!


MacBook Pro, Mac OS X (10.6.8), iPhoto 11 (9.2.3)
  • 1. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    LarryHN Level 9 Level 9 (56,645 points)

    No one here can "Fix" any thing - we are all users just like yourself

     

    We can explain how to use iPhoto and in some cases help with workarounds to bugs

     

    From my view this does not appear to be a "bug" - it usually is simply incorrect entries by users and is corrected as follows:

     

    Often going to the iPhoto preferences ==> accounts and deleting the problem e-mail and re-entering it will resolve problems - some times it is necessary to the the e-mail service tech support involved and set ports or other advanced settings - only they can supply those for your service

     

    This also can be caused by third party software - Little snitch used to be one of the worst offenders although I've not seen much about it lately so maybe they addressed the issue

     

    IMHO the best solution is not to use iPhoto as the e-mail client and use Apple Mail - set it in your iPhoto general preferences  Since iPhoto does not work for your e-mail I'm confused why you prefer using it to using mail that does work - but certainly that is your choice. I personally prefer using programs that work for me to using ones that do not work for me

     

     

    LN

  • 2. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    ddease2 Level 1 Level 1 (0 points)

    LarryHN,

     

    Thanks for your reply.

     

    1. Understand that you cannot "fix" anything and that you are not Apple support. What I am looking for are suggestions to an issue that I'm sure is not unique to my Apple MacBook Pro running iPhoto 11 (9.3.2), particularly with regards to sending email through iPhoto (NOT through Mac Mail).

     

    2. While I can understand your assumption that this is not a software glitch (or bug) due to incorrect user settings, you'd would not be correct in your assumption. I am well aware of how to configure a mail client, as I've been doing so on all types of platforms (Macs, PCs, Linux, and Unix (before it was Linux)) for the past 20 years. The issue with iPhoto appears to be the authentication (or lack thereof) between the application an the mail servers (most notably Google Apps SMTP servers).

     

    3. Yes, Little Snitch may be an issue in some cases, as could OSX's built-in firewall if it were misconfigured. However, Little Snitch is not the cultprit here, as I have configured it correctly and I've troubleshot that angle.

     

    4. Regarding your suggestion to use Mac Mail as the client, that really doesn't address my question, nor does it solve my problem (which is sending mail through iPhoto directly.) I'd prefer not to simply work-around a marketed feature of this commercial software because it does not function. That may be a solution for some, but it not for me. I'd rather find...a solution.

     

    (time passed....took a look into it later in the evening....)

     

     

    With a solution in mind -- I think I may have found it. Thanks to "wtobiasjr" here:

     

    https://discussions.apple.com/message/17637554#17637554 (see wtobiasjr's entry)

     

    Here's what I did:

     

    1. Remove all mail accounts from iPhoto

    2. Log into Google Mail (including Google Apps Mail - which I use) and enable the 2-way authentication feature. This can be somewhat confusing, but go to this link and follow the guide: http://support.google.com/accounts/bin/answer.py?hl=en&answer=185833

    3. You'll need to create a password code and name it "iPhoto Email"

    4. Once you generate the passcode, copy it to your clipboard

    5. Go back into iPhoto and go to Preferences > Accounts > Hit the '+' to add an account

    6. NOTE: Do not choose the Gmail email type, use the "Other" type

    7. Fill in your Full name, Email Address, Description, Outgoing Mail Server (use smtp.gmail.com), keep port 587, enter your Username (which is your full email), and finally enter the code from your clipboard

     

    Give it a try and you should not get the connection error message when you send an email. I tested it with one photo, multiple photos, and with various email accounts. All worked flawlessly for me.

     

    Good luck!

     

    DRD2

  • 3. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    LarryHN Level 9 Level 9 (56,645 points)

    What ever - that is a really compicated workaroud - but if you like it better than the suggestions then enjoy

     

    LN

  • 4. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    joshmeans Level 1 Level 1 (0 points)

    I'm having the same issue DRD2 and suspected it was tied to my Google Apps account as I'm able to successfully utilize my Gmail.com account.

     

    Will be happy to utilize the solutions you have posted and report back here.

     

                                                 -Josh

  • 5. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    yakapo Level 1 Level 1 (0 points)

    Thanks for posting.  It's ridiculous that Apple didn't just put an option to import settings from imail.  Furthermore, it was not 1/10th as difficult to get gmail working on imail.  I tried yahoo email and it worked immediately.  Perhaps this is an attempt by apple to get gmail users to switch over to apple mail.  Oh, and a big "whatever" to the pretentious apple pundits on this thread.

     

    Regardless, it's working now.  So much for "it just works".  Fyi, I'm an IT admin. 

  • 6. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Terence Devlin Level 10 Level 10 (123,770 points)

    Wow, an "IT admin" who doesn't know the difference between Yahoo's free and paid services, who doesn't know the name of the Mail application (it's Mail, by the way, there's no such app as "imail"), and iPhoto does import the Mail settings on first run.

  • 7. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Grigger Level 1 Level 1 (0 points)

    On my sixth attempt to add a (yes, sixth email client) I succeeded.  Fortunately my partner has a yahoo account which worked fine.

     

    I sympathize with this iPhoto user as sometimes you invest in the "Email" export screen with all sorts of content (photo descriptions, scrapbook templates, etc) that you cannot otherwise save.

  • 8. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    ericsoco Level 1 Level 1 (0 points)

    unfortunately, the 2-step verification gmail fix didn't work for me.  giving up, putting photos on a thumb drive.  too bad apple doesn't have smooth client-side synchronization between iPhoto and Mail -- no reason to set up an additional account if you don't have to (e.g. if you use both of those Apple applications, like many OSX users do).

     

    +1 to yakapo's comment about "pretentious apple pundits".  seems like every time i end up on apple forums there are one or two apple snobs who claim it's never apple's fault, it's the user's fault.  apple has a rep for great UI, and that's generally deserved.  but one central tenet of UI design: if the user can't figure it out, it's not the user's fault.  it can be designed better.  case in point with this issue.

  • 9. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Terence Devlin Level 10 Level 10 (123,770 points)

    too bad apple doesn't have smooth client-side synchronization between iPhoto and Mail

     

    It does, and I use it all the time, on three different mail services - Cloud, Gmail and a Private server. It works flawlessly on all three.

  • 10. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    ericsoco Level 1 Level 1 (0 points)

    it does not work flawlessly with gmail.  hence this thread.

     

    what i meant by that comment was that iphoto should be able (if the user grants it access) to use the accounts already set up with mail -- they're both apple products and they could be better integrated.

     

    if that's possible, please let me know how.

  • 11. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Brent D. Level 1 Level 1 (0 points)

    Grigger wrote:

     

    I sympathize with this iPhoto user as sometimes you invest in the "Email" export screen with all sorts of content (photo descriptions, scrapbook templates, etc) that you cannot otherwise save.

     

    Precisely. The layout options in iPhoto are very nice, and it makes it possible to send a "card" to someone via email with nice pictures without much trouble.

     

    I've been having this issue for a while and I cannot get anything to work. I have tried deleting and re-entering my mail settings (exactly as they are set in Mail), and it will not work. It will send if I show Apple Mail as the mail client, but then you don't get templates. I have tried different port settings - no go.

     

    This feature used to work for me a while back, so I'm pretty confident that this is some sort of bug, but I don't want to get into some sort of argument about whose fault it is.

  • 12. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Terence Devlin Level 10 Level 10 (123,770 points)

    It will send if I show Apple Mail as the mail client, but then you don't get templates

     

    Mail has templates - and more of them. Check out the Stationery.

  • 13. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    Andrew東京 Level 1 Level 1 (0 points)

    I have the same issue, on a machine and configuration that was previously working, and from which I could send photos by email from inside iPhoto.

     

    I shut down the iMac and relocated it from one location to another in the same room, then re-started. Network and peripherals are all wireless so apart from power there were no other cables or devices involved. After the re-start the error message "Your email did not go through because the server did not reply" appeared when I attempted to share photos by email from iPhoto.

     

    However, before posting, just to be sure, I quit and re-started iPhoto. The issue did not re-appear. So at least for me that was a "fix" which I suggest others could try.

     

    I agree with ddease2 that the exchange with LarryHN was not helpful. Forums like these only work when posters have respect for each other.

  • 14. Re: iPhoto email - "Your email did not go through because the server did not reply. "
    richsadams Level 1 Level 1 (70 points)

    I stumbled across this thread because I was having the exact same issue trying to send photos from within iPhoto using one of the built-in templates.  NONE of my email accounts including iCloud would work. No matter how many settings I changed and how many times I confirmed they were exactly right I received the same error message.

     

    FIX:  Ultimately I wiped every email account listed in iPhoto Preferences, closed iPhoto and reopened it.  Then I  added one, single email account for which I knew all of the settings (matched with the same account in my Apple Mail program).  I closed iPhoto, reopened it and it (finally) started working.

     

    I then added my iCloud account back in...most of the settings auto-filled except for the password - which I entered - and it began working as well.

     

    FWIW after clicking on "Send" the progress bar fills quickly but then it seems to sit there a while, presumably because the file it's sending is fairly large...but eventually iPhoto confirms that the email was sent.

     

    I can't guarantee wiping all of the email accounts listed in iPhoto and starting fresh will work for everyone or anyone else, but hope it helps!

1 2 3 4 Previous Next