Previous 1 2 3 4 5 6 Next 83 Replies Latest reply: Nov 24, 2012 7:13 PM by McDiverdan Go to original post
  • Micky350 Level 1 (0 points)

    I just upgraded to mountain loin and it doesn't show up in finder or disk utility but it does show up in system information saying this:

    Backup Drive:


      Product ID:          0x2828

      Vendor ID:          0x1980

      Version:           1.16

      Serial Number:          AC2300008AD3

      Speed:          Up to 5 Gb/sec

      Manufacturer:          SAC Clickfree

      Location ID:          0x14900000 / 8

      Current Available (mA):          900

      Current Required (mA):          0

  • Ciamy Level 1 (0 points)

    I bricked two external 3.5inch Self Powered Drives, made by two different manufactureres, after attempted to Erase them using disk utility.  Both drives mounted and transfered data fine while connected to my Retina Mac Book Pro USB 3.0 ports, prior to erasing them in disk utility.  Now, both continue to show in Disk Utility in the left hand column and both disk verify/repair just fine in disk utility, but neither will Mount.  In other words, both are bricked after attempting to erase them. 


    I called Apple Support after getting no usuable help through the Apple Forums. The rep felt is was a problem with the two older USB 2.0 drives compatablility with the Retina Macbook Pro's USB 3.0. He kindly offered to send me a Compatable USB 3.0 Drive, but could not offer a solution.


    FYI, I tried using different cords and both USB 3.0 ports on my Retina MacBook Pro and both are self powered.




  • MacKyver Level 1 (5 points)

    Have you tried connecting these drives to a Windows machine,, format it as exfat and then try to bring it back to the Mac to reformat again? I have a new crucial M4 SSD that couldn't be recognized but works now after this method, but who knows how long this would last?


    My Previous Crucial SSD had to be RMA because somehow my rMBP had "bricked" it in the process of formatting.

  • mariachah Level 1 (0 points)

    Hello sjam. Have you resolved the issue with the Verbatim HD? I have the same problem and any of the updates have fixed it... any clues?

  • sassmaster Level 1 (0 points)

    Hi. I don't know if this will solve it for you, but when my LACIE external hard drive wouldn't show up I went to the Finder Menu, Preferences, General and checked External Disks under "Show these items on the desktop". I also made sure External Disks was checked in Sidebar. It worked for me, so worth a try.

  • mariachah Level 1 (0 points)

    hello! Thanks for replaying. I have checked Finder Preferences Menu as you suggested and disks were checked to show up on desktop as well Slidebar.... Didn't work for me either. I'm guessing is the usb cable?, might not give the disk enough power... I really don´t know.... Help please!

  • Ciamy Level 1 (0 points)

    I was able to unbrick both of my external hard drives by taking them to an Apple Store and plugging them into a USB 2.0 drive on a MacBook Air running Lion, not mountain Lion and then reformatting/erasing them.  After this, both drives showed up on my Retina Pro and both work fine now. 

  • DrJeff_92677 Level 1 (30 points)

    My OS image boots fine with an external USB 2.0 case, but will NOT boot from a USB 3.0 case.


    But once the latest OS is running, the USB 3.0 case and drive are visible, files can be copied to and from the drive.



    Clearly, they don't have the proper firmware code to support USB 3.0 but support USB 3.0 only in the OS itself. This needs to be fixed, otherwise the idea of having an external disk image and booting from it is limited to USB 2.0, defeating on the the selling points of the newer MacBook Pro systems with USB 3.0 support, or lack of support.,


    Very disappointing. Back to USB 2.0 enclosure until they fix the MacBook USB 3.0 support.

  • McDiverdan Level 1 (0 points)

    Hi all, maybe this will work for you ! I also bought a flashy new retina macbook and 2tb lacie porche design hd to go with it, then could not use the hd as it wouldnt mount (( I looked everywhere for a solution with no luck then by accident found this works for me everytime.

    Slowly plug in the usb cable until you hear the hd spin up then stop and wait 2-3 sec then plug in all the way, i still dont know why this works but is a relief I found a way to use my hd.

Previous 1 2 3 4 5 6 Next