Previous 1 8 9 10 11 12 13 Next 184 Replies Latest reply: Dec 24, 2015 7:39 AM by Tehila L Go to original post
  • BKingdom Level 1 Level 1

    COnfirming Switzerland works again now.. looks like the apple servers are working again. Issue should be resolved for everyone I hope.


  • Tul_Bord Level 1 Level 1

    I'm having this problem again!!!!

  • Michellevp Level 1 Level 1

    Oh no! Don't tell me this is going to be an on going situation. Are you sure it's the same reason ?

  • muzti Level 1 Level 1

    Mine started working once I restarted the phone. Try that first and try disconnect and logging in before you restore firmware.

  • james.amrita Level 1 Level 1

    Hey everyone,


    I too was facing the same problem but have found a solution for it. Like it is said in the previous post's link, the problem is most likely because of the 'Date & Time' setting. Change to setting to 'Set Automatically' and then try reconnecting to facetime/imessage.


    Hope this helps you as it did to me.

  • RBrum Level 1 Level 1

    I was having this issue too. I turned off the cellular data and wifi then turned my phone off. Turned my phone back on and turned the cellular data and wifi back on and it was working.

  • Famke Kwant Level 1 Level 1

    Same overhere, Netherlands.

    I have 2 ipod Touch, 4G. One is working fine, other one not. So, it's not the server or our WIFI.

    Allready phoned Apple twice (> 1 hr!!) but no soloution so far.

  • Zotas Level 1 Level 1

    Possible Solution


    I was having the same problem today and then it ride something different.


    My main email is different from my main ID. I tired just for giggles logging in with my main email and not my Apple ID. I used my usual password and it actually worked. Then I set the desired email. (a third email as I have another family member using this device)


    Long story short is that logging in using alternate email got me pas hours of failed attempts.


    Hope this helps.

  • igarcia810 Level 1 Level 1

    This is happening to me - stopped working randomly last night, i turned it off and on and now it won't activate my phone number. Works fine with my email address but not with my phone number. I've been on the phone with apple for almost 30 minutes and we've gone through logging out of my apple ID, resetting my settings, the date & time, turning wifi off and on, turning my phone off and on, turning airplane mode off and on, turning imessage off and on.. you get the point. It's still not working and the woman on the other end of the phone is clearly running out of options to offer me. I'm hoping that it's a server thing and it will work again in 24 hours. If not I'm going to genius bar cuz this is so not okay.

  • kristenalisec Level 1 Level 1

    i have an iphone 4 that i am using with WiFi only... my imessages and facetime both say waiting for activation,,, i have restored back to factory setting and nothing has worked

  • makanjia Level 1 Level 1



    Thanks very much for the solution. It worked for me.

  • makthai420 Level 1 Level 1

    Why does everybody feel the need to reply with a " me too in (yourcountryhere)" when this helps no one. I have to scroll through pages on responses, and find out at the end no one has an answer. I know you have the same problem as the rest of us, that's why were here. Unless you have a solution, or are going to at least publish the steps you took, to save us the trouble of trying the same, then don't bother. It helps no one!

  • oosak Level 1 Level 1

    This started when I downloaded the new version of iso !! Grr

  • SissyRibbons Level 1 Level 1

    Hey you guys. After several stressful hours,I found a solution (hopefully it will also work for you)

    I currently have iOS Version 6.0.1, but this should work for everyone


    After hours of trying several methods to fix your iMessages from different forum websites, i mashed all methods together. 

    This all started when i accidently hit "iMessage" and turned it OFF, then it was not able to turn it back on using my number, but instead it was giving my email address for texting, or just giving regular text.  Hopefully this will work for you. Please read throughout all directions in order


    At this time, make sure your iMessage and Facetime are BOTH ON ( if you cant find these two options, skip a few steps down and it will tell you how to get to there)


    Before we start, BE SURE YOU HAVE A VALID "APPLE ID"

    1. Make sure your Date,Location, and Time are correct according to your time zone and location.



    • Go into "Settings"
    • Find and enter the "General" Tab
    • In the General Tab, find and enter the "Date and Time" tab
    • Turn OFF the "Set Automatically" ---- then. manually change the "Time Zone" to where you are currectly located" OR nearest location  (e.g. -  I am located in "Richmond CA," but the time zone I am checked in is "Cupertino CA(15 minutre drive away," So no big difference) ----Dont try and find me creepers, im a serial killer who rides a Donkey, serious business.
    • Turn "Set Automatic" back ON, (If it automatically find the closest city near you, no biggie)
    • End of Step


    Location: iMessages

    • Go into "Setting"
    • Find and enter the "Messages" tab
    • Scroll down and enter "Send & Receive"
    • Click on your Apple ID:
    • Click on "Change Location"
    • Make sure your "Region" is accurate to where you are located"
    • End of Step


    Location: Facetime

    • Go into "Setting"
    • Find and enter the "Facetime" tab
    • Click on your "Apple ID"
    • Click on "Change Location"
    • Make sure your Location is accurate
    • End of Step


    Okay, Now for the goodies, not too much though, might cut your tongue.



    Step one: Sign out of your Apple ID.

    • Find and enter your "Store" app ( where you download all your apps for your iPhone), select the "Featured" category located at the bottom left of the app.
    • Scroll down on the page, you should see a tab where it shows your email Apple ID address. - click on it and Sign Out.
    • If youre already signed out, SIGN IN AND BACK OUT AGAIN
    • End of Step


    Step two: Turn off Wifi.

    • Go into "Settings"
    • Find  and enter the "Wi-Fi" tab,
    • Turn OFF Wi-Fi
    • End of Step


    Step Three: Enable then Disable Restrictions

    • Go into "Settings"
    • Find and enter the "General" tab
    • Find and enter the "Restrictions" tab
    • If  Restrictions are already disabled-----Enable it.
    • It will ask you for a "Restrictions Password" (I put the same code i use to log into and unlock my iPhone)
    • After you Enable it ---- DISABLE IT again, so that every tab is "OFF" and greyed out, unable to be clicked.
    • End of Step


    Step four: Turn off iMessage

    • Go into Settings
    • Find and enter the "Messages" tab
    • Turn OFF iMessages
    • End of Step


    Step Four: Turn off FaceTime

    • Go into "Settings"
    • Find and enter the "Facetime" tab
    • Turn OFF Face Time
    • End of Step


    Step Five: Reset Network Settings

    [NOTE: This will NOT erase contacts or any of the naked pictures you take of yourself/ Personal information, ex. Music, Schedules, or your only Girlfriend Siri (Doesnt count if youre a woman, Men, dont deny it, my Siri forced me to be her Husband :'( ]

    • Go into "Settings"
    • Find and enter the "General" Tab
    • Scroll Down and enter the "Reset" tab
    • Click on the "Reset Network Settings"
    • It may or may not ask you for a password, just use the same password again you use to get into your iPhone
    • ::Mr. T Voice:: PRESS THE RED BUTTON FOO!
    • End of Step


    After you pressed "Reset Network Settings" Your phone should have automatically restarted.


    Now for the Finishing Steps.


    Now that your phone has restarted, You must do the "Cha Cha Slide" and "Hokey Pokey" to induce a magical spell onto your iPhone. Just kidding, but try it, you'll make a fool of yourself and relieve some stress from all the researching you have been doing to fix this problem.  It's Okay if you didnt, im still your friend. =D


    NOTE: DO NOT SIGN INTO WIFI, From now on until your "iMessages/Facetime" Works, You should be running on "3g or 4g" internet



    Step Six: Sign in into your Apple Store

    • Find and enter your "Store" app ( where you download all your apps for your iPhone),
    • Select the "Featured" category located at the bottom left of the app.
    • Scroll down on the page and SIGN IN
    • End of step


    Step Seven: Sign into iMessages (MAKE SURE YOUR WI-FI IS STILL OFF or "Not Connected"!! and running on "3g/4g")

    • Go into "Settings"
    • Find and enter the "Messages" Tab
    • Turn ON "iMessages" (It may or may not ask you to sign into your Apple ID, just sign in whenever they ask you to.  OR there might be a tsb where it will say something about "You need to sign into your Apple ID, blah blah blah, something along those lines, Click it and Sign in)
    • Let it load ( loading times may varry, from five minutes to 1 and a half hours, keep checking in all while you DO NOT SIGN INTO Wi-Fi!)

    IMPORTANT! - Now, when i turned ON iMessages, IT FAILED THE FIRST.. or second time(cant remember), KEEP TRYING! It should turn on after three or four tries.


    Now do not toggle the On&Off button during the proccess of it loading because it will restart the whole loading process. Just wait until it says "unsuccessfull" to Turn off iMessages and on again.


    HOPEFULLY when your iMessages is turned on,


    Step Eight: Repeat step: Seven,

    • For your Facetime.  That also failed once for me before it started to work again.



    After both iMessages and Facetime are working, you are now free kiss a baby or Pet(Gold Fish, Husband and Wife included) on the cheek out of joy....but put him him/her/it down, youre scary looking and might make the baby/pet cry


    You are also free to sign back into Wi-Fi


    I hope this works for you. Enjoy your day and help a random stranger out.


    If it worked and you feel generous, Copy Paste this into any Forum or Website (Eg. Yahoo Answers) so others can see and be helped.



    SissyRibbons OUT!


    ^Best nickname ever.