Previous 1 2 3 Next 81 Replies Latest reply: Apr 2, 2013 3:35 PM by sarthakmalik Branched to a new discussion.
mcm128 Level 1 Level 1

I have a Mac Pro with two Nvidia GeForce GT120 video cards driving three displays.  After the upgrade to OS X 10.8, the third display is recognized by the system, but does not show the desktop or any windows... only the pointer arrow is displayed - but the arrow is displayed properly, is mapped properly across all three display spaces, and the system still allows windows to be open (but invisible) on the 3rd display.  Is this a general bug or perhaps unique to my configuration?

Mac Pro, OS X Mountain Lion
  • mcm128 Level 1 Level 1

    Supplemental info: I managed to blindly drag the 3rd display's preferences window onto the other display spaces and changed the rotation setting to standard (it was rotated 270)...  the system now shows the desktop and windows on the 3rd display (albeit off kilter due to the physical rotation of the display). 


    Out of curiosity, I tried the rotation setting on the other two displays... the same display failure occurs on all of my secondary displays, but the primary display (i.e. the first physical display on the first physical display controller) can be rotated without loss of function. 


    Note: I have the second and third displays both wired to the secondary (slot 2) display controller, so the problem may be with secondary display controllers rather than secondary displays... I'll try to reconnect the video cables to further localize the problem.


    It appears that this is a general bug with the OS X 10.8 base version.

  • mcm128 Level 1 Level 1

    Rearranging the video connections did work-around this OS X bug.  My rotated display had to be the first physical display in the first physical display controller.  However, the bug appears to be more insideous than that.  My secondary display (a Samsung T240) did appear to support rotation as the second physical diplay (second port of the slot 1 display controller), but the older Gateway display (the physically rotated display) did not support X windows rotation connected to the same video port)... but all displays connected to the slot 2 (secondary) display controller failed to support X windows rotation.

  • graemefromportland Level 1 Level 1

    I'm having a simialr issue with a GF8800 and a GF570GTX in a mac pro 3.1.


    The 570GTX that runs my primary monitor is just fine and can rotate etc.


    The 8800 that runs my "side" displays gives a black screen, but a correctly orientated pointer.


    This is the same for both side displays driven off the 8800 (I have 2) - not sure what card is in what slot, but I can check later.
  • Spits Fitzsimmons Level 1 Level 1

    I have the same issue trying to run three displays, two vertical on each side and one horizontal in the center. 


    I have two graphics cards (NVIDIA GeForce 8800 GT and NVIDIA GT 120). 


    I can rotate with those plugged into the GT 120, but not in the 8800 GT.  Tried changing the order of plugging in and everything, and every other tip I could find online, but still couldn't get 90 or 270 degrees to work on the displays plugged into the 8800 GT.


    I'm only seeing the "black screen" and a mouse pointer. I can drag and blindly click content on those black screens, just can't see it.


    Seems it must be some simple issue to reproduce and correct. 


    My system is a MacPro3,1 3 GHz Quad-Core Intel Xeon.  The 8800GT is the stock card that came with the machine.  The GT 120 is a about 2 years old and was added to power a newer Apple LED Cinema Display (black trim), the other two monitors are the older Apple Cinema Displays with the silver trim.


    I first noticed the issue when i upgraded from Mac OS 10.7 Snow Leopard to Mac OSX 10.8 Mountain Lion and from there the monitor / display rotation didn't work - again just a black screen and a mouse pointer on the rotated display.


    At this point I've got one rotated vertical and two horizontal as that's the best I could do.


    Any suggestions for a fix would be appreciated.

  • phallguy Level 1 Level 1

    I have the same problem. Resetting the PRAM seemed to work it out.


    However rebooting, or shutting down seems to re-introduce the error. There's definately something going on in the new release with video hardware settings.

  • PaulM_FTS Level 1 Level 1

    I'm having a slightly different issue of a frequent "blank" (gray) screen with only a cursor at login. This is with only one Nvidia video card (either a GTX-285 or GT-120) and an NEC 2490WUXi monitor.



    I know that there are new Nvidia drivers in 10.8, so that seems like a very likely suspect. I don't have any ATI cards to test with, except the Radeon HD 6750M on my 2010 MBP (which logs in just fine 100% of the time).


    In my case, however, I still suspect the monitor, as I know others using these cards on 10.8 with no issue. mcm128, you mentioned a Samsung T240 as your secondary monitor, and an "old Gateway" as the third; what's your primary display?

  • Spits Fitzsimmons Level 1 Level 1

    Resetting the PRAM didn't make a difference for me (still seeing black screen if i attempt to rotate the display).


    But thanks nonetheless.

  • Ajaxx42 Level 1 Level 1

    I had the same issue.. and I had 3 monitors with 2 being rotated. Making my main (the one that shows the boot screen) monitor one of the rotated ones fixed this issue for me as well.


    It's still a bug though and it needs to be resolved, but at least there is a way to get around it.

  • Dual 3.5 G6 Level 1 Level 1

    Mountain Lion Bug: 10.8.0 and 10.8.1

    MacPro 4,1 + Dual NVIDIA GeForce GT 120

    30" Apple LCD + 23" Apple LCD (rotated 270°)



    When computer boots, the rotated display is black; although mouse pointer shows fine. If I physically hot-swap both DVI connectors, one on each card, everything works perfectly until I reboot.


    Then after shutdown for the day, reboot the next morning, I have to swap the connections again. Then it works fine.


    Come on Apple, there is a serious problem here that was brought-up since 10.8 FC and was ignored in 10.8.1.




  • Semvgelooven Level 1 Level 1

    I have the same problem, black screen cursor visible, rotate back to standard screen works fine, rotate to 90 degrees. The screen is black again.. There is no hardware issue as Windows seems to work fine..


    Please fix this!

  • ccampagna Level 1 Level 1

    Runnig Mountain Lion 10.8.1 on a MacPro Early 2009.


    Mountain lion has screwed my multiple monitor life up! With Lion I was able to have 5 multiple monitors rotated 90 degrees running without a hitch. I know... I am a visual learner .  I have 3 Nvidia Geoforce GT 120 512 MB graphics cards. All bought from apple. Why can't mountain lion handle multiple monitors in any rotation? Is there going to be a fix soon? like 10.8.2? Does anyone know if apple is working with Nvidia to correct this?  I am back to just 1 90 degree rotated monitor.This hurts.

    Mac Pro, OS X Mountain Lion (10.8.1), Parallels 7

  • BillP-1 Level 1 Level 1

    I've experienced the same problems with my Mac Pro however, I'm running three cards with one monitor attached to each:


    ATI Radeon HD 4870 512 MB graphics (SLOT 1)

    NVIDIA GeForce GT 120 512 MB graphics (SLOT 2)

    NVIDIA GeForce GT 120 512 MB graphics (SLOT 3)

    All three monitors are LED Cinema Display 27 inch displays


    The ATI card rotates correctly and one of the NVIDIA cards rotates correctly.  The other NVIDIA card shows the black screen with mouse pointer when in any orientation other than standard.  I've changed slots and swapped monitors.  At one point, moving the NVIDIA cards from SLOT 3 to SLOT 4 allowed the third monitor to show up, but it was locked in standard mode.  When attempted to change it, it would reorientate then revert back to standard immediately.


    Guess I'll rearrange my configuration until better fixes are created.

  • BillP-1 Level 1 Level 1

    Rebooting caused problem to reappear but would correct itself if rearranged cables. Looks like it will be slot1 card monitor rotated rest standard. Please fix.

  • Semvgelooven Level 1 Level 1

    Already send some feedback to Apple about this, I can confirm that in the latest beta version of 10.8.2 the problem still occurs, so I guess we need to wait a lot longer.

Previous 1 2 3 Next