Previous 1 4 5 6 7 8 Next 157 Replies Latest reply: Jul 16, 2014 8:49 PM by Ruskat Go to original post
  • rkcorp Level 1 Level 1 (0 points)

    the addressbook 'fix' worked for me for about a week and now i am back to the same frustrations. this makes Mail absolutely unusable in this state. soooo bummed and might have to revert to an alternative mail client. which i dont want to do... i like mail!

  • MXP 150 Patriot Level 1 Level 1 (0 points)

    Hi folks,

     

    maybe not entirely what you are talking about, and I do not mean to hi-jack this nice thread, but it is a MAIL related question / problem, so here goes.

     

    (I started my own thread on this, but only 2 people and a bag of beans visited it, and nobody bothered to reply).

     

    When I move a message in my Yahoo inbox, say from Inbox to one of my custom made folders, MAIL just will not synchronize.

    It stays in the inbox........even the "get new mail" button doesn´t work.

     

    When I stop MAIL, and reopen the program.......it DOES sync, no problem.

    Everything moves to the correct folder

     

    I know there`s an option "Synch with Yahoo" in the menu above, but that does sweet bugger all, unfortunately.

     

    Is there a way to Sync or am I destined to stop the program and restart it everytime??

     

    Your feedback would be greatly appreciated!

     

    MXP 150 Patriot

     

    P.S: Anyone else noticed the custom made folders empty themselves at time, where you have to download all the mails again?

  • Kutten1303 Level 1 Level 1 (0 points)

    For me it did the trick just by repairing permissions. It took some 8-10 minuttes, but it only repaired one plist file, and now everything good and speedy again. Mail is up and running in under ONE second now

     

    K

  • appleuxfail Level 1 Level 1 (0 points)

    Another way to speed up Mountain Lion's Mail.app, compared to SL or older versions, is to disable the conversation view.

     

    Go to "View" -> "Organize by conversation" <- untick it.

     

    this makes it heaps faster in general, aside from the problems others have listed..

  • FUNK1196 Level 1 Level 1 (10 points)

    I've tried all these options. This is unacceptable, and shameful.

  • barrylazow Level 1 Level 1 (0 points)

    I tried this and it did not solve the problem. it actually caused other problems with my printer that I had FINALLY solved...  Be careful with this one

  • to_bias Level 1 Level 1 (0 points)

    That worked for me, thank you!

  • Kutten1303 Level 1 Level 1 (0 points)

    Repairing disc permission helped me. Good luck  ;=)

  • Alvin Koh Level 1 Level 1 (45 points)

    I had the same slow lookup issues and tried most of the suggestion in this thread without success. I then took a look at /var/log/system.log and noticed the following message:

     

    Nov 14 22:56:14 bigfella Mail[762]: Error creating source folder ~/Library/Application Support/AddressBook: Error Domain=NSCocoaErrorDomain Code=4 "The file “AddressBook” doesn’t exist." UserInfo=0x7facc40c5e30 {NSFilePath=/Users/alvin/Library/Containers/com.apple.mail/Data/Library/Applica tion Support/AddressBook, NSUnderlyingError=0x7facc409efb0 "The operation couldn’t be completed. No such file or directory"}

     

    I then went into ~/Library/Containers/com.apple.mail/Data/Library/Application Support and noticed that AddressBook was linking to some garbage.

     

    $ ls -l

    total 48

    lrwxr-xr-x  1 alvin  staff   46 Aug 16 23:25 AddressBook -> pp??m?4??@??q???????;???????=x??K1????`??mGGz?

    drwx------  3 alvin  staff  102 Aug 21 09:07 CrashReporter

    drwx------  2 alvin  staff   68 Aug 16 23:25 Mail

    lrwxr-xr-x  1 alvin  staff   47 Aug 16 23:25 SyncServices -> ../../../../../Application Support/SyncServices

    lrwxr-xr-x  1 alvin  staff   41 Aug 16 23:25 iCloud -> ../../../../../Application Support/iCloud

     

    I renamed AddressBook to Old_AddressBook and relinked AddressBook:

     

    $ mv AddressBook OLD_AddressBook

    $ ln -s ../../../../../Application\ Support/AddressBook

     

    I then restarted Mail and now lookups are instantaneous again. Hope this helps some of you.

     

    Alvin

  • barrylazow Level 1 Level 1 (0 points)

    What application or utility did you use to do this?

  • Alvin Koh Level 1 Level 1 (45 points)

    Sorry, I used Terminal.

  • barrylazow Level 1 Level 1 (0 points)

    I tried this in Terminal and got the following error

     

    no such file or directory

     

    and

     

    -bash: $: no such command found

  • Alvin Koh Level 1 Level 1 (45 points)

    The "$" is the command prompt so you do not type it. Open the Terminal utility and do the following:

     

    1. Go to the folder specified

     

        cd ~/Library/Containers/com.apple.mail/Data/Library/Application Support

     

    2. List the files in the folder

     

        ls -l

     

    3. If you see a line like the following then you have a similar issue to mine.

     

    lrwxr-xr-x  1 alvin  staff   46 Aug 16 23:25 AddressBook -> pp??m?4??@??q???????;???????=x??K1????`??mGGz?


    4. To rename the AddressBook link

     

        mv AddressBook OLD_AddressBook

     

    5. To relink AddressBook correctly

     

        ln -s ../../../../../Application\ Support/AddressBook

     

    Alternatively you can try the following:

     

    1. Open a Finder window to your home folder

     

    2. Command-Shift-G and type "Library/Containers/com.apple.mail/Data/Library/Application Support"

     

    3. The AddressBook icon should show up as a folder shortcut. If it appears as a file shortcut then you have the same problem as me.

     

    4. To fix just rename AddressBook to OLD_AddressBook

     

    5. Now open a new Finder window and navigate to "Library/Application Support"

     

    6. Hold down Command-Option and drag the AddressBook folder to the first window. This will create an AddressBook folder shortcut in Library/Containers/com.apple.mail/Data/Library/Application Support.

     

    Hope this helps.

     

    Alvin

       

  • barrylazow Level 1 Level 1 (0 points)

    I tried what youn suggested (the second method) and then tried to address a message.  It wouldn't even link to an address book at all (no data) so I deleted the "moved" address book and went back and renamed the "old_addressbook" to "addressbook" and it seems to link again but I still have the slow rainbow spinning problem...

     

     

     

    These are the files under Address book

     

    ABAssistantChangelog.aclcddb

    Migration 20120406061143-23534.abbu.tbz

    Migration 20111113091409-5477.abbu.tbz

    Sources

    AddressBook-v22.abcddb

    Configuration.plist

    Images

    MailRecents-v4.abcdmr

    Metadata

     

    Sources, images and Metadata are folders with files in them

     

    I'm thinking of going into an Apple store and trying one of their so callled geniuses.  I've had varying success with it

  • thebluedevil Level 1 Level 1 (0 points)

    That did the trick...for now at least! Thank you so much. 

Previous 1 4 5 6 7 8 Next