Previous 1 4 5 6 7 8 9 Next 126 Replies Latest reply: Jun 21, 2013 1:47 AM by Mad-Hias Go to original post
  • Smokolator Level 1 Level 1 (0 points)

    I get Time Machine backups and CCCloner clones occuring during Power Nap, with the lid closed, only if my external (portable) drive is connected directly to the USB port on my MBP Retina.

     

    If the external drive is connected via a USB hub I get the "Disk not properly ejected" error when the MBP wakes. This error prevents any further activity on the external drive as it needs to be disconnected then reconnected so that it can mount again.

     

    In other words once you get the "Disk not ejected properly" error your external drive is no longer mounted.

     

    I hope Apple fix this soon! The only way I can get a BackUp during Power Nap is to eject my BackUp disk, remove it from the hub and plug it directly into a USB port prior to putting it to sleep.  As a work around I've set Power Nap to "Never" and only put the display to sleep when I leave the MBP overnight.  Less than ideal!

     

    C'mon Apple - fix this.

  • Mad-Hias Level 1 Level 1 (5 points)

    Smokolator wrote:

     

    If the external drive is connected via a USB hub I get the "Disk not properly ejected" error when the MBP wakes. This error prevents any further activity on the external drive as it needs to be disconnected then reconnected so that it can mount again.

     

    Same problem here. But I don't use a hub. The external drive is always connected directly to the rMBP (via USB 3). When I close the lid and open it again, I ALWAYS get the "Disk not properly ejected" message. Of course that prevents Time Machine from making backups when the Mac is sleeping.

     

    Mail seems to work so far. But mails I get on my iPhone are not filtered. On the iPhone I get all the spam stuff, no matter if Power Nap is switched on or off.

  • Karl Johnson Level 1 Level 1 (15 points)

    I'm using a TIme Capsule and it works fine with Power Nap on my rMBP, so I don't have a problem, but I agree PN needs to be compatible with TM backups done to a plugged in external to be useful.

     

    Mail. When it's working with Power Nap, the messages are collected and the spam filtered. It only runs once an hour, but it does help keep the junk to a minimum when I connect with my iPhone.

     

    Unfortunately it fails as often as it works. It can fail in two ways. Most of the time it won't collect messages or do any filtering. Other times it collects message, and filters the spam, but although the spam is flagged as such, the messages remain in the inbox.

     

    I'd leave it on and let it work since 50% is better than 0%, but Power Nap seems to have some other side effects. The rMBP seems much slower when waking up, and a few it didn't want to wake up at all and I had to do a reboot. Every now and then the rMBP would wake, but Mail, Calendar, and Contacts would be unresponsive and had to be force-quit. The problems went away with Power Nap tunred off.

  • Mad-Hias Level 1 Level 1 (5 points)

    So it still seems to be a very buggy feature. Let's hope they'll fix the whole thing in 10.8.1.

  • Karl Johnson Level 1 Level 1 (15 points)

    Agreed.

     

    All in all I'm happy with Mountain Lion. The installation went well and Power Nap is about the only problem I've run into.

     

    Power Nap would be great if it worked, but it's not a biggie if it doesn't.

  • Mad-Hias Level 1 Level 1 (5 points)

    Right, ML is a great OS and also for me Power Nap seems to be the only problem so far. For me Power Nap would be a great way to backup my system. I'd would be great if the Mac would backup itself at night while sleeping.

  • Smokolator Level 1 Level 1 (0 points)

    Is your external drive powered by the MBP or does it have it's own power supply?  Mine is powered from the MBP when directly connected.  I'm guessing there may be a problem arising from external drives being put to sleep before that are properly ejected during Power Nap.  I'll try turning off the "put hard disk to sleep option" in System Preferences > Energy Saver(?) and see if that makes any difference when connected via the USB hub.

     

    Or has someone tried this already?

  • Mad-Hias Level 1 Level 1 (5 points)

    My external drive has its own power supply.

    Please let me know if you had success turning off the hard disk sleep option.

  • Mad-Hias Level 1 Level 1 (5 points)

    Any new experiences with Power Nap running 10.8.1?

  • Smokolator Level 1 Level 1 (0 points)

    I've just updated - I'll let you know how it goes.

  • Smokolator Level 1 Level 1 (0 points)

    Nope, same deal.  If my backup drive is connected and powered directly by the MBPs USB port it survives a sleep and wake sequence.  If it's connected and powered through a USB hub I get the "disk not ejected properly" error when waking from sleep.

     

    And as before the USB thumb drive survives the sleep/wake cycle even though it is connected to the USB hub.

     

    An optical drive also get's dumped from the hub.

     

    I've also tried turning off power nap completely, then putting the MBP to sleep, and I get the same results. 

     

    Has anyone else seen this on non-retina MBPs, or on other macs running Mountain Lion?

  • Karl Johnson Level 1 Level 1 (15 points)

    I installed 10.8.1 on my rMBP when it was released two days ago. I didn't hold much hope for it to improve Power Nap since it wasn't mentioned in the update notes...

    http://support.apple.com/kb/HT5418

     

    Although it wasn't mentioned in the release notes some people were reporting improvements with battery life of their portables...well, a return to pre-Mt. Lion battery life anyhow. So you never know what might be affected in an update.

     

    Anyway, I did the update, and since it was potentially battery related, I also did a SMC reset...

    http://support.apple.com/kb/HT3964

     

    The results? Well, Power Nap is worse if anything. Not only is Mail not being processed (which was working about 50% of the time), but now Time Machine isn't backing up (which was working 100% of the time).

     

    I opened up the utility Console and checked the log files. I'm no expert, but it was clear Time Machine hadn't run. It only had this entry. Once it failed it didn't appear to try again...

     

    8/24/12 10:50:03.036 PM airportd[2845]: _doAutoJoin: Already associated to “xxxxxxx”. Bailing on auto-join.

     

    The only mention of Mail was in these three entries...

     

    8/25/12 12:39:09.494 AM SyncServer[3109]: [0x7fcec0c0be80] |DataManager|Warning| Client com.apple.Mail sync alert tool path /System/Library/Frameworks/Message.framework/Resources/MailSync does not exist.

     

    8/25/12 1:32:26.351 AM SyncServer[3223]: [0x7fd6a840be80] |DataManager|Warning| Client com.apple.Mail sync alert tool path /System/Library/Frameworks/Message.framework/Resources/MailSync does not exist.

     

    8/25/12 5:42:01.606 AM SyncServer[3789]: [0x7f885b40be80] |DataManager|Warning| Client com.apple.Mail sync alert tool path /System/Library/Frameworks/Message.framework/Resources/MailSync does not exist.

     

    I did a search on "MailSync does not exist" and didn't come up with much. It was in some log reports people posted when trying to get their OS X problems fixed. One indicated the MailSync error might be from some old device syncing...

    https://discussions.apple.com/thread/3294602?start=0&tstart=0

     

    It's quite possible that could be the case on my machine since I've used Migration Assistant many times while upgrading hardware over the years.

     

    Maybe 10.8.2?

  • Mad-Hias Level 1 Level 1 (5 points)

    Same here. Power Nap is (not) working exactly as before (10.8.0). Still no TM backups, still the "not properly ejected" error. Let's hope for 10.8.2. Or maybe 10.9.....

  • Smokolator Level 1 Level 1 (0 points)

    I just tried the same drive/hub combo on my iMac running 10.8 and didn't get any "not properly ejected" errors when sleep/waking - but power nap is not available on this Mac.  Do we know if the problem is specific to MBPr or have people had the "not properly ejected" issue on other Macs?

     

    BTW toggling various options in Energy Saver didn't make any difference on the MBPr. 

  • simoncheng Level 1 Level 1 (0 points)

    I still could not get the "power nap" working on my base rMBP. So frustrated. I tried every way suggested in here and by apple. None seemed to work. I reset the SMC a couple of thousand times, no luck. I even did a clean reinstall of the mountain lion yesterday, still I could not get the power nap working with the Mail (i left the mail app open while putting rMBP to sleep). I don't own a Time Machine so I don't know whether the power nap works with the automatic backup.

     

    There is something weird I noticed. I re-dowanloaded the power app update from apple site today, trying to install the update for the second time. Then i saw an alert of saying "This feature is not supported on your system." (or something similar to that). I'm pretty sure my hardware meets the requirement of powernap( rMBP + Mountain Lion (10.8.1) ).

     

    Hope Apple can investigate into this and provide a solution soon.

Previous 1 4 5 6 7 8 9 Next