Previous 1 2 3 Next 40 Replies Latest reply: Mar 6, 2016 12:07 AM by spacenewt
Dew Wong Level 1 Level 1

I used to be able to convert Traditional Chinese to Simplified Chinese and vice versa in OS X Lion. After I upgraded it to Mountain Lion, I cannot do so anymore. It just keeps asking to run the service which I have already done it. After clicking "Run service" nothing happened.

 

Any help please

 

 

Thank you in advance

Solved by Tom Gewecke on Jul 29, 2012 2:18 PM Solved

Dew Wong wrote:

 

I also thought so but before I saw your reply, I deleted that account and migrated it back from a time machine backup and unexpectedly, the problem solved.  Strange..

 

Not so strange.  Your backup of that account had a good copy of whatever .plist had gone bad, so that solved the problem.

Reply by Tom Gewecke on Jul 29, 2012 11:50 AM Helpful

Dew Wong wrote:

 

FYI, I just created a new admin account and it did solve this issue. That means something's gone wrong with my main account. Help pls

 

Normally that means that there is a bad .plist list in Home/Library/Preferences.  That folder is normally hidden, but you can get to it by doing Finder > Go while holding down the Option/alt key.  Sorry I do not know which .plist would be the problem in this case.

All replies

  • Dew Wong Level 1 Level 1

    Screen Shot 2012-07-29 at 18.07.00.pngScreen Shot 2012-07-29 at 18.01.36.pngScreen Shot 2012-07-29 at 18.01.30.png

     

    Still, nothing happened

  • Dew Wong Level 1 Level 1

    FYI, I just created a new admin account and it did solve this issue. That means something's gone wrong with my main account. Help pls

  • Tom Gewecke Level 9 Level 9

    Dew Wong wrote:

     

    FYI, I just created a new admin account and it did solve this issue. That means something's gone wrong with my main account. Help pls

     

    Normally that means that there is a bad .plist list in Home/Library/Preferences.  That folder is normally hidden, but you can get to it by doing Finder > Go while holding down the Option/alt key.  Sorry I do not know which .plist would be the problem in this case.

  • Dew Wong Level 1 Level 1

    I also thought so but before I saw your reply, I deleted that account and migrated it back from a time machine backup and unexpectedly, the problem solved.  Strange..

  • Tom Gewecke Level 9 Level 9

    Dew Wong wrote:

     

    I also thought so but before I saw your reply, I deleted that account and migrated it back from a time machine backup and unexpectedly, the problem solved.  Strange..

     

    Not so strange.  Your backup of that account had a good copy of whatever .plist had gone bad, so that solved the problem.

  • groovysundae Level 1 Level 1

    Hi, I have the same problem too. I tried to delete the textedit plist and copy the working ones before the upgrade from my backup but it didn't work. I tried moving all the plist to the desktop and restarted, but the text conversion is still not working. Is there no other way to rectify this other than doing a clean reinstall? I've also discovered under services preference menu, there are four selections for converting texts, that shouldn't be the case, it should only be two. Anyone can help?Screen Shot 2012-07-30 at 5.44.08 PM.jpeg

  • Dew Wong Level 1 Level 1

    I recommend you to backup your current user account to time machine and migrate it back. this worked for me even I restored it from the backup that contains this issue. However, the problem solved after migrating back.

  • groovysundae Level 1 Level 1

    Hi Dew,

     

    Yes, that seems to be the only way. I did just that 2 hours ago, migrating everything back from the time machine and now the text converter works just fine. I last check the service preference, there's now only two selections for text converting as compared to four previously. I hope not many people are facing the same problem because it's rather time consuming for a small problem.

  • Tom Gewecke Level 9 Level 9

    groovysundae wrote:

     

    I hope not many people are facing the same problem because it's rather time consuming for a small problem.

     

    Yes, there must be an easier way.  I did not have this problem myself, but I installed on an empty partition.  I wonder if it only affects those who install over something else.  Since it does not affect a new account, it logically should be related to a .plist, cache or permissions issue in the main account.  But hard to know how to find which one.  I wonder if the system log says anything useful on systems which have the problem.

  • alidarbac Level 1 Level 1

    I was having the same problem as groovysundae and Dew Wong and I think I found a solution that doesn't involve migrating accounts, etc.

     

    I too did an upgrade install of Mountain Lion on top of Lion. I was getting the same thing as groovysundae: highlighting simplified Chinese and going to the Services menu wouldn't bring up the Convert option. Moreover going to the Preferences pane, I saw four options instead of two for converting Chinese.

     

    What I did to solve this was rereun the Simplified and Traditional Chinese installers located in the Home/Mac OS X Install Data directory (SimplifiedChinese.pkg and TraditionalChinese.pkg) Now converting Simp->Trad and Trad->Simp options come up when I highlight Chinese in TextEdit.

     

    Where the Convert Chinese options no longer works for me is in other programs. For instance, on Lion I mostly used the Convert Chinese options in TextWrangler since it could tell which characters weren't properly converting to Big5.

  • joimage Level 1 Level 1

    Hi alidarbac, I've tried your way, but I could not find SimplifiedChinese.pkg and TraditionalChinese.pkg. Could you tell me how to find them? Thanks.

  • nicklim Level 1 Level 1

    i've called apple support hong kong and here's the solution (works on apple's app like textedit but not on MS office applications):

     

    1. go to /system/library/services and copy "ChineseTextConverterService" to desktop.

    2. quit all running applications.

    3. log out and log in again.

    4. move "ChineseTextConverterService" from desktop back to where it was. when asked click on "replace".

    5. log out and log in again.

    6. of course boxes of "convert text from..." under system preference/keyboard/keyboard shortcuts/services/text should be checked (turn on)

     

    i'm still looking for solution on how to make it work on MS office applications. if anyone knows one, pls post. thanks.

    Screen Shot 2012-08-15 at 10.00.30 PM.jpg

  • antdude Level 1 Level 1
    expertise.macosx
    Mac OS X

    Does this trick work in the latest English MS Office 2011 in updated English Mac OS X 10.8.2 (also in 2008 and 10.5.8 -- upgraded and migrated from old MBP to a new MBP))? My client and I are having the same problem in http://groups.google.com/group/chinesemac/browse_thread/thread/e04b62ea7fec794f ...

     

    Thank you in advance.

  • antdude Level 1 Level 1
    expertise.macosx
    Mac OS X

    nicklim wrote:

     

    ... i'm still looking for solution on how to make it work on MS office applications. if anyone knows one, pls post. thanks.

    Did you ever get this to work in MS Office (e.g., 2008 and 2011)?

Previous 1 2 3 Next