Previous 1 2 3 Next 30 Replies Latest reply: Feb 27, 2015 2:17 PM by Ralph Johns (UK) Branched to a new discussion.
hellodaniel Level 1 Level 1

I've experienced a crippling memory leak with taking up: 


60gb of virtual memory

13gb real memory

75% CPU

Screen Shot 2012-08-15 at 9.43.37 AM.jpg

After force-quitting it's freed up the RAM but not the virtual memory and, so, I'm still getting this:

Screen Shot 2012-08-15 at 9.47.14 AM.jpg

...despite having 150gb disk space free (was 210gb this morning!).


Obviously the virtual memory has filled up and not been freed. I'm sure I can clean up the swap space issue but I'm concerned about this ongoing.


All the related articles discuss iMessages beta, but I've got a clean Mountain Lion install that has never had iMessages beta installed.

Macbook Pro 8,3, Mac OS X (10.7)
  • duosx Level 1 Level 1

    Since my Mountain Lion install, I too have begun noticing 40+ gigs of hd space slowly dwindle away until I am forced to restart to retreive the space on my startup disk.  I havent caught the imagent yet as the culprit, but this I am now getting "startup disk out of space" errors and cant find the app that is direct culprit.

  • KJBlack Level 1 Level 1

    Dear HelloDaniel,


    I'm getting this same issue at different levels on three different machines.  Two of the machines have Mountain Lion installed and one only has Lion installed.  I orginally thought this was a hardware issue. (One of the main machines could not boot into safe mode.) I'm now experiencing it on my work machine and a machine at a friend's house where I have a user account.


    If I was to take a step back I would think it has to do with some software  issue between all three computers.  I don't have the same sw on all machines but I really can't track it down to anything except my apple id/icloud account being active on all three accounts.


    I'm hoping that this gets fixed soon.  If anybody responds with a solution to the "imagent memory leak" issue I would love to hear about it.



  • Philip Lamb Level 1 Level 1
    Servers Enterprise

    I've also just run into this for the first time, on Mac OS X 10.8.1. Pretty annoying.


    There are a bunch of other threads like this, e.g.:

  • David-Z Level 1 Level 1

    try typing "purge" in terminal, that should free unused memory back to the OS.


    my OS running on SSD had some issues, but might had been related to the SSD, once i flashed the firmware all seems to be working ok.


    as for Duosx comment, there are some settings to stop the disk from filling up, this most likly coused when the OS sleeps and save the active ram to disk files. but could be just plain old corrupted files, have you tried using diskutil and repairing the disks?

    (cannot locat atm the link to the sleep settings, some terminal syntax)



  • putnik Level 3 Level 3
    Mac OS X

    The reducing disk space may be explained in Pondini's well known user tips.



    The virtual memory problem may be related to third party software, which could be checked by a Safe Mode boot.



    Somebody likened the 'purge' command to rolling a hand grenade into the supermarket to clear the queue at the checkout.  It will work, but it is probably faster in the end, to wait patiently.

  • Philip Lamb Level 1 Level 1
    Servers Enterprise

    That's nice that you're trying to be helpful, but none of that is in the slightest relevant. The problem is runaway memory usage by a background process which appears to be part of Messages. The problem has evidently been around since the Messages beta, and is still present in at least 10.8.1 and possibly 10.8.2 The fix has to come from Apple.

  • putnik Level 3 Level 3
    Mac OS X

    I don't have the problem with Messages so can't really help in the diagnostics.  I would still suspect third party apps as being the probable cause.

  • duosx Level 1 Level 1

    I've repaied permissions, run disk utility, rebuild all kext & cache, rebuild spotlight... nothing fixes it.

  • KJBlack Level 1 Level 1

    Yep, I'm still experiencing it too.  Work computer and home computer.  As an odd aside, while there's no pattern when it happens on my home computer it does seem to crop up + or - 10 mins at 12:30 every day on my work computer.  I kill it in the Activity Monitor, imagent and Messages and most often I restart Messages and it calms down.

  • jaytuten Level 1 Level 1

    Same problem. Upon bootup my memory is drained very quickly by the process Imagent. I stop the process in Activity Monitor, but it returns instantly though I am not running the new messages app. After killing it a number of times n Activity Montior, it settles down and does not chew through the RAM. Any ideas on how to kill this process entirely? I have a Genius Bar appointment tomorrow, but it is right before kickoff for my college team and I'd hate to spent the afternoon goign through this with a 'Genius.'

  • BarrettF77 Level 1 Level 1

    I was importing some stuff to aperture last night.  I noticed it too.  A reboot fixed it, but what a POS.  Sound stutters, crashes, video stutters, corruption of aperture, and now this.   (Yes, I know aperture was updated today.  But seriously?!?!  I already fixed it on my own.  Apple is the new version of digital waste).  I can't believe how bad mountain lion is. 


    They need to fix this and fast before other steps are taken. 

  • Fred Kahl Level 1 Level 1

    Having this issue on two macbooks ever since upgrading to Mountain Lion:

    -brand new Retina Macbook Pro

    -2 year old Macbook Pro


    Apple support had me go to the store, where they verified that the new machine's hardware was fine. Of course the issue didn't happen when I was there, but both the phone support and genius folks told me the issue was software and that my next step was to wipe the entire drive and start over again. I'd really like to avoid havign to reinstall all the software....

  • BarrettF77 Level 1 Level 1

    Don't do this.  It isn't fixing it.  Either revert to lion, hang out for a fix, or buy windows.  Otherwise you're wasting your time.

  • KJBlack Level 1 Level 1

    I hear you ... and then the question is ... which app might be causing the issue?   The rule of halves is helpful but tedious when you are considering the amount of apps one has.

Previous 1 2 3 Next