Previous 1 2 3 Next 40 Replies Latest reply: Oct 10, 2012 5:54 PM by stw2186
abowl0e Level 1 Level 1 (0 points)

For two weeks I have not been able to download apps <20mb on my Sprint iPhone 4s.  I'm not the only one, as several people in the store at the time were having the same issue.  They didn't know what to tell me because "Apple and Sprint know about the issue, but neither one wants to take the blame."

 

My Sprint Android devices download apps just fine.

 

However, my iPhone 4s downloads apps on WiFi just fine.

 

Wat do Big Fruit?  Help me out here please.  Downloading apps is a rudimentary feature of the smartphone at this stage in the game. 

 

Thank You

 

 


iPhone 4S, iOS 5.1.1
  • Abledfire Level 1 Level 1 (40 points)

    We need more information. Do you get an error when trying to download, if yes, what error? Does it get stuck on waiting? Can you sync the apps to the device from a computer?

  • abowl0e Level 1 Level 1 (0 points)

    Here is what I have tried:

     

    Restart

    Reset All Settings

    Restore from iTunes

    Restore Manually

    Faux iTunes account to counter check my primary account and see if it's my primary account specifically

    Signing in and out of iTunes

    Checking my Updates

    Checking my Queue

    Deleting and redownloading all of my apps in iTunes

    Deleting the commonly corrupted download.28.sqlitedb file

    Deleting and re-entering all of my Account info (including billing, in iTunes)

    Checked the ownership of the launch daemons to ensure they are mobile and not root

    Restored older firmware, updated via iTunes

    Restored on a Mac, Restored on Windows 7, Restored on Windows 8 - on 3 different machines

    more I can't remember...

     

    Also, this problem is well documented by now.  Go into the App Store, install an app, it appears on the Springboard, displays as "waiting' after a minute (metaphorically speaking) it says "Loading" but the progress bar is already half way full.  At this point, it goes back to "Waiting...".  This cycle propagates itself a few times and then the message "Application cannot be downloaded at this time [Done] - [Retry]."  If I choose retry, the cycle continues, vicsious and relenting.  If I click done, the "half downloaded app" just sits there on the Springboard "half downloaded."

     

    Of note too is that I stopped in at a Sprint store today where the techs with iPhones were also having the problem and said they are hearing about it more and more.  They also said that both Apple and Sprint are aware of the problem but neither company want's to take responsibility because of the fact that all of Sprints other phones, such as Android handsets are able to download apps.  Apple doesn't want to take the blame because it's only Sprint's network that is having the issue. 

     

    So, who is the whipping boy in this situation? 

  • tekkierich Level 1 Level 1 (0 points)

    I can confirm that I am having the same problems on my 64GB Sprint 4s.  I have had the issue for 3 or 4 weeks and I have been in Maryland and Pennsylvania durring that time.

  • KingLion278 Level 1 Level 1 (0 points)

    I am having the same isssue its been about 3 weeks for me, I have the 4s

  • stw2186 Level 1 Level 1 (0 points)

    Any updates yet?  I am having the same problem for about two weeks now.  I called Sprint and they also told that they and apple are "working" on it.  Let me know if any of you guys get it working!

  • NascarGrl4Life Level 1 Level 1 (0 points)

    Well, I'm having the same issue. Done all you have done, long list. Sprint Care Mr, Kenneth Senior Care advisor never called me back. Very true Sprint and Apple neither one taking credit for this issue. If I find out who the whipping boy is, they have an spanking coming!

  • NascarGrl4Life Level 1 Level 1 (0 points)

    Apps on wifi want download!

  • Meg St._Clair Level 8 Level 8 (43,760 points)

    You really need to look up the actual meaning of the phrase "whipping boy". You keep using it incorrectly.

     

    http://en.wikipedia.org/wiki/Whipping_boy

     

    Also, threatening physical harm to people on a public forum seems imprudent.

  • NascarGrl4Life Level 1 Level 1 (0 points)

    I wasn't meaning harm, kinda hard to mean that, when I have better chances of winning the lottery than me spanking someone. By the way Apple is aware of the issue, a patch will be released, date unknown. You have a blessed day!

  • NascarGrl4Life Level 1 Level 1 (0 points)

    I was informed a patch is typically released to fix issues of this nature. Fix is unknown at this time, when it would be released. Going Andriod, good-bye Apple.

     

     

    Devin,

     

    Thank you for calling AppleCare Technical Support.  Today we discussed updating and downloading Apps.  If you have any further questions, concerns, or comments, please contact me at the information below.  Thank you again for calling Apple and have a great day.

     

     

    -----

     

    Have you tried Express Lane?

     

    Jump start your next support call by creating a case online first. Let us know the best time to reach you, and we'll connect you to an Apple Advisor who has the answers. Put yourself in the driver's seat and check out Express Lane today!

     

    http://expresslane.apple.com

     

    <Edited By Host>

  • abowl0e Level 1 Level 1 (0 points)

    Actually the suggested use of "whipping boy" in this context would be the pretense that we the consumer are the collective whipping boy to Apple and Sprint being the collective prince.  They "mess up" and don't take any responsibility and we the consumer are the ones getting proverbially whipped.  But hey, thanks for playing.

     

    Anyway.  It's going on what, a month now and this still doesn't work.  I also installed iOS 6 beta 4 via a developer account onto a mate's Sprint 4s and guess what...it still doesn't work.  I have a feeling there is *no* fix in the works and I won't be buying anymore Apple products anymore, nor will I be resigning with Sprint. 

     

    *All I ask for, is what I paid for* 

     

    Let me skip out on paying one of these companies for a month and see how they feel.  Apple is too big to be concerned with consumers, they have that luxury, but Sprint.  C'mon man.  TMous is launching unlimited data in a few days and you guys are in no position to be so mum about this. 

     

    Good luck NascarGRL - and don't let pedants like Meg St. Claire get you down in life.  Note how she contributed zero to finding a solution.

  • scottmk Level 1 Level 1 (0 points)

    My teenager came to me an hour ago with this same problem with her 16GB iPhone 4S on Sprint (problem not happening on my 32GB 4S on Sprint).  Tried many of the suggested fixes found online, nothing worked, except for this one:

     

    Try signing out and in from the Apple Store under Settings>Store on your iPhone.

     

    Did that, and then when I went to the App Store itself it asked me to log in, which I did.  The first App I tried to update did so, straight through, on WiFi.  I've now downloaded a new App install, and it installed right away.

     

    I was very discouraged to read that it's a known problem between Sprint and Apple, and neither party is willing to take responsibility.  Since my 32GB 4S did not exhibit the problem, I didn't believe it was isolated to Sprint.

     

    Anyway, try the above suggestion.  Worked for me.

     

    Here's the original post: http://osxdaily.com/2012/03/17/fix-ios-apps-stuck-on-waiting/

     

    Scroll down to poster "SOLUTION."

  • NascarGrl4Life Level 1 Level 1 (0 points)

    Thank You!! Well, I'm only leaving Sprint, since they fail to compensate for what I pay for, however not getting. I'm also done with Apple products! Meg St. Claire, well no solution, maybe she works for Apple. Tmous will look into them. I love Sprint, however I've been hung up on, told I would receive call back, never happened. Sprint, Alex who is an employee told me, "it's a device issue, you need to back off Sprint", following his advice. :)

     

    Apple Senior Care Advisor also gave me the run around, so I shall treat them, as they treated me, no return call back. Verizon offered me a nice deal, no unlimited data plan. Though I can live with an Android and the plan they offered me. If I'm not satisfied for 90 days, I can let them go with no contract penalties. :) this 64 GB iPhone I get 400-450 buckaroos from Verizon.

     

    Thank you again. It's not just a Speint issue, daughters family with AT&amp;T are having same issue, however Sisters family with Verizon on all their iPhones, no issue, who knows.

     

    Have a blessed week!

  • NascarGrl4Life Level 1 Level 1 (0 points)

    Tried this and much more, nothing has worked. Thank you very much for taking the time to assist. God Bless!!

Previous 1 2 3 Next