Previous 1 2 3 Next 40 Replies Latest reply: Jul 18, 2013 9:24 PM by cnlwoo
FourtyEightFan Level 1 Level 1

I upgraded to 10.8.2 this afternoon and now my son's parental controled account is broken. Whenever he tries to access a web page via Safari (or Chrome) he gets a message stating "Safari attempted to access a secure website..." I haven't changed anything on his account - it worked fine before the upgrade, so I assume 10.8.2 caused the problem.


I do have Parental Controls on his account, but web browsing is set to Unlimitied Access.


Please Help!

MacBook Pro, OS X Mountain Lion
  • George Pan Level 1 Level 1

    Just confirming that I have the same issue. It seems that the youtube bug that started with 10.8 has been fixed, but now the "secure website" warning appears all the time, even though the settings allow for unlimited access.

  • grantalewis Level 1 Level 1

    Yes, same here. Happening in a Mac technology lab with six workstations. The student account has Parental Controls in place. The account is set for unlimited access to websites. Clicking in the Address Bar and trying to type any web address produces this error/alert.

  • grantalewis Level 1 Level 1

    Still experimenting, but I think I may have solved the problem. Try this:

    • Log out of the account with Parental Controls enabled.
    • Log into an account with administrative priveleges
    • Go to System Preferences | Parental Controls
    • Click the padlock and authenticate with the administrator's credentials
    • Click on the account with the Parental Controls enabled
    • Turn off Parental Controls for that account
    • Log out of the administrative account
    • Log in to the account that had Parental Controls enabled
    • Try browsing to see if any error messages appear (none should)
    • Log out of the account
    • Log back into the account with administrative priveleges
    • Follow the same process as earlier to find the account that should have Parental Controls enabled and enable restrictions accordingly; ensure under the Web tab that "Allow unrestricted access to websites" is enabled (if that's the setting you wish the account to have... which in my case, it is)
    • Log out of the administrative account
    • Log in to the account that has Parental Controls enabled
    • Try browsing to see if any error messages appear (none should)


    This has worked for me on one of the six workstations I'm administering. I'll have the opportunity to test the remaining 5 in a few minutes.

  • grantalewis Level 1 Level 1

    Weird. Seems to have worked on one of the workstations, but didn't work on the other 5. Based on what I'm finding in other threads, I have the sneaking suspicion that the sixth one may revert to having problems after a period of time.

  • grantalewis Level 1 Level 1

    Follow-up: this is a confirmed bug and has been reported to Apple. The tech was able to duplicate the behavior on a 10.8.2 test machine.

  • Laurakcb Level 1 Level 1

    Same exact problem with my son's computer. This is beyond frustrating for homework purposes. I finally did get it to stop after completely turning off his parental controls in his account and then also in the admin account. I didn't realize at the time that's what I was doing but after reading the other posts I realized that's what I had done. However, before the update his parental controls were set to try to allow appropriate websites and I just approved ones he needed added. But now all of those websites that I had approved before are erased--and there were a lot of them. I don't know if anyone else has this same issue or not with the previously approved sites erased.

  • bluedakar Level 1 Level 1

    Here we are again. Another update, another Parental Controls bug. After finally finding the workaround to the Time Limits bug after upgrading to Mt. Lion I now have the dreaded "secure website" bug of 10.8.2. The only way I can find around this is to turn off Parental Controls. Aren't there any developers that test these Parental Controls on their kids when preparing an update? I'm a big fan, but come on Apple! Trying to fix these bugs reminds me of my Windows days! Worked great before the update, none of the settings have changed (unlimited access). Ugh!

  • grantalewis Level 1 Level 1

    Been experimenting all day on this. I'm about to decide that creating a new user account with Parental Controls enabled fixes the "secure website" problem. You'll have to back up all of the old user's data and bring it over into the new account, of course.

  • Tekneek Level 1 Level 1

    This is a bug that has existed before, in previous versions of Mac OS X, and apparently has returned once more. I have little confidence that appropriate testing procedures are in place.

  • raama.srivatsan Level 1 Level 1

    sorry. doesnt work

  • FastOne Level 1 Level 1

    Having the same problem (with Minecraft specifically).  I'm glad I didn't do too much fiddling with it before reading this post.  Clearly parental controls didn't get much QA before 10.8 was released.

  • Mickey4nay Level 1 Level 1

    Yes me to, I have updated to 10.8.2 and hav the annoying  message.  I have dropbox so this thing is coming up all the time.  If you look at the parental control authorised website list I can see the websites I keep authorising over and over again


    Are apple becoming like Microsoft now with these updates.......



  • hokiefans Level 1 Level 1

    Ran into same issue.  Contact apple help.  Had t prove it was not a google chrome issues (kind of funny when i had to point ot the apple supprt app as a blocked app).  Response was that this would have to be sent up to the developers and I should wait until bug fix.  kind of confused as to when I would ever hear if it was fixed.


    Short term answer found out on own.  Turn off parental controls.  Not ideal, but stops me from having to allow all normal sites. 


    Mac must be too busy fixing maps instead of testing updates.

  • Weborican Level 1 Level 1

    Same here. I'm afraid we are not going to have to wait until 10.8.3 in hopes it gets fixed on that release. Ugh!

Previous 1 2 3 Next