Previous 1 3 4 5 6 7 Next 145 Replies Latest reply: Feb 27, 2013 6:28 AM by bananagas Go to original post
  • Torn Cloud Level 1 (0 points)

    Afternoon all,


    I too am experiencing the same issue as others have reported.


    Upgraded to IPad 3 and Iphone 4S to IOS 6 yesterday evening at home and all worked well (via apple extreme base station) over wireless network.


    At work however, we use Netgear WAG 102 wireless routers and I cannot connect with "Unable to join the network" message being displayed on every attempt to fix the issue.

    Any help from Apple would be greatly appreciated!

  • gsafety Level 1 (10 points)

    We have a Westell modum and can't connect to it since I upgraded my I-phone 4S to IOS6 last night.  Just keeps asking for the password.  Does anyone no if a firmware update would work for this router?  Next time will not jump so quick to upgrade.

  • xans.poppa Level 1 (0 points)

    just wanted to also confirm that AFTER reverting my netgear wgt624v3 router to the older 2.0.21 firmware, BOTH my ipad3 and iphone4s now have wifi connectivity at home...


    thanks SP Cooper and NaplesDave!!!

  • PeterTranter Level 1 (0 points)

    Thanks, same router same problem.

    iPad feels alive again! Thought I was going mad. Thanks for the find guys.

  • Old School 93 Level 1 (0 points)

    Rolling back the firmware on my Netgear wgt624v3 also worked like a charm.  Took a total of three minutes.  Thanks guys!

  • Skronk61 Level 1 (0 points)

    Can't believe getting older netgear firmware actually worked... I factory reset my ipad for nothing. well time to redownload a lot of comics


    Thanks for the help guys

  • AstroAndy Level 1 (0 points)

    I can also confirm that this fixed my issue as well.


    I have an iPhone 4s and was unable to join networks on two different Netgear access points. I had to downgrade the firmware on both the Netgear ProSafe WAG102 from v2.0.15 to v2.0.12, and the Netgear ProSafe WG102 from v5.0.3 to v5.0.1. Doing this enabled me to join the networks on both access points.


    Serves us right for using the bleeding edge



  • Oscar Mata Level 1 (0 points)



    I'm experiencing a weird problem with my iPhone 4S Wifi, I upgraded to iOS 6 at my office, Wifi worked fine there, but I experienced an issue at my home Wifi, my device connect without problems to the Network, (WPA2 PSK), my router is a Mikrotik hd701, so even connected to my home wifi network I was unable to browse the web or use Internet. Then my brother's iPhone 4, was upgraded to iOS 6 too, and he got exactly the same issue, no Internet, even when he is able to connect to our home Wifi network. Before do the upgrade, our devices were able to connect to Internet without issues with our Mikrotik router.


    So I will try some fixes that I just seen here and post again later. Best regards,



  • S. P. Cooper Level 1 (5 points)



    You have a different issue than that specified in this thread.


    This thread is for users who are completely unable to connect to their Wi-Fi networks due to an incompatibility between iOS6 on iPad3/iPhone4s/New iPods and a selection of particular routers.


    Because you can connect to your Wi-Fi network--even though you do not have access to the internet--the fixes here are not appropriate to your problem. You should search the discussion threads for people who are having problems accessing the internet after being able to connect to their routers, or contact Apple support.


    Sorry, and good luck!

  • zmSP94 Level 1 (0 points)

    I just want to give my observation based on similar problem of unable to connect.


    I have Netgear WNDR3700. Works great before. Set to WPA2 Personal (which i don't know why iOS won't show that but i guess they just dumm it down) and SSID hidden. I really don't want to downgrade the firmware since the fix below worked.


    So. computer, iphone, and other internet devices have no problem. same with Ipad2 on 5.1.1.  Apple mess up something so it won't connect even after network reset and input the password.


    What worked for me (I tried a lot of things) was turn the SSID to broadcast, connect to it, enter the password, and voila.  Not sure how many of you have SSID broadcast turned off. 

  • 12121211111 Level 1 (0 points)

    I can confirm that downgradeing the firmware on the Netgear ProSafe WAG102 from v2.0.16 to v2.0.12 works like a charm.

  • crewhughes Level 1 (0 points)

    How about TP-Link routers?  I have the same issue but I am not on a Netgear router but a TP-Link version.  I am also in China and losing my network so I can't skype/facetime with my family in the US has me really upset.


    Appreciate any feedback on TP-Link options to get reconnected to my network.  My Touch still works on the network but of course its an old one with no camera and its an older ios level.

  • wudstak Level 1 (0 points)



    iphone 4s, ipad3 with Netgear WGT624v3 is not connecting to the Wifi.


    We have  tried all possible combinations to fix this to no avail.

  • S. P. Cooper Level 1 (5 points)



    It seems you had a different issue. My WGT624v3 was set to broadcast, and changing it to off or on made no difference. (Incidentally, Apple now suggests that people use broadcast for SSID with all of their devices, probably for this exact reason.)






    Apple's engineers are aware of the issue and a fix is in the works. In the meantime, revert your WGT624v3 driver firmware to 2.0.21 and that should take care of the problem for now. This workaround isn't ideal, but it will make it easier to wait for the update.

  • bessman Level 1 (0 points)

    I can happily say that after looking for a solution for 48 hours now and going absolutely INSANE - I finally downgraded the firmware and was able to log in right away.

    Thanks guys!!

Previous 1 3 4 5 6 7 Next