Previous 1 2 3 Next 37 Replies Latest reply: May 11, 2013 3:04 PM by Jetmek.007
egemendemirel Level 1 (0 points)

Hey there,
I know some of people facing Wi-Fi connection problems after iOS 6 update.
There are a lot of threads and solutions about this problem. But mine is bit different.

I have an iPad and after i update to iOS 6 there wasn't any issue about Wi-Fi connection.
I surfed all day long , upload and download many thing using my home Wi-Fi network.


Today I couldn't connect to my campus' Wi-Fi network. I turned on my phone's hotspot

and iPad connected to my phone's cellular based network just fine. I tried to connect directly with my phone to campus' network and my phone also connected just fine. When i searched the web i saw a lot of Wi-Fi issue thread about iOS 6. I have read all of them but my problem is bit different.

My campus' network is using a Captive Portal thing to get internet access. So you have to enter your user id and password after you connect wirelessly.

When i was using iOS 5.1.1 iPad was connecting to network automatically and waiting for me to open safari or chrome and enter my id and password.

But now after i joined to network a window pops up and and wants me to enter id and password (not an apple page, my own university page) and at the same time connection drops and wi-fi icon get lost so my log-in info can't send. I open and wi-fi panel and connect again and same thing occurs. Pop-up window and connection lost. This is a vicious cycle i think and everybody using iOS 6 in my campus facing same problem. iPhone iPad iPod Touch users can not connect because of this problem.


I have done everything that written about common Wi-Fi issue.


I am sorry about my broken English BTW.

Waiting for your help.

iPad, iOS 6, 16GB Wi-Fi Only
  • clemon85 Level 1 (5 points)

    I am having similar issues.  I started a thread about it earlier this morning, no solutions yet, but:


  • bighercman Level 1 (5 points)

    I run an IT department for a college that utilizes a captive portal.  It seems that the issue is with the iOS6 update.  We require everyone to authenticate via our captive portal to use anything other than e-mail.  We allow e-mail to pass without authentication.  This is already causing A LOT of problems for me as i have half of our 2000 wi-fi user base using iDevices.  With any other iOS version my users could connect to our network and receive e-mail without authentication.  Something needs to be done about waiting for Apple to call me.

  • bighercman Level 1 (5 points)

    1 hour later with support to a senior advisor for iOS no solution.  All they told me was to look at enterprise deployment guides. The person was not IT knowledgeable and was consistently putting me on hold to "check with a coworker on the issue". Doubt this will get fixed any time soon. Looks like businesses with Captive portal pages are going to have nothing but issues until Apple gets knowledgeable staff to adress this issue....

  • @bagjaap Level 1 (0 points)

    Yo Everybody


    I managed to fix this issue few minutes ago. There a few steps to maintain it.


    1. Settings>>Safari>>"Clear History" also "Clear Cookies and Data"


    2. Turn Your Cellular Data Off

         Settings>>General>>Cellular>>Cellular Data (OFF)

                                                   >>Enable 3G (OFF)

    3. To Maintain your Wifi

         Settings>>Wi-Fi>>(Your Network Name)>>HTTP Proxy(Auto) + Leave URL empty



    I hope that might help you folks!

    ps. if you haven't managed to find your network, after step one you might wanna restart your network settings

  • TKJ64 Level 1 (0 points)

    Extremely irritated with the wifi issues that have occurred because of ios6. Rep had me do a restore through iTunes, nothing changed. I want to go back or throw this in the garbage. Fed completely up at this point! 

  • LGV92 Level 1 (0 points)

    I'm currently studying overseas in Beijing and I'm having the same problem. Several students here updated their iPads and can no longer access the Internet at our school's campus. The "Auto Login" toggle switch has been removed, so when we select our network, it defaults to Apple's pop-up page rather than allowing us the option to log in using Safari.


    This issue isn't getting half the attention that the website bug had, and that's incredibly frustrating. This needs a quick fix. 

  • egemendemirel Level 1 (0 points)

    I returned to iOS 5.1.1

  • mpa9366 Level 1 (0 points)

    Looks like the same problem and I'm overseas also, dont have access to the "campus" routers and cant use any of the router reset or changes suggested solutions. Network login page has been 'hijacked' by the apple no connection message.


    Totally p###d off - does Apple have any idea how useless a tablet device is without connectivity and how much we rely on them for study, work and maintaining communication with family and friends?


    4 days of no connectivity and no statement from Apple is too long.

  • PabloSanz Level 1 (0 points)

    This works for me:


         1) install Google Chrome

         2) login with Chrome in the captive portal

         3) done! (now you can switch to Safari or continue with Chrome)

  • egemendemirel Level 1 (0 points)

    Pablo thank you for reply,

    But the problem is connection not safari.

    When i connected to network suddenly a pop-up window of safari appears and connection drops at the same time. I can not choose anything, just happens.

    So if i open chrome, there won't be a connection so my log-in information cannot be sent.

    I returned to iOS 5.1.1 so i can't try this solution. I'll ask my friend to try.


  • ro0ri Level 1 (0 points)

    hi egemendemirel! how did you returned to ios 5.1.1?? I tried  and couldn't return.

    I'm tired of ios6. I want my 5.1.1 back!

    please tell me how to do this.

    i have an ipad2.


  • bighercman Level 1 (5 points)

    @bagjaap - This solution will not work for an enterprise environment where you have 2000+ users like i do. I refuse to go around to everyone's ipad or iphone and make these changes and show them how or to push out a configuration profile to all of them.  This shows how careless Apple is of the business world when developing their products.  They need to revert this "pop-up" page change that they made in iOS6 back to how it functioned in iOS 5.1.1 & earlier.  Absolutely terrible work by them!

  • Beatsbyair Level 1 (0 points)

    I upgraded my 4s to iOS 6 and have "spotty" wifi availability within every app on my phone.  For instance, iTunes basically came to a hault.  Can't preview songs, can't download songs or podcasts.  When browsing the internet with Safari, I randomy get locked up or slowed to a crawl.  I've tried every fix on the internet and none of them have worked.  I never had the auto proxy issue either.  3G data seems to be working fine.  But it really ***** not to have my iPhone working as it should be when I'm bored at work!  LOL


    Really hope this is addressed soon.  Don't wanna go back to 5.1.1.  It's officially a week now since I upgraded and still no word from the big A.

  • Shanon.Roberts Level 1 (5 points)

    If you experiencing the above subject heading, please read below


    Go to Settings, General, About

    Scroll down till you see Modem Firmware

    Reply Back with your Modem Firmware

    Modem Firmware: 04.12.02


    Wireless Access Point Device: NetGear WG102 which is superceded by NetGear WG103.

    I have Firmware 5.0 for this device


    Also check your IOS Version and (BUILD)


    If your Modem Firmware is LESS than the above, then you have the same problem as myself and many others with Wireless Connectivity issues to WAP's


    It is my understanding, unless im proven wrong by anyone with my above findings, this can only be fixed by APPLE. I have reported this as a BUG


    Please REPLY only to this thread if you're criteria is less than the MODEM FIRMWARE listed


    Im checking to see if i can be proven wrong in my findings.


    I have performed the below

    Backup Phone

    Factory Reset

    Network Reset

    Hard Reset

    Soft Reset


    Apply Store in Australia, Sydney CBD George St have tried the above with meand cant help either.

    Apple support via the phone cant help. This problem has now been logged as a BUG for the time being.

Previous 1 2 3 Next