Previous 1 2 3 4 Next 58 Replies Latest reply: Oct 5, 2015 9:20 AM by igloo8
Fredo Viola Level 1 (30 points)

Hi there folks,

I just bought a brand new computer. I went from using Logic Pro on a 2009 MacBook Pro with 8 gb of memory to a 2.44 ghz 12-core Mac Pro with 24 gb of memory. I just started working on a song that was stalling quite often with Logic on the old computer and 1) find it still stalls! and 2) often during playback it suddenly becomes unresponsive to the stop button (either moused on the screen or hit with the space bar) and just keeps playing. What should I do? Is this a known problem?

At first I thought it might be the Abbey Road plugins, which do not work well in 10.7 or 10.8 (I'm running 10.8.1 btw). But after removing all instances from this song and deleting the files from the computer Logic is still misbehaving badly.

The only other plugins I have loaded up on this computer are Valhalla room, Valhalla Shimmer (which I'm not using in this song), Kontakt (which I'm not using with this song), Trillian and Waves CLA-2a/3a/76.

If anyone can help I'd be eternally grateful. This is so wildly frustrating!  I figured after shelling out this much money and taking 2 solid weeks to very carefully set up the computer it would be smooth sailing. 

  • bgbussey Level 1 (0 points)

    Hey Fredo,


    I'm having the same problem!!!


    I upgraded to Mountain Lion 10.8.2 yesterday and Logic Pro suddenly has gone unresponsive when trying to switch between Arrange View and a Plug-in View while in Loop mode. Eventually, after several seconds delay, the interactivity actions catchup - for example hitting the stop button.


    I've called Apple Support regarding this issue and according to them, it's hardware issue. Unforenately, I've gone through the process of disconnecting all my USB & Fireware keys, audio interfaces, etc. and restarted the system. The problem still exists!!


    Apple Support then suggested to reinstall Logic Pro from the App Store, I did. Still having the same problem!!


    Please let me know if you have any ideas what's going on! Very Frustrated - Brent

  • Fredo Viola Level 1 (30 points)

    Yep, that's exactly the same problem I am having.  Actually, I was trying to edit the Channel EQ live and that's when it became completely unresponsive.  And for me it lasted a lot longer than a couple seconds.  Actually it was minutes. 


    I have some questions for you and I think perhaps if we compare and contrast answers we might be able to figure things out a bit better.


    1) what Analog Digital Convertor are you using?  I'm using an Apogee Ensemble.


    2) are you using Logic Pro 64 bit, or 32 bit?  I'm using Logic Pro 64 bit


    3) do you have any plugins that use the 32 bit bridge?  The only plugin I had that used that was the Abbey Road plugin.  The only way I was able to force quite the playback at one point was to force quite 32 bit bridge.  It stopped Logic in it's tracks.  Of course, that doesn't really mean it's necessarily the problem, but I've been working on the same song now, having restarted Logic twice after deleting Abbey Road and so far so good.


    Let's see if we can figure this out, Brent. 

  • bgbussey Level 1 (0 points)

    Ok, just got off the phone again with Apple Supoort. Apparently, they are pushing it up through the support chain. Should be receiving a call from one of the level IV support agents within 48 hours!!


    In the mean time - let's do our best to soleve this issue.


    1) I'm using a MOTU 828MKII for my audio conversion.


    2) I'm using 64bit. But, I switched to 32bit when troubleshooting this issue. It didn't fix it!


    3) Yes, Sylenth1 uses the bridge. But, it shouldn't matter when in 32bit mode.


    Honestly, I think it's a Mountain Lion issue. As a software developer, my best guess is there's is an issue with the Window Controller Class. It appears to want to maintain "state" over the main application window. If this sounds greek to you - I'm sorry! I've gone through other applications in Mac OSX, and haven't come a cross another one that allows that type functionality. I could be wrong, but that's my best guess for right now.


    Like I said before, I'm running bare bones right now in order to troubleshoot this issue. I have no external devices plugged in. Not not mention, I created a new user thinking it might have something to do with my profile - didn't work!!


    Let me know if you have any ideas - Cheers, Brent

  • Fredo Viola Level 1 (30 points)

    Can't say I completely understand, but I definitely catch your drift and it makes sense.  VERY VERY FRUSTRATING!!! 


    OK, so we know then that it's not the AtoD.


    That said, since quitting the 32-bit bridge I haven't had any of that behavior. That doesn't explain why you are still having the issue in 32-bit mode.



  • Pancenter Level 6 (9,330 points)

    Actually there's been several threads on this very subject over the past three months... some of the threads are huge with many users weighing in.


    These are still on the main page-



  • sabin333 Level 1 (0 points)


  • Fredo Viola Level 1 (30 points)

    Any news, Brent?  For a while I thought quitting any 32-bit bridge plugins fixed it but it didn't.  It just made spaz-duration a little shorter. Maybe.  Looking over those discussions, Apple should really be ashamed of themselves.  Yet another indication of their poor attitude toward their professional users. 

  • sabin333 Level 1 (0 points)

    Have any of you called Apple yet?  I think that the more people that register this complaint with the pro audio department, the faster we'll get a fix for this.

  • Fredo Viola Level 1 (30 points)

    As you read above, Brent has.  And I'm calling a Pro Tech contact I have in 30 minutes.  Let's all just keep the pressure on and keep in communication with eachother.  If this is not completely fixed in 30 days I'm changing my DAW.  Very sad for me, I've been a Logic Pro user since 2000.  All my work is on this app.  It would be an extremely painful process which hopefully won't have to happen.  But this problem is a really big one that just can't be tolerated.

  • Fredo Viola Level 1 (30 points)

    Just an update, I had a long conversation with a fellow in level one professional app support.  Unfortunately he wants me to remove all third party plugins and start with a brand new project before upgrading this to hgiher level support.  I sent him to this thread and the many others where people have already done all of these test but apparently it's a necessity.  He was very nice and courteous, and no doubt is just following the rules, but in my opinion this is a very annoying waste of time.

  • Fredo Viola Level 1 (30 points)

    OK, one more update:


    I did what was suggested and removed all the AU components from the Audio folder (within the main Library) and Logic was playing perfectly.  Played around for 5 minutes trying to make the lag happen.   Then one after the other I began to add all the components back into the folder.  It wasn't until Kontakt was included that I had my first LOW MEMORY stall during playback, and it happened pretty much right away.  Playing around for about 20 minutes and I had another little moment of that laggy behavior, but just a really quick one. 

  • Fredo Viola Level 1 (30 points)

    OK, I seem to have figured out the problem. It's not 3rd party plugins at all.  Actually, I called Native Instruments about that memory issue and apparently I had Kontakt setup incorrectly. But the lag continued today, really badly, and I was able to get to the bottom of it.


    The problem occurred when I had an instance of Channel eq open with the Analyzer engaged.  It would play find until I opened another instance of Channel eq with Analyzer engaged during playback.  It then lagged for about 15 seconds (frrrrustrating!). 


    When it finally stopped I turned off Analyzer and tried the exact same thing again.  NO PROBLEMO!


    I tried to record this using quicktime screen record but apparently it was just as bad as having EQ Analyzer engaged.  This time the lag lasted for almost a whole minute (even more frrrrrusstrating!!!!!)


    After it stopped, I quick quicktime, tried the test again with Analyzer turned off again, and once more:  NO PROBLEMO.  So I think what Brent said about Window Class is probably true.  If you open multiple windows that are pulling data live and showing them visually this problem occurs. 



  • sabin333 Level 1 (0 points)

    Hi Fredo.  I'm sure that you're already going to do this, but please follow through and call Apple to tell them what you saw after the 3rd party plugins were removed.

  • Fredo Viola Level 1 (30 points)

    I have had 3 calls already, the third occurring just now.  They're very nice about it and have told me they would focus on figuring it out.  I have a problem with blaming 3rd party software though.  As users we shouldn't be expected to work without an additional plugin, instrument or two.  Actually, I tried the test without the third party stuff as well as with and the lag issue occurred in both states equally. 

Previous 1 2 3 4 Next