Skip navigation

iPhone 5 wifi issues

1444035 Views 4,653 Replies Latest reply: Apr 5, 2014 1:09 PM by intuitionist RSS Branched to a new discussion.
  • Paul Roberts7 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 1, 2012 2:12 PM (in response to Jtnorr)

    That makes no sense to me.  If all my other devices connect just fine to something that was built on standards why would the firmware be "outdated"?  All those other devices are compatible or backward compatible.  They all connect fine.  Then the iPhone5 comes along and suddenly something was implemented wrong in the old firmware that only Apple did correctly in the new phone so eveyone must update?  Not saying it doesn't work on a different/new AP.  However, it sounds more like Apple trying to either (1) find a quick way to close the ticket (2) trying to sell more hardware.  The iPhone claims it can connect to these industry standard APs and I doubt the other manufacturers have been implementing the standards wrong all this time.

  • Phil Ossifer Calculating status...
    Currently Being Moderated
    Oct 1, 2012 2:25 PM (in response to Paul Roberts7)

    Based on the WIFI specifications there are some very specific WIFI settings that one would expect would work out of the box, but maybe not.

     

     

    My guess is that the phone is trying to do something advanced that your router does not support in the current configuration.

     

    That's simply a pie in the sky guess if there's no other problem with the software or hardware. It actually could just be incompatible.

     

    That means having some way of turning off those features on the phone, or causing it renogotiate the connection, (for example my router does not do dual N connections at the same time) plus there are some settings on the report that I have never bothered tweaking and they are specifically mentioned which may turn out to be the culprit.

     

    I can understand why people don't want to touch their router, if you don't feel comfortable doing so, don't bother.

  • andrewket Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 2:46 PM (in response to Phil Ossifer)

    I had the WPA2 issue on two iPhone 5's with Apple Airport Extremes (the latest edition). So if the argument is that Apple is following a standard and the router manufactuerers are not, then Apple is guilty of not following the standard on their own access points.

     

    What is most confusing to me is that after a hardware swap I still had the WPA2 problem - at least initially. The problem has gone away, and the only thing I did was to configure the wireless network manually on my phone. Specifically, rather than select the network from the list of wireless networks, I selected other and entered the SSID manually. Since then it's been working just fine at home and at work.

  • Paul Roberts7 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 1, 2012 2:41 PM (in response to Paul Roberts7)

    Unbelivable.  According to Apple just now since my phone connects to public WiFi "perfectly" there is no problem with my phone and the issue is isolated to my network.

     

    Apparently my Netgear Prosafe AP may have a limit of how may devices can connect to it...  (according to the tech).

     

    The solution from Apple is that I need to call my router company.  Despite the fact that all other Apple products, Blu-Ray, Asus, Toshiba, etc. can connect perfectly.

     

    What a load of Apple b#$%#$it.

     

    I can't believe I wasted my time calling in to the Apple "Geniuses".

  • Eric Maier Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 1, 2012 3:18 PM (in response to Paul Roberts7)

    Hi Paul, I think we are having the same issue. No amount of router fiddling (other than leaving the wifi open) will maintain internet connectivity more than a couple of minutes.

     

    So, I just got back from the Apple store. The Genius was actually very sympathetic and nice. The only router fiddling she suggested, which makes sense, is to make sure you don't have mac id filtering on. I don't, and I'm not sure why it would connect even for the 2 minutes that it does if I had mac id filtering on. But a good suggestion for troubleshooting.

     

    I have 3 iPads (2 running OS 6), and 2 iPhone 4's running OS6, and 1 iPhone 4S on OS5 here, all with zero connectivity problems. I have 3 Airport WAPs and 1 Asus R56U (latest firmware on all) which the phone won't connect to. Also, it doesn't work at the office, which is a dealbreaker.

     

    So she took the phone into the back, reloaded firmware & software. Then we set it up as new. She said take it home, try it out, and bring it back for a replacement if this didn't work.

     

    Well it still doesn't work, so I've made an appt for tomorrow (rest of today was totally booked up by 2 pm today). She said she made notes on my account, so I'm hoping the replacement will be hassle free. If not, I'll just return it.

     

    And actually, even before I left the store, the browser seemed kind of sluggish on their open network. At home, for the blissful 2 minutes of connectivity I can get after a network settings reset, pages load blazingly fast, even complicated sites like Engadget.

  • Patsywright Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 3:20 PM (in response to Paul Roberts7)

    This is all B.S I have tried everything and this phone will not hold wifi. I have iPad 2 that's updated to ios6 and works just fine You go 5 feet away from router with the iPhone 5and  it stop working.Going to Apple Store tomorrow. I want a new phone this is bull we all paid good money for a phone that will not work.

  • Eric Maier Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 1, 2012 3:27 PM (in response to Patsywright)

    Yes it's bull. As long as you're in the replacement period use that threat. If you return it and buy a Samsung they lose a customer. If they replace it and it works, they keep you.

     

    I was willing to try the in-store reset she did (which she said is deeper than we can do on our own) because I was curious to see if it would work. Another poster on here did the same thing, with the same result: still didn't work, so my hopes weren't too high. So make that at least 2 of us that have tried that.

     

    Tomorrow it's new phone or return. And if new phone doesn't work, it's return that one and start looking for alternatives.

  • kanepresten Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 3:32 PM (in response to tobifs)

    I just got off the phone with my applecare followup. I had called them last week to notify them of this issue, and they stated that it looked like engineering was working on the problem of  wpa2-aes encryption. They agreed to call me back to let me know of any findings.

     

    The follow-up call was not as productive as I had hoped.

     

    The senior applecare employee did not seem aware of this issue at all, and did not seem to have any new data readily available. He decided to put in a specific request with engineering. He plans on calling me back on Thursday or Friday with any results he gets from engineering.

     

    Again, friends, if you are experiencing this issue with WPA2-AES Encryption, PLEASE call AppleCare to make sure as many members of their support team are aware of the issue and can facilitate a swift resolution to this problem.

  • boosteddub69 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 3:38 PM (in response to kanepresten)

    People have been calling AppleCare constantly. They know about the problem, they play ignorant as its the corporate mantra with problems.

     

    Not a good way to treat customers.

  • Eric Maier Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 1, 2012 3:38 PM (in response to kanepresten)

    Just be sure not to let them string you along past the return period. You'll lose your leverage after that. If bought direct from Apple it's 30 days. Thru a carrier it may be much shorter.

  • PatrickL Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 1, 2012 3:41 PM (in response to tobifs)

    I have been stung by the electronic device nocebo effect. Thus, I too have this same issue.

  • Meekinit Calculating status...
    Currently Being Moderated
    Oct 1, 2012 3:41 PM (in response to Eric Maier)

    I was able to fix this issue (as of now at least), though without much help from Apple.  I was experiencing the same issues with my D-Link DIR-625 router with WPA2 security.  Prior to getting the Iphone 5, my HTC EVO 4G, my desktop, my PS3, and my girlfriend's iPhone 4S all worked without issue on my router.  Along came the iPhone 5 and my issues began.  Sometimes it would connect and transmit data, though only for around five minutes tops.  Other times it would not connect at all.  Other times it would connect and then crash my entire network, downing all my other connections to the router as well.  After reviewing this thread and many other topics regarding the same issues online, and attempting nearly everything (aside from disabling my security), I called AppleCare.  The support tech on the phone asked me to do all the things I'd already done; reset the router, reset my phone's network settings, check to ensure I had the latest router firmware, etc.  After telling her I'd done all of that already without success, and informing her it seemed to be a larger issue based upon all of the people who were having the same issue, she placed me on hold to speak with a supervisor.  After returning, she advised me to go somewhere else (McDonald's was her suggestion) and attempt to use their Wifi.  She stated if that did not work then to call back.  Needless to say, I didn't feel as though I was actually getting a resolution, as I didn't care if my phone worked somewhere with an open Wifi connection, I needed it to work at home.  I then went to Wal-Mart and bought a Belkin N600 dual-band router, set it up, and put all of my devices aside from the iPhone 5 on the 2.4 GHz band.  I put the iPhone 5 on the 5 GHz band, and my issues have been resolved as of now.  I am still unhappy in having to shell out $70 for what I believe is a software/Apple issue, but I don't have the time to sit around and wait for Apple to acknowledge what is apparently an issue on their end.  Hopefully they will acknowledge this issue soon...

  • Eric Maier Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 1, 2012 3:48 PM (in response to Meekinit)

    LOL "just go to MacDonald's" - that tops "You're not holding it right" by a mile!

  • BigZ12 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 4:04 PM (in response to tobifs)

    I can now PROVE that the problem is related to AES encryption.

    Have tested with two routers. A brand new and expensive ASUS RT-AC66U and a cheap DLINK DIR-615.

    I tried with all types of WPA settings, and this is the results:

     

    Works flawlessly with:

    AUTO (WPA or WPA2) - TKIP

    WPA only - TKIP

    WPA2 only - TKIP

     

    The iPhone connects to the network, but stops working after a couple of seconds with:

    AUTO (WPA or WPA2) - AES

    WPA only - AES

    WPA only - AES

    AUTO (WPA or WPA2) - TKIP and AES

    WPA only - TKIP and AES

    WPA only - TKIP and AES

     

    100% sure that I'm right about this, and now just curious if this is software- or hardware related.

  • RJB4 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 3:58 PM (in response to Meekinit)

    I also have tried just about everything suggested and finally have it working (for now). No thanks to Apple who is treating us like idiots and pretending they have super technology and it must be 3rd party router issues. I basically had to change my router settings. I was using WPA-PSK (TKIP) + WPA PSK (AES). I changed it to WPA PSK and manually entered my wifi connection. For the first time since I owned it my Iphone 5 is working on my home wifi and not dropping off.  Still not acceptable but at least I'm not chewing through data at home now. I've told everyone I know not to purchase the iPhone 5 until Apple fixes this. Of course they first will have to admit they have a problem:/. I also have iPod 4th generation, iPhone 4, iPhone 4S, iPad 2, the New iPad (phones and ipads all updated to ios6) and all have and do work fine with my router. iPhone 5 is when all the issues began.

1 ... 67 68 69 70 71 ... 311 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (127)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.