Previous 1 3 4 5 6 7 Next 168 Replies Latest reply: Nov 21, 2015 12:48 PM by victorian08 Go to original post
  • pjbmil Level 1 (0 points)

    it seems to be the same  symptom (slow shutdown) but with different causes (and solutions).

    In my case the problem was generated by appleeventsd (Exit timeout elapsed 20 sec.)


    My workaround is:

    as root edit /System/Library/LaunchDaemons/


    add two lines at the end (before </dict>)
























    do not use 0, zero is interpreted as infinity

    Save and reboot.


    It’s  just  a workaround but now my shutdown is fine

  • Scott Newman Level 2 (220 points)

    I've contributed to several items in this thread and I've tried every fix mentioned above.  I tried the most recent one from pjbmil and wasn't expecting it to work because none of the other ones did on a permanent basis.  But so far it works GREAT!!  Thanks so much.  I tend not to edit anything inside the System folder; however, this appears to be harmless and, IT WORKS for me.

  • firesidefromellenville Level 1 (10 points)

    I think I would refute that harmless remark  I swear I did exactly what pjbmil said to do, and it did shut down very quickly.  However when I restarted my computer I found I couldn't get get Finder to work from the dock, and I couldn't get into Trash to get out the old system file.  I couldn't really see how to fix this at all, I did try and take that file off my iMac and got it onto my MacBookPro but after a reboot I still couldn't get Finder to work from the dock.  I saved my ML installation file so it didn't take too long to reinstall a copy over the current one, then about the same time again to up update to 10.8.2 again.  I am glad that the fix worked for those who it did work for, and am not blaming anyone, we are all adults here and it was probably my mistake in the first place. 

  • bogdanfromploiesti Level 1 (0 points)

    I tried to change the file "appleevents.plist" but no way. This fie is locked to any changes into "LaunchDaemons" folder. help please thanks

  • firesidefromellenville Level 1 (10 points)

    I wouldn't put any credence in anything from me about the modification of that file.  It opened up OK in TextEdit and after I put those two lines in it I was told I would have to save it as a copy, which I did.  I then changed the extension to .plist and then deleted the original file and put in the new one.  Obviously this ISN"T the way to go.  However...... after my reinstallation of the OS, wasn't even a clean install, my shut down time is back to normal again, at least in the 3 reboots I have done so far.

  • Scott Newman Level 2 (220 points)

    The file in question is a system file with related permissions.  Once you put a copy of that file on your desktop, it no longer has the correct permissions.  It then has permissions the same as all of your user files.  If you make the changes to the copy and replace the original file with your new file (inside System/Library/LaunchDaemons), it will still have the incorrect permissions.  At that point you need to repair permissions using Disk Utility.  When you look at the repairs made by Disk Utility you will that file's permissions have been repaired.


    I've got a zipped copy of the original file in case I need to go back.  I also keep multiple bootable backups.


    I'm not saying that anyone should do this.  In fact, you probably shouldn't.  It worked for me so I'm making the same change on my second Mac.  YMMV.

  • Scott Newman Level 2 (220 points)

    I just made the change on my second Mac and here's the related output from Disk Utility when I repaired permissions:


    User differs on “System/Library/LaunchDaemons/”; should be 0; user is 501.

    Group differs on “System/Library/LaunchDaemons/”; should be 0; group is 501.

    Repaired “System/Library/LaunchDaemons/”


  • pjbmil Level 1 (0 points)

    Just to clarify:

    Before sharing this solution I tested it for 2 days with two defferent Macs and no problems arose.

    I changed the timeout exit from 20 to 1 sec (time before a SIGKILL signal is sent to appleeventsd).

    You must be ROOT to change, I did it opening a teminal session and using VIM as editor.

    Be careful with permission: wrong permissions on that file "FINDER" WILL STOP TO WORK. (as firesidefromellenville reported and tested it by me)

    Use Disk Utility (as Scott suggested) or from terminal as root "chown root:wheel"

    If you use from a terminal session Vim or another editor there is no need to change permissions.

    -rw-r--r--  1 root wheel  655 11 Ott 15:37


    It is not the solution, it's just a workaround.

  • firesidefromellenville Level 1 (10 points)

    Just to prove to myself I still have a pair..... I re-modified that file and then repaired my permissions, rebooted 2 times and fingers cross my shut down is normal again.  It does seem a lot of messing around for 18 seconds, but it does sort of get to you in the

  • Cool711 Level 1 (0 points)

    Worked for me.


    Changed the file using TextWrangler.


    Repaired permissions and shutdown times back to normal.


    Seems like every update they break a key feature I've come to rely on.

  • 1aut3 Level 1 (0 points)

    That did the trick for me too. Thank you so much!



  • Ray Demel Level 1 (0 points)

    Tried your fix and that fixed part of the issue-it shuts down faster - but - It still seems to hang up while trying to kill apple.launchd



  • schnaufifant Level 1 (10 points)

    Doesn´t work for me.
    After some Restarts the System is still "hanging" for 15 Seconds.

  • razmarin Level 1 (0 points)

    because not only appleeventsd hangin on shutdown.. you can see what is your culprit by opening console after reboot and check shutdown.log

    Снимок экрана 2012-11-15 в 18.17.53.png

  • Don Barron Level 1 (90 points)

    This is a plague.


    I've tried a lot of things to work around this, but so far, they've all been temporary fixes.


    Note to Apple: cough up some of those billions and actually fix this problem!


    It is real, and a "clean install" (which is the typical extent of your "tech support" advice won't fix it.

Previous 1 3 4 5 6 7 Next