Previous 1 2 3 Next 65 Replies Latest reply: Jan 31, 2016 7:48 PM by Dave SF
ronenishai Level 1 (0 points)

I get a picture but no audio.

I saw this discussion:

No Audio when Airplay Mirroring from Mac to Apple TV

 

BUT in my case I can't change the sound settings to AirPlay.

When I click it with the cursor, it tosses me back to Internal Speakers, and won't let me select AirPlay.

 

Any suggestions?Screen Shot 2012-09-26 at 12.52.34 AM.png


iMac (27-inch Mid 2011), Mac OS X (10.7.4)
  • Warrior Scribe Level 1 (0 points)

    Add me to this complaint. Just tried to Mirror from my 2012 Macbook Air.

     

    When I'm already in Mirroring mode and click Apple TV for audio it takes me out of mirroring.

     

    When I try to choose the audio before I do into Mirroring mode it tosses me back to the internal speakers.

     

    I have been unable to direct audio to my TV -- it just plays out of my computer speaker even though the video is on the TV.

  • driver49 Level 1 (0 points)

    I'm in the same boat.

     

    Found an instruction elsewhere to flip audio to AppleTV BEFORE switching to Airplay Mirroring.  Should not be necessary (several extra clicks where one should suffice), but if that's what I have to do, OK...

     

    But as these users are reporting... it doesn't work.  I click on the AppleTV option and it keeps reverting to Internal Speakers.  I'm not able to actuall select the AppleTV for audio output.

     

    So, ***?

     

    --P

  • jeffreyfromandover Level 1 (0 points)

    Same response as users above..video works with AirPlay, when try to select Apple TV, kicks back to Internal Speakers. Unable to select Apple TV for speaker output.

     

     

    Jeff

  • mamajag Level 1 (0 points)

    Add me to the list.  I cannot get my Apple TV to select as my sound output on my 2012 MBP.  I upgraded to have Airplay, so this is a disappointment to say the least.

  • ronenishai Level 1 (0 points)

    I don't get it... Is this "Apple Support Communities"?

    Look how many people have reported the same problem (not to mention many others who probably didn't report but have the same problem)

    How about a little comment from the crew? How about providing the basic service for those who paid their best money to purchase your products? How about SUPPORTING?

  • dgoedhard Level 1 (0 points)

    simple fix I found

     

    completely shut down and restart your mac ...turn on your apple tv and then begin mirroring before you play your movie or music.

     

    I've had to reboot my laptop on other occations and it usually fixes whatever seems to be the problem

     

    worked for me hope it helps

     

    cheers,

     

    danny

  • couchfries Level 1 (5 points)

    I have had the same problem. For a while now, I just restarted my mac and that fixed it. But finally I found a workaround. Try running this from the terminal : sudo killall coreaudiod

  • haylsjmc Level 1 (0 points)

    I have exactly the same problem on my 2012 Macbook pro retina 15". the reboot works but is there really no fix? maybe an update is needed??

  • dgoedhard Level 1 (0 points)

    I've been using vlc a lot for streaming avi's as quicktime codecs have been hard to find. If I loose audio ...I've noticed even shutting down the program and restarting it works too. Its a pain in the butt and I'm hoping its just a glitch that they'll iron out in the next update!

     

    here's to hoping!

  • PetWolverine Level 1 (0 points)

    couchfries wrote:

     

    I have had the same problem. For a while now, I just restarted my mac and that fixed it. But finally I found a workaround. Try running this from the terminal : sudo killall coreaudiod

     

    I was having the same problem and this worked for me. Thanks for the fix!

  • Toki Level 1 (0 points)

    I had this too, but restarting the Apple TV worked to resolve.  Didn't have to walk upstairs to the computer.  :-)

     

    Oh and Discussions isn't a avenue for getting support from Apple.  It's just a forum for users.  Granted, moderators may sometime jump in, but that's the exception.  If you really want direct support, call AppleCare.

  • Dave Mao Level 1 (0 points)

    couchfries wrote:

     

    I have had the same problem. For a while now, I just restarted my mac and that fixed it. But finally I found a workaround. Try running this from the terminal : sudo killall coreaudiod

     

     

    +1 worked for me.

  • SHOMAS Level 1 (0 points)

    Seems like it's the way to go. Worked for me. Thanks.

  • mynameisearl Level 1 (5 points)

    Hi - I had this also - "sudo killall coreaudiod" from terminal worked for me - THANKS! Has been annoying me for ages!!

Previous 1 2 3 Next