Previous 1 2 3 4 Next 56 Replies Latest reply: Jan 4, 2015 1:00 PM by exuberantmonkey Go to original post
  • Eric Root Level 7 Level 7 (24,635 points)

    Why doesn't everyone submit feedback to Apple:

     

    Feedback

  • m_Three Level 1 Level 1 (0 points)

    Hello All.

     

    I too am experiencing the problem of Apple mail sending email from the worng address EVEN AFTER making sure I've selected the correct 'send from' account. The problem occurs for both 1st time sent messages and replies. I'm running 10.8.2.

     

    In frustration, I downloaded Postbox (http://www.postbox-inc.com/) thinking a different email client would solve the problem. Unfortunately, I'm experiencing the same sent from the wrong address issue in Postbox as well.

     

    I now have to use webmail to ensure my emails are being sent from the correct address until this issue is resolved in the future.

  • m_Three Level 1 Level 1 (0 points)

    (POSSIBLE FIX to email problem)

     

    FYI All...

     

    I found this other forum and followed the instructions and so far it appears to have fixed the Apple Mail problem:

     

    http://forums.macrumors.com/showthread.php?t=1371261

     

    The user "eugenem" posted the solution.

     

    >> Quoted from: http://forums.macrumors.com/showthread.php?t=1371261

     

    I figured it out!

     

    Go into preferences and check the outgoing mail server for the address that you've having issues with. It will be shown as offline. Put a checkmark next to it where it says use only this server only. It will ask you to confirm the password for this account and take it back online.

     

    It seems that something happened and the outgoing server was taken offline so the mail client has been using other outgoing servers from other accounts to send your messages which is why the replies were going to the wrong place.

     

    Now that it's using the correct server and you're forcing it to use it, it should work just fine!

  • dodo0566 Level 1 Level 1 (0 points)

    It's not so easy, I have already double checked many time about it, and also together with the support of Apple. I have three different email and for everyone I have different outgoing SMTP and I have selected for everyone use only this, with trademark.

    I still think that is a bug from Apple, I was on Tel. with the Italian support and it happened also to him during talking with me. He promised me ( three months ago) to contact the Appe service in USA and resolve quickly ! The one who was on Tel. with me gave me his direct Tel. and e-mail, I have tried many times to contact him in these three months, but not replied. I think we have only to wait for the new release.

  • The Motherwell Level 1 Level 1 (10 points)

    I was able to fix my problem this way.  I had two gmail accounts, and it was always sending mail from the second account.  After deleting the outgoing server the issue was finally resolved. 

  • dodo0566 Level 1 Level 1 (0 points)

    I'm sorry yes you are right, my problem, like other people who use MAIL, is when you use the rules. If I receive an email and keep it in arrival post, I can reply with the same account, but if I use a rule and the email is moved in different folders, than when I use reply or forward, the program use the default email and not the one where I have received it. I hope it's clear.

  • DPBest Level 1 Level 1 (0 points)

    I'm having the exact same problem:

     

    Message arrives to accout B and a rule moves it to a folder.  A reply to that message is sent from account A, not account B to which is was originally sent. 

     

    This behavior was after upgrading to Mail 6.2 and it has nothing to do with the account setups regarding SMTP or POP or iMAP - it's a bug in Mail 6.2 - or if not a bug, a terrible change from previous version. 

     

    This needs to get fixed.  How does one get this bug across to Apple?

  • eburger Level 1 Level 1 (0 points)

    Please people, read the original post. It is ALL about what DPBest says here: messages moved out of the Inbox will only be sent from the default account, unless you manually select the outgoing accout to be what it is supposed to be. All versions of Mail.app until version 6.2 had the correct behavior of replying by default using the account the message originally arrived in.

     

    I do not know how the old versions of Mail.app did it, but I do know a little about Internet mail and mobile mail (see RFC 3458, RFC 3459, and IETF Lemonade Charter). There will almost always be a header that indicates the receiving mailbox, either in the To: header or one of the Received: headers. Since there are some corner cases where that won't fly, Apple can easily insert an X-apple-mailbox: or X-apple-received-from: header indicating from which accout the email arrived.

     

    Someone had to write code to break what worked in the past. It would be nice if the code got put back.

  • dodo0566 Level 1 Level 1 (0 points)

    I didn't have this problem till the new release of OS 6. I have contacted 3 months ago the Italian apple support, and they found the same problem during our telephone conversation. He promised me to contact the assistance in USA and to resolve it, but no news since that date.

  • floh@mac.com Level 1 Level 1 (0 points)

    The issue seems to be fixed with MacOS 10.8.3. At least on my system I don´t see the problem anymore with 10.8.3 and Mail 6.3. All replies are coming from the right account again.

  • dodo0566 Level 1 Level 1 (0 points)

    Yes you are right, finally it works in the right way. Thank you Apple.

  • Hugh Brown Level 1 Level 1 (65 points)

    This is the only thing that worked for me:

    https://discussions.apple.com/docs/DOC-4451

  • eburger Level 1 Level 1 (0 points)

    I did something similar. I have 17 inboxes under management by Mail.app. The best I could do is sort the INBOXes so that the most likely ones for me to send from are at the top or bottom of the list. That's a long way of saying the list in compose / reply comes from the order in the INBOX tray.

  • pen waters Level 1 Level 1 (0 points)

    I am having THIS EXACT PROBLEM.

    I have a professional email that I use to send and receive email for work and other purposes, and personal emails for everything else, which generally only receive email. I write, almost all of the time, from the one email. This was the way things had gone for years. Now, Mail is changing the account it is sending from, even after I disabled the other accounts, "broke" the SMTP information deliberately on the personal accounts and checked "use only this server" on every one of the accounts.

     

    Mail still switches the sending account, without my choosing it, completely arbitrarily. Last night I needed to send a professional email and I wake up this morning to find it has sent from my personal address,  WITH THE ACCOUNT INVISIBLE, DISABLED, NO LONGER AVAILABLE OR USEABLE TO ME FROM WITHIN MAIL, IT STILL SENT OUT THE MESSAGE FROM THAT ADDRESS. I am so disgusted. I had installed Opera and been using that browser for the personal email accounts. I am absolutely certain I was writing in Mail's window because of who I was writing to. I chose it deliberately.  IT STILL SENT FROM THE PERSONAL ACCOUNTS. They were not visible, nor enabled.

     

    The only solution I can see is what I've done now, delete those accounts entirely from Mail. When I looked at the list of SMTP servers, they were still in there, even with the accounts gone, so I took those out, too. I'll be deleting Mail entirely, even with the small problems with Opera, if it finds that old, deleted information somehow, somewhere else and continues to send from wrong  addresses. It has done this several times now, in spite of every fix I have tried, upending everything to try those fixes.

     

    I tried the link for the feedback, the webpage didn't show Mail, maybe no one wants to hear it.

     

    At any rate, Opera has some nice features Mail doesn't have. It's got a few annoying issues, but so far, hasn't sent out mail from any email address it chooses.

  • barereef Level 1 Level 1 (0 points)

    This issue is not fixed in 10.8.3.  It's amazing that it hasn't been addressed by Apple yet.