Previous 1 5 6 7 8 9 Next 129 Replies Latest reply: Dec 17, 2013 11:45 PM by vernes Go to original post Branched to a new discussion.
  • pvonk Level 6 (13,722 points)

    That's happening to me and a lot of others are reporting the same thing.  I suspect a server issue - wait a day and try again.

  • mrbofus Level 1 (5 points)

    I have been able to install app updates on both my iPhone and iPad today and yesterday with no issues. 

     

    That said, this issue of app updates not showing up despite the badge showing happens to me probably about once a week.  Force quitting the app always fixes it for me (double-tap the home button, tap and hold on the App Store icon, tap the minus sign, push the home button to go back to regular screen).

     

    If you are force quitting the app and upon re-opening it doesn't work, sometimes tapping on a different tab (like Search or Top Charts) and then going back to the Updates tab works too.

     

    If neither of those work, then as of right now, I don't have any alternate suggestions.  Good luck!

  • MattisonS Level 1 (0 points)

    I'm having the same issues, but this has not been chronic/historic...it has just been of late.  I am a "compulsive updater" so it bothers me. I have tried the methods you suggested and I will stay posted if there any additional pieces of advice anyone be able to give. Thanks for the insight...looking forward to a solution.

  • paultzirides Level 1 (0 points)

    The issue isn't that the App Store app is showing "No updates" but the badge shows that there are, it's that tapping on "Updates" in the App Store app brings up a completely blank page. Even when the app shows "No Updates", there is a not insignificant amount of data activity (indicated by the progress spinner in the top left near the carrier/wifi information). With the current behavior, the data transfer stops very quickly, only after a moment or two, and the page remains completely blank.

     

    The idea of going to "Purchased" apps and manually locating and updating apps is inconvenient and not optimal, but it works for the time being. That method will not work with iPhone apps, however. Those have to be searched for and updated manually using the App Store search interface.

     

    Strange problem, and, like many have mentioned, only started happening recently.

  • jsfiller Level 1 (0 points)

    I had the same problem and submitted a support request. I received the following:

     

     

    I understand that you App Store does not show your app updates. Please follow the steep below to help resolve the issue.

     

    1. Close All Apps on iPad: http://support.apple.com/kb/ht5137

     

    2. Sign out of iTunes & App Stores: Settings > iTunes & App Stores > Tap AppleID > Sign out

     

    3. Reset All Settings: Settings > General > Reset > Reset All Settings

     

    4. Reboot iPad

     

    5. Sign back into iTunes and App Stores: Settings > iTunes & App Stores > Sign In with AppleID

     

    I cannot say whether it works or not, because I don't have any apps that need to update at the moment. But I did it. We'll see if it works.

  • paultzirides Level 1 (0 points)

    It doesn't appear that this fixes anything. I still receive a blank screen instead of the expected "All Apps Are Up to Date". It was worth a shot. Interesting problem. It also appears that this doesn't have anything to do with the server, since my phone is able to update just fine.

  • petermaz Level 1 (10 points)

    Me Too! Just adding to the list. C'mon Apple, yer failing.

  • Mawkmw Level 1 (0 points)

    I called and spoke to someone all they could say was he had had several calls, told me to delete some apps that I may have installed with in the last day or so, and power off then back on.....it did nothing!  I have two iPads and both are doing the samething.....shows about 20 updates on app but when you go in nothing....

  • Muirlovin Level 1 (0 points)

    I pressed on the Updates button in the App Store and held it until the updates appeared. That's the only thing here that helped me. ,

  • joacampo Level 1 (0 points)

    Same here. I just ended up updating it via Itunes while my Ipad mini is connected to my computer. It's such a bummer.

  • sWo97 Level 1 (0 points)

    So I figured it out...at least for me. Tried just about everything too.

     

    Open all the apps that still have the "new" tag on it.

    Chances are one of those has to be updated.

     

    I had 7 updates...none showing and when I went through all the "new" tagged apps, opening them, the updates finally appeared and sure enough one of them was up for an update.

     

    Hope this helps.

  • lerbi Level 1 (0 points)

    That solved the problem for me.  Thanks.

  • j_fox99 Level 1 (0 points)

    Solved it for me too. Thanks for posting.

  • brent82 Level 1 (0 points)
  • mrbofus Level 1 (5 points)

    brent82 wrote:

     

    This cleared it up for me (it's really a SPOTLIGHT ISSUE): 

     

    http://www.ngpixel.com/2011/06/25/mac-app-store-you-have-updates-available-for-t he-other-accounts-bug/

     

    Are you saying that we should turn off the Applications indexing in Spotlight under Settings -> General -> Spotlight Search and then turn it back on?  Unless I missed it, the article you link to doesn't talk about that or the iOS App Store at all.

     

    This is an iPhone thread regarding the iOS App Store, not a Mac or OS X thread regarding the Mac App Store.  I already posted a solution/workaround that worked for me under iOS 6.  Under iOS 7, I haven't encountered this issue.

Previous 1 5 6 7 8 9 Next