Previous 1 2 3 4 Next 56 Replies Latest reply: Dec 25, 2015 8:42 AM by renee7819 Go to original post
  • KedarR Level 1 (0 points)

    Go to settings - iTunes & App Stores - tap on your Apple ID - view Apple ID - Turn off Genius for Apps.

    You should be able to update your apps now.

    To turn On Genius tap on the Genius tab.

  • sandeepgv Level 1 (0 points)

    I faced the Same Issue. It is resolved by changing the language at Settings-->General-->International-Language. Change the Current Language ( I have changed it from British English to English). Then after a succesful change, Go to Appstore- Updates. The Issue is resolved. Now go back to your original Setting (if required)

  • lingeringmind Level 1 (0 points)

    thanks, this worked for me.

  • jd2020 Level 1 (15 points)

    If changing language, signing out of iTunes, turning off Genius had not solved the blank update screen, a solution that worked for me is:

    1. Turn off automatice time setting
    2. Set the clock forward one year
    3. Check for app updates (get error)
    4. Correct the clock time/date
    5. Check for update and get them!

     

    Hat tip to SenseiPhone:

    http://senseiphone.com/app-store-loading-returned-white-blank-screen-10145364/

    The page lists a number of solutions, but the first one worked for me (after trying many in the Apple discussions).

  • MarcelaLima Level 1 (0 points)

    This worked perfectly for me! Thanks JoshuaS1998

  • wadey62 Level 1 (0 points)

    I haven't been able to update apps on my iPhone 5 for about a week now. I have tried everything that people have suggested but nothing works. My iPad is ok and running the same iOS (6.1.3) also my daughter hasn't any problems updating her phone.

     

    Have to say I had it with Apple. This phone is the worse phone I have ever owned. It has already been replaced for constantly shutting down and closing apps all the time and now this! I have searched these forums for an answer, but what stands out as clear as a sore thumb is not one person from Apple has commented. It is disgraceful. They market 'premium' products at premium prices, but no support or advice when things go wrong unless you ring or run off to the Apple store.

     

    In a way I am lucky that I only live 10 mins away from a store, though I have made so many visits over the last 3 months that I'm thinking of moving in!

     

    If anyone any suggestions that differ from ones already given, then please let me know. Thanks

  • mhallkc Level 1 (0 points)

    THANK YOU, JoshuaS1998!!!  Your simple answer did the trick for me!

  • summer-sailor Level 1 (0 points)

    I still have the white screen on app update -- and the number of updates keeps growing.  I cannot do the updates.  And it's on two ipads (an iPad 2 and a mini).  I've tried all the suggestions I could find:

    1. Turning off "Genius" did not work

    2. Going to Purchases and manually updating did not work (no updates listed)

    3. I switched International Languages from English to British English and back -- did not work

    4. I set the clock forward a year -- did not work

    5. I signed out of the App Store and then signed back in on the Purchases screen -- didn't work

    6. I am on the latest IOS v6.1.3.  Not working!

    All of these (unrelated?) solutions seem like non-sensical.  I've even faced the iPad to Redmond and chanted my Apple ID.  No luck.  Surely some wizard at Apple has figured out by now what the problem is, right? 

    This is totally annoying.  Any fix, would be greatly appreciated.

    Thanks to all in the Apple Community trying to help.

  • Mychilmao Level 1 (0 points)

    This happened to me with my iPad mini. I'm running the current iOS 6.1.3 software and I've tried all the tricks to fix the issue and nothing seems to work. I'm not sure if its just a bug with this software, an issue with my iPad or what, just know its highly frustrating and want it to be corrected.

  • Tink    Level 1 (0 points)

    I had the same issue on my ipad with version 6.1.3 and after trying everything that people wrote here, I still had the problem. I finally decided to go to Settings > General> Reset> Reset all settings. It doesn't delete your data it just seems to reset all the setting like wallpaper, etc. As of right now, it worked. I'm hoping that it doesn't resurface. Yes it's a pain to change all the settings the way I had them, but I don't have to stare at the 37 updates on the app store icon.

  • Phin11 Level 1 (0 points)

    The old hard reboot just worked for me. Power down the iPod and then turn it back on.

     

    Hold down the on/off switch until the bar appears "slide to turn off". Once the iPod is off, press the switch again to turn back on.

  • jdburgoyne Level 1 (0 points)

    Signing out and signing in to purchases didn't work. Still blank screen, and 3 updates on the badge. Wish Apple would address this. Very frustrating. The only work around that works is to go to purchased and click on update all the apps that show update.

  • mhallkc Level 1 (0 points)

    I guess I "spoke too soon" ..... the "fix" suggested by JoshuaS1998 worked for me exactly 2 times.  Then, the third time an update came out for an application, his fix no longer worked/works. :-(  I believe that the issue has to be on Apple's end, so I will wait it out for a while to see if they come up with a fix that works and is permanent.

  • summer-sailor Level 1 (0 points)

    An update to my post of two days ago.  Magically, both iPads (an iPad 2 and a mini) updated just fine this morning.  After I did the reboot, language change, sing-out-sign-in to the app store, bump the time by one year, turn off the Genius update, faced west towards Redmond and chanted my Apple ID, etc., etc, (over the last two days) and nothing worked ... it mystically worked this morning.  What changed between last night and this morning on my two un-used iPads?  Well, nothing changed here -- both iPads were idle.  So, I can only guess that the change was back in Redmond (we are all clients to their server).  Perhaps someone rebooted the Apple App Store authentication server or actually fixed some code on it.  I believe the problem was at Apple.  Since nearly all of the reported 'solutions' somehow involved the iPad being forced to re-authenticate to the App store (and it sometimes worked), this seems to my simple mind to have been the problem all along.

    Thank you, Apple, for the Magic.   8-)

  • anok goh Level 1 (0 points)

    turn off wifi. take out the sim card. reboot the the iPhone. turn on the wifi. go to ur app store... if u see everything is back to normal or working fine. put ur sim card in. and turn off wifi. and then reboot ur iPhone again... i fixed mine manually... no setting changes...